Quick question on the NX bottle heater. - LS1TECH

Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Nitrous Oxide
Sign in using an external account
Register Forgot Password?
Search


Nitrous Oxide
Installation | Tuning | Products


Quick question on the NX bottle heater.

Reply
 
Thread Tools Search this Thread
Old 07-19-2005, 03:37 PM   #1
10 Second Club
 
Captain InsaneO's Avatar
 
Trader Rating: 38
Join Date: Mar 2003
Location: Whiteland, Indiana
Posts: 584
Default Quick question on the NX bottle heater.

I am trying to test my bottle heater to make sure all the connections are fine. I have verified it to have power to the relay and to the pressure switch that mounts on the bottle. The grounds are fine etc.

My questions is should the bottle heater warm up even if its not connected to a bottle, or an empty bottle?

If so.. I might have a bad relay. The green wire that runs to the warmer its self is not getting any power.

Thanks.
__________________
Black '99 Z/28 (original owner)
Precision Engine and Machine Iron block 408, K1 Rods/Crank, Wiseco Pistons, Custom Grind Cam: 244/252 629/649 113, LandSpeed Stage 3 Dart heads, and Super Victor Jr. intake ported/polished, port matched, 200 shot of NX goodness. Vig 4000 stall, 9" rear.
A4 built by RPM Transmissions
750 RWHP 735 RWTQ

Captain InsaneO is offline   Reply With Quote
Old 07-19-2005, 05:42 PM   #2
TECH Enthusiast
 
2001 Red Coupe Bandit's Avatar
 
Trader Rating: 0
Join Date: Jul 2002
Location: Dallas, TX
Posts: 653
Default

Not sure, but I would Imagine that it SHOULD Work without a Bottle.

Someone will chime in to confirm though


Bandit.................
__________________
2001 Red Corvette Coupe, A4, Yank SS3600 TC, 3.42 Gears, Patriot Stage II 59 CC Heads, 228/.588/114LSA CAM, KOOKS LT Headers, KOOKS 3" Off Road X-Pipe/No Cats, Vortex Air Rammer, ZO6 Titanium Exhaust,Ported TB, NX 100 SDhot Dual Nozzle Wet Nitrous Kit. Best 1/4 mile 11.17 at 125 MPH Best 1/8 mile 7.15 at 95.55 MPH
2001 Red Coupe Bandit is offline   Reply With Quote
Old 07-19-2005, 05:58 PM   #3
10 Second Club
 
Captain InsaneO's Avatar
 
Trader Rating: 38
Join Date: Mar 2003
Location: Whiteland, Indiana
Posts: 584
Default

I got it, and yes it should work w/o a bottle hooked to it. I have a loose wire from the pressure solenoid to the relay..
__________________
Black '99 Z/28 (original owner)
Precision Engine and Machine Iron block 408, K1 Rods/Crank, Wiseco Pistons, Custom Grind Cam: 244/252 629/649 113, LandSpeed Stage 3 Dart heads, and Super Victor Jr. intake ported/polished, port matched, 200 shot of NX goodness. Vig 4000 stall, 9" rear.
A4 built by RPM Transmissions
750 RWHP 735 RWTQ

Captain InsaneO is offline   Reply With Quote
Old 07-19-2005, 05:58 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details