Anyone know what this is? - LS1TECH

Log In 


Northwest Members WA, OR, ID, MT, WY, SD, ND

Anyone know what this is?

Reply
 
Thread Tools Search this Thread
Old 04-14-2007, 12:15 AM   #1
On The Tree
Thread Starter
 
Lunchbox01_chris's Avatar
 
Join Date: Oct 2006
Location: ARLINGTON, WA
Posts: 157
Default Anyone know what this is?

I was at my apt complex and went over a speed bump a little faster than normal, and after my front wheels passed the speed bump and the car bounced, I heard a horrible noise, and this is all I saw... It may not even be from my car but who knows. Any help would be great. Every thing still works e-brake, reg brakes.. no leaks.. I dont know....RON I KNOW YOU HAVE SOMTHING TO SAY...
Attached Thumbnails
Anyone know what this is?-broken-transam-thing.jpg   Anyone know what this is?-broken-trans-am-thing2.jpg   Anyone know what this is?-broken-trans-am-thing3.jpg  
Lunchbox01_chris is offline   Reply With Quote
Old 04-14-2007, 12:16 AM   #2
On The Tree
iTrader: (5)
 
Black02Bird's Avatar
 
Join Date: Dec 2006
Location: Newport, NC (the Stix)
Posts: 193
Default

damn i been lookin for that
Black02Bird is offline   Reply With Quote
Old 04-14-2007, 12:17 AM   #3
On The Tree
iTrader: (5)
 
Black02Bird's Avatar
 
Join Date: Dec 2006
Location: Newport, NC (the Stix)
Posts: 193
Default

in all seriousness is that part of a spring from your clutch? i dunno i got an A4
Black02Bird is offline   Reply With Quote
Old 04-14-2007, 12:17 AM   #4
On The Tree
Thread Starter
 
Lunchbox01_chris's Avatar
 
Join Date: Oct 2006
Location: ARLINGTON, WA
Posts: 157
Default

Quote:
Originally Posted by Black02Bird
damn i been lookin for that
??? wHAT IS IT?
Lunchbox01_chris is offline   Reply With Quote
Old 04-14-2007, 12:18 AM   #5
TECH Addict
 
Poik's Avatar
 
Join Date: May 2004
Location: Bellingham/Edmonds, WA
Posts: 2,564
Default

Hood latch from another car? I don't know.
Poik is offline   Reply With Quote
Old 04-14-2007, 12:18 AM   #6
On The Tree
Thread Starter
 
Lunchbox01_chris's Avatar
 
Join Date: Oct 2006
Location: ARLINGTON, WA
Posts: 157
Default

Quote:
Originally Posted by Black02Bird
in all seriousness is that part of a spring from your clutch? i dunno i got an A4
Dont know if It is, but Clutch still works.
Lunchbox01_chris is offline   Reply With Quote
Old 04-14-2007, 12:19 AM   #7
On The Tree
Thread Starter
 
Lunchbox01_chris's Avatar
 
Join Date: Oct 2006
Location: ARLINGTON, WA
Posts: 157
Default

Quote:
Originally Posted by Poik
Hood latch from another car? I don't know.
maybe, but that noise sucked.. it sounded like somthing popping and shearing, and this is all I found at the scene of the crime.
Lunchbox01_chris is offline   Reply With Quote
Old 04-14-2007, 12:25 AM   #8
On The Tree
iTrader: (5)
 
Black02Bird's Avatar
 
Join Date: Dec 2006
Location: Newport, NC (the Stix)
Posts: 193
Default

popping and shearing like a clutch spring?
Black02Bird is offline   Reply With Quote
Old 04-14-2007, 12:57 AM   #9
On The Tree
Thread Starter
 
Lunchbox01_chris's Avatar
 
Join Date: Oct 2006
Location: ARLINGTON, WA
Posts: 157
Default

Quote:
Originally Posted by Black02Bird
popping and shearing like a clutch spring?
I dont know enough about clutches to know if thats what it was.. the clutch still works fine, and how would it pop out?
Lunchbox01_chris is offline   Reply With Quote
Old 04-14-2007, 03:16 AM   #10
11 Second Club
iTrader: (29)
 
EDS01SS's Avatar
 
Join Date: Jul 2003
Location: Hampton Virginia
Posts: 1,012
Default

Looks alot like an exhaust flange bolt and spring
EDS01SS is offline   Reply With Quote
Old 04-14-2007, 04:52 AM   #11
TECH Addict
iTrader: (4)
 
LSxChevelle's Avatar
 
Join Date: Feb 2002
Location: Enumclaw, WA
Posts: 2,566
Default

Doubt it's yours...
LSxChevelle is offline   Reply With Quote
Old 04-14-2007, 08:58 AM   #12
Pathological Modifier
iTrader: (11)
 
Ryan K's Avatar
 
Join Date: Jan 2002
Posts: 3,626
Default

Its not part of your car...
Ryan K is offline   Reply With Quote
Old 04-14-2007, 09:16 AM   #13
10 Second Club
iTrader: (8)
 
TwoFast4Lv's Avatar
 
Join Date: Nov 2001
Location: LT1 land...the "409" of the 90s!
Posts: 9,994
Default

Quote:
Originally Posted by Ryan K
Its not part of your car...
TwoFast4Lv is offline   Reply With Quote
Old 04-14-2007, 06:43 PM   #14
On The Tree
Thread Starter
 
Lunchbox01_chris's Avatar
 
Join Date: Oct 2006
Location: ARLINGTON, WA
Posts: 157
Default

sweet. On a totally different subject, whould changing your fuel filter help with power? I mean if its 110,000 miles old. Would u notice?
Lunchbox01_chris is offline   Reply With Quote
Old 04-14-2007, 07:55 PM   #15
TECH Fanatic
iTrader: (7)
 
Join Date: May 2003
Location: Topeka KS
Posts: 1,579
Default

Check your muffler bearing....might have lost one of those.
Ackattack1 is offline   Reply With Quote
Old 04-14-2007, 07:58 PM   #16
TECH Veteran
iTrader: (3)
 
Rottluver's Avatar
 
Join Date: Feb 2004
Location: Lynnwood, WA (North of Seattle)
Posts: 4,729
Default

Quote:
Originally Posted by Ackattack1
Check your muffler bearing....might have lost one of those.
Could that be the plug to the blinker fluid resivour <sp?> tank?
Rottluver is offline   Reply With Quote
Old 04-14-2007, 08:24 PM   #17
Launching!
 
Ram4384's Avatar
 
Join Date: Jan 2005
Location: WASHINGTON
Posts: 207
Default

chris i think u need to slow down going over speed bumps. do u think u are driving a lifted truck or something? lol I look at it last night and it looks like it goes to some type of cable. chris u should check ur muffler bearing like ackattack1 said. lol. dont know bro!!!!!!!!!!
Ram4384 is offline   Reply With Quote
Old 04-14-2007, 08:31 PM   #18
TECH Fanatic
iTrader: (8)
 
My1st Truck's Avatar
 
Join Date: Jan 2004
Location: B-town
Posts: 1,797
Default

I second the exhaust part...not from your car.
My1st Truck is offline   Reply With Quote
Old 04-14-2007, 08:35 PM   #19
TECH Apprentice
iTrader: (3)
 
Join Date: Jun 2002
Location: Spring, TX
Posts: 326
Default

Looks like an end of a cable that broke.
sunsetta is offline   Reply With Quote
Old 04-14-2007, 09:14 PM   #20
TECH Fanatic
iTrader: (7)
 
Join Date: May 2003
Location: Topeka KS
Posts: 1,579
Default

looking at it....for real this time I think its an antena base...like a CB or something.
Ackattack1 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:44 AM.