engine knock im lost - LS1TECH

Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > Pontiac Firebird 1967-2002
Sign in using an external account
Register Forgot Password?
Search


Pontiac Firebird 1967-2002 Birds of a feather flock together

engine knock im lost

Reply
 
Thread Tools Search this Thread
Old 06-04-2012, 06:46 PM   #1
Teching In
 
Trader Rating: 0
Join Date: Sep 2010
Posts: 25
Default engine knock im lost

ok im really in need of help here my 2002 ws6 is a daily driver and my wife is starting her new job soon so i cant drive hers to work anymore,
ok here goes
ive got a sound a code and loss of power and it shakes all through the pedal and shifter.
sound is like a rattle/knock this is in idle and speeds up with rpm
code is p0300
what i have done,
put 93 in it ( i ran 87 for a month or so bc of $)
pulled valve covers, springs, and everything there looks ok to me,
pulled plugs, 2 of them were extremely more worn than the others, i cant remember now which cylinders they were but i know they fire right after each other in the sequence,
so i replaced the plugs, and finnaly put my long tubes on that have been sitting in the garage for a year,
anyway started car up after everything was put back together and the sound is still there, drove it arround the block and noticed the lack of power,
so that is what i have done, please if some of you ls1 gods out there got something i can do, or if you know a thread that can point me in the right direction please let me know thanks in advance
thefridgews6 is offline   Reply With Quote
Old 06-05-2012, 05:35 PM   #2
Teching In
 
Trader Rating: 0
Join Date: Sep 2010
Posts: 25
Default

Bump for suggestions
thefridgews6 is offline   Reply With Quote
Old 06-05-2012, 05:50 PM   #3
TECH Fanatic
 
ghardester's Avatar
 
Trader Rating: 0
Join Date: Aug 2006
Location: Knappa, Oregon
Posts: 1,168
Default

P0300 is "Random multiple misfire."

Most likely causes, in my experience, are bad plugs and/or wires, or a blown coil.
__________________
2002 Navy Blue Metalic WS6 TA A-4. Born on 7-24-2002. I drive it every day.
ghardester is offline   Reply With Quote
Old 08-02-2012, 08:50 PM   #4
Staging Lane
 
white99ta!!'s Avatar
 
Trader Rating: 0
Join Date: Mar 2012
Location: Beaufort/ West Ashley, SC
Posts: 81
Default

Is their any of things wrong that your noticing? My p0300 was from my tci ssh 3600 stall. Could be plugs and wires.
white99ta!! is offline   Reply With Quote
Old 08-02-2012, 08:50 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
engine, firebird, knockinv, randomly, syarted


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 02:45 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details