Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > Pontiac Firebird 1967-2002
Sign in using an external account
Register Forgot Password?
Search

Pontiac Firebird 1967-2002 Birds of a feather flock together

Tail light problem

Reply
 
Thread Tools Search this Thread
Old 01-23-2007, 05:34 PM   #1
Staging Lane
 
TorchRedZ's Avatar
 
Trader Rating: 10
Join Date: Apr 2006
Location: Columbia SC
Posts: 71
Default Tail light problem

I was wondering if any of you other guys with had problems with one of your taillights being a lot more dim than the other. I changed all of the bulbs and it made no difference. Any help would be appreciated.
TorchRedZ is offline   Reply With Quote
Old 01-23-2007, 06:04 PM   #2
Teching In
 
kevin-557's Avatar
 
Trader Rating: 0
Join Date: May 2006
Location: Sonoma, California
Posts: 19
Default

I had a problem with mine, and it turned out to be a bad ground in the sockets. I'm not sure why GM went with the 3 wire system, but i ended up changing all the light sockets out in back with aftermarket and so far it has fixed the problem. The draw back is the replacement sockets are pricey, so double check that you may have the same issue. Good luck
kevin-557 is offline   Reply With Quote
Old 01-23-2007, 07:11 PM   #3
'Bird Director
 
y2k_ta's Avatar
 
Trader Rating: 80
Join Date: Dec 2001
Location: Central Indiana Honors: 4th grade spelling bee contestant
Posts: 12,586
Default

http://www.ls1tech.com/forums/showth...ing+taillights
__________________

www.car-art.us | car-art.us facebook | NMCA LSX #600 / OC #9500
1995 Firebird 4.8L Turbo Street/Strip Project | BUY IN GLASS
y2k_ta is offline   Reply With Quote
Old 01-23-2007, 09:27 PM   #4
Staging Lane
 
TorchRedZ's Avatar
 
Trader Rating: 10
Join Date: Apr 2006
Location: Columbia SC
Posts: 71
Default

Quote:
Originally Posted by y2k_ta
Thanks guys
TorchRedZ is offline   Reply With Quote
Old 01-23-2007, 11:42 PM   #5
Banned
 
Trader Rating: 1
Join Date: Jan 2007
Location: mississippi
Posts: 177
Send a message via AIM to sobaka79 Send a message via MSN to sobaka79 Send a message via Yahoo to sobaka79
Default

if its leaking water, it can get a film on the inside of it. my seal was broke and it held water, so i replaced it and np.
sobaka79 is offline   Reply With Quote
Old 01-23-2007, 11:42 PM   #6
Banned
 
Trader Rating: 1
Join Date: Jan 2007
Location: mississippi
Posts: 177
Send a message via AIM to sobaka79 Send a message via MSN to sobaka79 Send a message via Yahoo to sobaka79
Default

heh like the thread says =)
sobaka79 is offline   Reply With Quote
Old 01-24-2007, 05:44 PM   #7
11 Second Club
 
01badbird's Avatar
 
Trader Rating: 0
Join Date: May 2005
Location: ortonville,mi.
Posts: 344
Default

I had problem with 94 T/A ,I took a paperclip and shoved wire(clip) in the ground wire socket from back.If you have lights on you'll see it light up brighter when you insert wire.then cut off extra wire and seemed to work sold 2 years later.JUST A RIG NEED NEW SOCKETS
__________________
2001 TRANS AM WS6 LS1 -HPtuners,full bolt ons 12.39@109.05 MOTOR 11.38@119.78 W/100 SHOT The original smooth bay
01badbird is offline   Reply With Quote
Old 01-24-2007, 05:44 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 02:56 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details