Need 305 HELP. Can't get it to run right - LS1TECH

Go Back   LS1TECH > SBC-BBC-LT1-LT4 PERFORMANCE > Small Block & Big Block Chevy Specific
Log In 

Small Block & Big Block Chevy Specific Mouse & Rat Motor Discussion & Conversions

Need 305 HELP. Can't get it to run right

Thread Tools Search this Thread
Old 03-17-2012, 08:47 PM   #1
TECH Enthusiast
Fabian's Avatar
Trader Rating: 5
Join Date: Aug 2006
Location: Albuquerque, NM
Posts: 661
Default Need 305 HELP. Can't get it to run right

1982 Chevy G20 van with 305

I picked it up about a month ago. It had been sitting for 10 years so the fuel was obviously ****. So I got rid of the old fuel of course.

I have since installed new tires, a new QuadraJet, fuel pump (mechanical), plugs, wires, got rid of a **** ton of emissions and replaced the vacuum lines, air filter, timing chain with new cam gear and crank gear, I've played with the timing forward and back in degree increments and I installed a tach to make sure my idle and everything else is fine. Now before you point to the emissions, I only kept what I needed. Vacuum lines for the brake booster (bottom of carb), pcv line (top of carb), line to the distributor and the line to the tranny. Everything else is eliminated/capped off.

So onto the problem, it will idle fine but when I drive it it starts to stumble at about 30-35 mph sometimes to where it dies out. It starts bucking/surging. What the hell is causing this? I don't know what else to replace. I'm thinking the carb may just need to be tweaked but I dunno. I'm trying to get this thing going so I can stop working out of my Tahoe and use a proper vehicle for plumbing/hvac.

What else can be tried?
Fabian is offline   Reply With Quote
Old 03-19-2012, 06:24 AM   #2
Teching In
Trader Rating: 0
Join Date: Nov 2011
Location: Mid-MO
Posts: 13

Which Q-jet, electronic/computer carb or an older 'original'?

Did you check the mechanical advance in the Distributor?

Is it still the original ignition coil?

These are some of the more common issues that could be a problem.
CharlieB53 is offline   Reply With Quote
Old 03-20-2012, 09:57 PM   #3
TECH Addict
blk/slvr02ss's Avatar
Trader Rating: 21
Join Date: Dec 2006
Location: Port Saint Lucie,Florida
Posts: 2,773

Sounds like the Quadrabogger is not getting gas pumped threw it !
2008 CBR1000RR !!!
blk/slvr02ss is offline   Reply With Quote

1982, 305, 57, air, big, block, carburetor, chevy, filter, fuel, idle, quadrajet, run, small, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -5. The time now is 03:46 AM.