NA$TY Turbo TA - LS1TECH

Log In 


Staff Vehicles Showcase Check out the rides that belong to the LS1TECH Staff.

NA$TY Turbo TA

Reply
 
Thread Tools Search this Thread
Old 12-02-2006, 04:35 PM   #1
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default NA$TY Turbo TA

My 1998 Trans am was my 2nd TA.
My 1st TA was my 1st choice in Color and i loved it.
That was back when i was into more show then go...

She is Gone now

My 2nd TA and current car started out like everyone TA. STOCK
It was May of 2003.
My Brother Rob Found it for me in Kansas after i totaled my 1st TA.
Picked the car up with 26,xxx miles. Her only Mods were an MTI Lid and Edelbrock STB.






The 1st day started modding it.
A Hooker catback was waiting for me at my Bro's house.



After returning to TX, i started installing more parts that had arrived at my House.

Eibach Prokit.



A few days later the Bulk of my order i had been waiting weeks on arrived.
Comp Cams 212/218 camshaft, Comp 918 valvesprings, Comp pushrods, Jet-Hot Long Tube Header's, Hooker Off Road Y-pipe, TCI Super Street Fighter 3500 Stall Converter, Trans-go Tranny Cooler, and Nitto 245/50/16 Drag Radials.
The parts sat for a few weeks while i waited for my few days off from work to do the install and to drive to Houston to get the car tuned at MTI.
It was June 23rd.
The car dynoed 323 rwhp and 366 rwtq in 88 degree heat.... i was kinda bumbed on the HP, but the car drove one hell of alot better.

AUG 22 2003
Time for my 1st time at the track in the car.
Drove the car 90 miles each way to Edinburg, TX
1st pass. Foot Braking
1.842 60'
8.271 @ 83.695MPH 1/8
12.943 @ 106.032 1/4

Man was i stoked.... 1st pass and a 12 sec pass...
2nd Pass flashing Converter
1.747 60'
8.137 @ 83.959MPH 1/8
12.801 @ 106.118 1/4

3 more passes that night between 12.9-13.1 I was happy, but time to go faster.



Last edited by NA$TY-TA; 12-05-2009 at 11:06 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-05-2006, 03:44 PM   #2
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Man what a day...... I had never seen so many parts arrive on the same day...
ATI Procharger D1-SC 6 rib setup 4.10" Blower pulley.
iForged Aero's 18X9 Fronts and 18X10 Rears fully Polished.









Time to install them.












Last edited by NA$TY-TA; 12-17-2006 at 03:24 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-17-2006, 03:32 PM   #3
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

iForged Aero's Installed
265/35/18's Tires up front and 295/35/18's Out back












It was Now time to make the trip back to MTI to get the car tuned for the new found Boost from the ATI Procharger and the 42# Injectors.

SEP 2nd 2003
Arrived at MTI after being delaying for almost an HR in a horrible rain storm.
None the less i was ready to see what kind of Boost/Power the car was making.
After a few quick key stroked Jason had the car running in tip top shape. Time for some Dyno Pulls.
4 psi was all that we saw.
The car dynoed 377.7 rwhp and 416.8 rwtq.
After a quick call to ATI it was disclosed the pulley they sent (4.10") was sapposed to make 8-9 psi on a bone stock motor.
After arriving back home i quickley ordered a 3.7" Blower pulley and began to get ready to go to the track.

Last edited by NA$TY-TA; 12-05-2009 at 11:10 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-17-2006, 03:59 PM   #4
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

My 1st Time at the strip with the Blower.
It was a friday. OCT 24th 2003
My Friends and i arrived at San Antonio Raceway a little before 7pm.
At 708pm i was staged and ready to make my 1st pass.
It was against a BIG single Turboed Mustang.
Needless to say he won By almost 3 1/2 sec.
1st pass.
1.808 60'
7.49 @ 92.46 1/8
11.57 @ 121.79 1/4

Man was i happy even though i had just lost to a mid 8 sec. Mustang LOL
2nd pass
1.8006 60'
7.49 @ 91.89 1/8
11.59 @ 121.13 1/4

3rd Pass and Fastest of the Night
1.8264 60'
7.494 @ 96.82 1/8
11.512 @ 123.09 1/4
I was told to slow down or go Home because i didnt have a 5 point rollbar installed in the car.
I didnt want to pack up and go home so i slowed down.
I ran 2 more mid 11 sec passes that night and on the final pass i blew out the valve cover gasket on the pass. side and oiled down the top of the track.
Here is a lil vid my buddy put togeather from that night...
The music sucks though.... i think he just hit a Mix button
That was 11 psi on a stock Bottom end.
18" iForged wheels up front and 245/50/16 Nitto Drag radials out back.

Right click save as

http://itlxlr8.com/vids/NA$TY-TA.mpg

After that the car started to do the Ol smoke out of the Oil fill cap.
Until one night she decided it was time to go..... and man did she...
She was a lil lean up top...

4 of the 8 pistons had chunks missing but that is not what finally stopped the motor.
She blew a hole out the side of the motor between the heand and block.



BOOB








Time for a Forged Short Block.

Last edited by NA$TY-TA; 07-30-2007 at 02:41 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-17-2006, 04:35 PM   #5
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Since i needed a new Motor and a new Block i decided to go with an Iron Block.

I placed my Order for a Iron 370ci Motor from AP Engineering.
Diamond -15cc dish Pistons
Eagle H-beam Rods
Stock Crank
ARP Heads Studs, Main Studs and L-19 Rod Bolts.
Comp XER 230/236 .592/.602 114+4 Blower cam
Ported LS6 Oil Pump
Roomaster Timing chain.

The motor was brought to me at the 1st LS1 Tech Spring Break Shoot-out in San Antonio in April of 2004.
The Motor was installed in my garage by myself.


Motor in place with GM MLS gaskets and ARP 12 Point Head Studs.


I ordered a set of 6.0L 317 casting Heads from patriot performance with 2.02/1.57 valves, 72cc Chambers and patriot Gold valvesprings.


With the help of Nate @ Nasty Performance my new Fuel System would be up to task with my new found Cubic Inches and more boost.









Motron 60# Injectors


The new Motor was Broke in and it was time to re-install the Blower.
After the Blower was installed the car was trailered to MTI to be retuned.

After arriving at MTI it was found on the 1st atempted pull that the Car didnt have a MAF reading and the stock MAF was fried.
After replacing it the car had a Horrible belt alignment problem and was eating the Belt that fed the supercharger.
After 2 hrs in the parking lot at MTI with my Buddy's help we were able to fix the belt problem.
The car went back on the rollers were Jason began to Tune once again.
Half way thru the 1st pull Jason stopped the car and told me to come forward.
The low oil pressure light had come on. The car had below 5 psi of oil pressure.
We pushed the car off the dyno and began to push it on the trailer.
I said screw this heavy beast im driving it on. The motors already Hurt.
Once back home i contacted APE and quickley pulled the motor to send it back to them.
6 weeks later my warrantied shortblock arrived.
In it went and the break-in procedure started once again.
At that time i recieved a PM from (Tiffany) Z-Angel and was asked im i wanted to me in the 2005 LS1Tech Calander.
i quickley said YES.

Last edited by NA$TY-TA; 12-17-2006 at 05:22 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-17-2006, 04:43 PM   #6
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

I met up with Mctullis in San Marcus TX for my LS1Tech calender shoot.

The Pic's below are two of the pic's he took of the car.
The 2nd one of the two being the one that was chosen for the calendar.






The iForged wheels that were on the car before were sold to help offset the cost of a new Longblock.
So American racing Torque Thrust II's were chosen with 275/40/17 on 17X9.5's up front and 315/35/17's on 17x11's out back.






Last edited by NA$TY-TA; 12-05-2009 at 11:15 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-17-2006, 04:50 PM   #7
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

It was now time to remedy the Belt slip problem that had been ocuring.
So a Spring Tensioned 8 Rib Setup was ordered from SDCE. As was a new Steel J-bracket for more strength and less bracket flex.









May 28th 2004.
The car now needed to be retuned.
So Back to MTI the car went.
This time with the same 3.7" Blower pulley and a larger 7.25" 8 Rib crank Pulley.
The car saw 7 psi with the Built 370 and made
489.5rwhp and 502rwtq.



Back to Edinburg, TX for a few more passes at the strip.
Jul 3oth 2004
I went down with a couple friends mostly just to watch since i drove the 90 miles down in the car. No Trailer.
I made one pass and i new there was more in it.


After getting back home i was reading a fellow Buddy of mine on here's thread (FRCEFED98) about swapping to a bigger FMIC and ditching the small stick Intercoolers that came with the kit from ATI.
So i began to gather parts for the FMIC Install.

Last edited by NA$TY-TA; 12-17-2006 at 05:48 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-17-2006, 06:03 PM   #8
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Parts began to come in for the FMIC install.







After all the parts showed up the install began.
I went over to a buddy of mine who had a chop saw and a Mig welder.



The Blower bracket was made out of sguare stock from Home depot.














NA$TY-TA is offline   Reply With Quote
Old 12-17-2006, 08:51 PM   #9
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

The new motor was running just fine.... but now i had another problem...
The week link. The 4L60E and the stock 10 Bolt. I was on my 3rd set of gears and the tranny was now slipping at WOT.
Right about that time i recieved a Call From Chris @ AP Engineering aka (Jelly)
At that time he had taken care of my shortblock problem and was still a sponsor in good standings on LS1Tech.
He had offered me a price i couldnt refuse on a custom Turbo kit for my car, so off it went to Detroit.
Before it left i pulled the Blower kit off the car. and sold it for a very cheap $4200 shipped.

So the car was now in Detroit and Chris @ APE started another one of his Forged shortblock GP's. Amazing prices...... to good to be true...... 30+ orders for shortblocks were taken and none were delivered.
The shop had been siezed by the local Police and my car was stuck inside.
At the time i wanted to do an 88mm Turbo Build-up with a T56.
When my car was finally released from APE the car was in Horrible shape. It didnt run, my stock A4 was missing. My T56 was sitting in the hatch, my intake was sitting sideways under the hood with water all over it.
It was a mess.
Joe From Stenod Performance came to the rescue. He trailered my car from APE to his shop and started my Current Build.

It was decided that we would go with a Precision GT42-76mm Turbo. It is a T6 Flanged Turbo.
A little over a Month after Stenod received the car i started receiving progress pic's
With in that 1st month i received more updates then i did the whole 6 months my car was at APE.

20APR 2006
Piping had arrived.


Heads back from Livernois


5 JUL 2005
Radiator Support Cut and moved Forward.
AJE Tubular K-Member and A-Arms installed.


19 JUL 2005
Turbo Placement was decided.


1 AUG 2005
Both Headers are finished.

Last edited by NA$TY-TA; 12-18-2006 at 04:37 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-18-2006, 04:44 PM   #10
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

4 AUG 2005
24 update Pic's
http://itlxlr8.com/images/Car%20Buil...ug05%20update/







17 AUG 2005
4" Downpipe thru the K-member.




NA$TY-TA is offline   Reply With Quote
Old 12-18-2006, 04:56 PM   #11
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

8 SEP 2005
My motor was pulled so under the hood could be repainted.
While under the hood was being painted all the hot-parts were at the coaters getting coated.
I was asked.... since i had, had problems before with a motor from APE if i wanted to have Stenod pull the pan and just take a look.
This motor had almost 2500 miles on it.







Man was i bumbed..... 2 motors????
Since i was so Bumbed Stenod sent me these pic;s to try and cheer me up...







The choice was made to have a local Shop in Detroit do the rebuild.
They are not a sponsor on here so ill keep it at that. They do awsome work... the same people who did Harlans and kevin @ Stenod's Motor.



7 OCT 2005
Hot-parts back on the car


The interior of the car was gutted for my Custom 10 Point Cage.
NA$TY-TA is offline   Reply With Quote
Old 12-19-2006, 10:35 PM   #12
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

19OCT 2005
Stenod Performance Custom 10 Point Cage.
I wanted something different..... and thats what i got LOL











Nov 25th 2005
I flew to Detriot the day after Thanksgiving to see the progress on the car and hang out with Stenod, Derty, Harlan, and Kevin.
These are some of the pic's i took while i was there.....

Cage Done




Griffin radiator and SPAL 16" fan


My FMIC


Notched Frame


GMPP Carbed Intake drilled for Injectors


Precision Turbo 120 degree elbow and Accufab 90mmTB
NA$TY-TA is offline   Reply With Quote
Old 12-20-2006, 11:45 AM   #13
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

9 DEC 2005
Fuel system going in.








FMIC Mounted


Motor in for the final time.


Rossler Powerglide
NA$TY-TA is offline   Reply With Quote
Old 12-20-2006, 11:36 PM   #14
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

10 Jan 2006

4" all the way back.













10 Feb 2006











Last edited by NA$TY-TA; 12-22-2006 at 07:59 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-20-2006, 11:41 PM   #15
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

8-9 Mar 2006
Stenod was sending me randon close up pic's of the car..... it was almost complete and he was teasing me....










13 Mar 2006
She's ALIVE

http://itlxlr8.com/vids/kyle_gt42.wmv





SLEEPER?????

[img]




Last edited by NA$TY-TA; 12-20-2006 at 11:47 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-21-2006, 12:03 AM   #16
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

23 Jun 2006
The car is tuned and ready for some 1/4 passes.
Man 4 try's in a row and we got rained out.....
Not this time.

Slammed


The 1st Outing at the Track.
Learning the car and How it responds..


1st pass. 14 psi of Boost
Lazy 1.75 60'
7.4 @ 93.50 1/8
11.55 @ 120.6 1/4

2nd Pass
Car was lazy off the line and wouldnt make any Boost.
Compressor wheel had hit the Housing.


Well thats it for that Track Outing.


13 Jul 2006
Stenod Took Awsome care of me and so did Precision and another GT42-76mm turbo was back on the car and she was ready to hit the track again.




NA$TY-TA is offline   Reply With Quote
Old 12-21-2006, 12:25 AM   #17
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

18 Jul 2006

Milan










15 psi of boost.
10.80@126 mph.
Even adjusted more the car would not make more then 15 psi of Boost.
After some testing it was determined there was a huge amount of back pressure using this 76mm turbo with my 370ci motor.

Last edited by NA$TY-TA; 12-22-2006 at 07:46 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-22-2006, 07:52 PM   #18
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Some people dont think the above with a 76mm Turbo is true.....
but this below proves it.......

23 JUL 2006

My shake down Passes

http://itlxlr8.com/vids/kyle_shakedown_passes.wmv

S88 88mm Turbo was put in place of the GT42-76.
14 psi of Boost

1.474 60'
6.47 @ 107.89 1/8
10.07 @ 135.55 1/4

1 psi less boost then the GT42-76 passes and ran .7 tenths quicker @ 9 mph faster.....


2nd pass.... in the vid... it was the last pass..
tried 22 psi and spun the tires....

3rd pass... really 2nd pass of the day.

1.45 60'
6.055 @ 120.97 1/8
9.263 @ 150.50 1/4

Out of gear the last 150 ft.

Pic's from that day.











Last edited by NA$TY-TA; 07-03-2008 at 12:18 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-22-2006, 07:57 PM   #19
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

26 JUL 2006
She's Home in VA.
Coming off the Trailer...






1st day Home








Time for the street wheels and some new Fancy Fabricated valve Covers/ Catch-Can Setup from NA$TY Performance










Last edited by NA$TY-TA; 12-22-2006 at 08:10 PM.
NA$TY-TA is offline   Reply With Quote
Old 12-22-2006, 09:32 PM   #20
TECH Senior Member
Thread Starter
iTrader: (21)
 
NA$TY-TA's Avatar
 
Join Date: Aug 2002
Location: San Antonio, TX
Posts: 10,348
Default

Track Outing @ Richmond Dragway

In STREET Trim





I made 3 passes at our Track Rental and it started to Rain.

Back on our rain day @ Richmond Dragway.
Man this track is short... no shutdown...
This is the same Track Mightey Mouse crashed at.....
So i was on the brakes early on all these runs....
Still won my $$ back from the rental for winning the Quick 8




A fellow member on here ritz took these following pic's.... awsome work...
















I love these two...... Me vs C6 ZO6




The Vid.......

http://itlxlr8.com/vids/TWR%20Track%...%2010NOV06.wmv

Last edited by NA$TY-TA; 12-22-2006 at 09:39 PM.
NA$TY-TA is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Santa Does Like FI :) NA$TY-TA Forced Induction 53 12-31-2007 08:52 PM
My Track Star Wheels Finally Showed Up NA$TY-TA Drag Racing Tech 27 01-26-2007 03:29 PM
My Weld Aluma Stars Arrived Today NA$TY-TA Wheels & Tires 34 09-19-2006 10:42 AM
Mike Brown's Turbo Build Pics NA$TY-TA Forced Induction 58 08-04-2006 09:38 AM


Tags
aluma, american, bolts, mighty, mouse, naty, pro, racing, series, star, ta, titanium, trackstar, transam, turbo, wheels, wwwamericanracingproseriestrackstarcom

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 04:06 AM.