Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Stereo & Electronics
Sign in using an external account
Register Forgot Password?
Search

Stereo & Electronics Audio Components | Radars | Alarms

View Poll Results: Nice and clean?
A good job 13 100.00%
Looks like crap 0 0%
Voters: 13. You may not vote on this poll

Installed Subs and amp tell me what you think about install?

Reply
 
Thread Tools Search this Thread
Old 03-20-2011, 09:17 PM   #1
Teching In
Garage is empty, add now
 
Trader Rating: 4
Join Date: Aug 2004
Location: Ohio
Posts: 30
Post Installed Subs and amp tell me what you think about install?

Hello all here is my 99 trans am was wondering if you guys think i did a good job with my stereo install that i built. It is a built box for the t-top area and a amp rack for the amp with a trim piece to finish it out on the top. Took me about a week to build the whole setup after work every night. I think it turned out pretty good but was wondering what you all thought of it. The subs are rockford fosgate t1 12's and the amp is a memphis pr1.1000. Wow they sound great with this amp. There not even broke in yet but they are moving the hatch on some low bass over 1/2 inch. Well guess thats all i have to say just let me know how you guys think i did and and what you think. Thanks in advance, ramair1999@hotmail.com
Attached Thumbnails
Installed Subs and amp tell me what you think about install?-system1.jpg   Installed Subs and amp tell me what you think about install?-system2.jpg   Installed Subs and amp tell me what you think about install?-system3.jpg  

Last edited by bryankuhn; 03-21-2011 at 11:56 AM..
bryankuhn is offline   Reply With Quote
Old 03-20-2011, 10:08 PM   #2
TECH Apprentice
Garage is empty, add now
 
Trader Rating: 1
Join Date: Dec 2008
Location: Fuquay Varina, NC
Posts: 383
Default

Damn man nice job. That looks like a lot of work, seems to fit perfect though. I think it looks great, although I would probably cover up the white parts with more carpet like you have on the sides/middle. I'm sure it's insanely loud haha, I had two memphis 10's in the hatch with a box kinda like that with memphis amps but my **** got broke into and my amps along with other things were stolen. Had a shitty amp on them for a while then took them out, too much weight.
__________________
02 Camaro Z28 M6 - SLP intake, kooks LT's, kooks catted y, borla catback, custom tune, bilstein HD/strano shocks, strano springs, UMI lca relocation brackets, MGW short shifter, Tick MC

359 rwhp 376 ft lbs

The beater: 99 Nissan Altima GXE 5-speed
ncfastls1 is offline   Reply With Quote
Old 03-20-2011, 10:17 PM   #3
Teching In
Garage is empty, add now
 
Trader Rating: 0
Join Date: Mar 2010
Posts: 47
Default

Looks good bro.
LS9SkyRedline is offline   Reply With Quote
Old 03-21-2011, 08:50 PM   #4
LS1Tech Premium Sponsor
Garage is empty, add now
 
KEE AUDIO's Avatar
 
Trader Rating: 65
Join Date: Sep 2004
Location: Marietta, GA
Posts: 2,859
Default

Nice job man! Looks good.
__________________

KeeAudio.com
KEE AUDIO is offline   Reply With Quote
Old 03-21-2011, 11:10 PM   #5
TECH Addict
2000 Chevrolet Camaro
 
The Mighty Texan's Avatar
 
Trader Rating: 4
Join Date: Apr 2010
Location: Longview,TX & Tricitys,WA
Posts: 2,208
Default

Looking good man thats a very nice set up you got and looks like you did a clean job
__________________
2000 LPM Camaro z28
Lt, TSP ory, Moroso bullet, P&P TB, SLP lid & cai, B&M short shifter, Stage 2 clutch, BFG DRs, MSD Wires, NGK TR55, Frost Tune

The Mighty Texan is offline   Reply With Quote
Old 03-22-2011, 12:52 AM   #6
Launching!
Garage is empty, add now
 
bernarlitt's Avatar
 
Trader Rating: 11
Join Date: Mar 2010
Location: Moorhead,Ms
Posts: 206
Default

Quote:
Originally Posted by ncfastls1 View Post
Damn man nice job. That looks like a lot of work, seems to fit perfect though. I think it looks great, although I would probably cover up the white parts with more carpet like you have on the sides/middle. I'm sure it's insanely loud haha, I had two memphis 10's in the hatch with a box kinda like that with memphis amps but my **** got broke into and my amps along with other things were stolen. Had a shitty amp on them for a while then took them out, too much weight.
The white is showing to match his interior! LOOks BAD ***!!!! Nice Job. couldnt have done it any better my self
__________________
2000 Pontiac trans am WS6 Aka "King Kong"
"FEARLESS RACING"!
bernarlitt is offline   Reply With Quote
Old 03-22-2011, 07:14 AM   #7
TECH Fanatic
Garage is empty, add now
 
Trader Rating: 0
Join Date: Nov 2006
Posts: 1,273
Default

looks good only thing i would do different is flush mount the amp
pentavolvo is offline   Reply With Quote
Old 03-22-2011, 12:47 PM   #8
Teching In
Garage is empty, add now
 
Trader Rating: 4
Join Date: Aug 2004
Location: Ohio
Posts: 30
Default

Thanks everyone for the kind coments on my install. Yeah did the white that way it matched the white leather camaro seats i put in there couple years ago it matches perfect in person. Also the reason i didnt put the amp flush was because of the high rise trim pieces that go around the subs. The amp is pretty much level with them so they are the same height all the way across this way. Keep the coments coming guys love to hear what you all think i did on the setup.
bryankuhn is offline   Reply With Quote
Old 03-23-2011, 01:43 PM   #9
Banned
Garage is empty, add now
 
Trader Rating: 13
Join Date: Jan 2011
Location: Wisconsin
Posts: 335
Default

Aww come on you know it looks killer Nice job dude.
iWon is offline   Reply With Quote
Old 03-24-2011, 05:19 PM   #10
Teching In
Garage is empty, add now
 
Trader Rating: 4
Join Date: Aug 2004
Location: Ohio
Posts: 30
Default

Yeah i really think it turned out really nice for someone that has never built anything like this before. I use to have a complete stereo system that looked about like this done at a local audio shop that had a build to to the car that looked very good too but this was alot cheaper than that was and it looks almost as good. Thanks everyone for all the kind coments on my system. Just to let everyone know it wasnt very fun to make the box that goes into the t top area with the angles and stuff that had to be cut to get the biggest cubic feet needed for the subs but i got it done. Just wish i could of made a box to still use the t top storage part but since the subs needed this much space i had to do away with that. Guess i will put them in the back seat or leave them at home. Once again thanks everyone, ramair1999@hotmail.com
bryankuhn is offline   Reply With Quote
Old 03-24-2011, 05:19 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
12, 2011, amp, camaro, fosgate, install, installing, ls1tech, pictures, rack, rockford, subs, t1


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details