speaker help - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Stereo & Electronics
Log In 
Search


Stereo & Electronics Audio Components | Radars | Alarms


speaker help

Reply
 
Thread Tools Search this Thread
Old 12-24-2005, 11:49 AM   #1
Launching!
 
ckingcmaro's Avatar
 
Trader Rating: 0
Join Date: Dec 2005
Location: Athens, Alabama (North Alabama)
Posts: 281
Send a message via AIM to ckingcmaro
Default speaker help

Ok I have a 2001 SS Camaro, with the Monsoon Stereo System. All of my speakers are working, Except the mid speakers (beside the buckets in the back). There is no power getting to the speakers but both of the speakers are in good condition. I beleive it is the amp that has gone out or something. Could you guys give me your opinion, and a solution to the problem, I would really like to keep the monsoon sound system..

Thanks, Caleb
ckingcmaro is offline   Reply With Quote
Old 12-25-2005, 02:03 PM   #2
TECH Fanatic
 
Rescue Ranger's Avatar
 
Trader Rating: 10
Join Date: Jan 2005
Location: NH
Posts: 1,264
Default

No power to the speakers at all?

hehe.. not to be condescending, but they're not faded out on the HU are they

If it is the monsoon amp that is fried, there are used ones that pop up on the FS section and sometimes on eBay also.

Used sail panel speakers go for 50-60$ typically too used if for some reason it was the speakers.
Rescue Ranger is offline   Reply With Quote
Old 12-25-2005, 02:24 PM   #3
Staging Lane
 
Don B 02 Z28's Avatar
 
Trader Rating: 3
Join Date: Aug 2004
Location: Savannah, Ga
Posts: 75
Send a message via Yahoo to Don B 02 Z28
Default

Good advice, Ranger...I just repl. all of the Monsoon 2 ohm speakers(mainly, due to one of the door spks. being blown) including, the 4in hatch spks., in my Z28. In favor of, a JBL 4 ohm(70w rms/270 peak) speaker system(uitilizing the Monsoon amp to some degree) to go w/ the Pioneer AM/FM/XM HU.

Soooooo, now the Monsoons are on the f/s block and I had no idea what they were worth.

Hey, can you tell me if, the rear seat speaker are ones w/ the double set of connectors or the single set of connections???

Thanks,
Don
__________________
Silver '02 35th Ann'y T-Top Z28(A4) SS Hood, Mac Headers, Borba cat-back, BFG g-force 275-40/17 on ROH wheels w/ Tuning by Vengeance Racing

'04 Southern Comfort Vindicator SS Silverado C1500 w/ 285/60-18 BFG KDW g-Force(N/T) tires
Don B 02 Z28 is offline   Reply With Quote
Old 12-25-2005, 07:09 PM   #4
Launching!
 
ckingcmaro's Avatar
 
Trader Rating: 0
Join Date: Dec 2005
Location: Athens, Alabama (North Alabama)
Posts: 281
Send a message via AIM to ckingcmaro
Default

I think single?? (only 2 wires)
ckingcmaro is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details