Security Light On while driving? What gives? - LS1TECH

Log In 


Stereo & Electronics Audio Components | Radars | Alarms

Security Light On while driving? What gives?

Reply
 
Thread Tools Search this Thread
Old 01-07-2007, 01:07 AM   #1
On The Tree
Thread Starter
 
Join Date: Mar 2004
Location: San Fernando, CA
Posts: 177
Exclamation Security Light On while driving? What gives?

I own a 1998 Z28 camaro automatic. I went to the store tonight and when I started my car to leave, my security light stays on while all the other lights go off. The car starts perfect everytime and I cleaned the key with rubbing alcohol, but not the key insert yet. I even tried my new spare key and the car starts, but the light stays on. What should I do? Should I disconnect the battery or clean out the ignition hole with rubbing alcohol? Any help from fellow LS1 members would help!

I would hate to drive all day & night with the damn security light on or get raped at the dealer. Thanks everyone for looking at this and have a goodnight. Sam
MasterOfPuppets is offline   Reply With Quote
Old 01-07-2007, 01:14 AM   #2
TECH Fanatic
iTrader: (10)
 
JacobK's Avatar
 
Join Date: Mar 2004
Location: Hodgkins, IL
Posts: 1,962
Default

mine is doing the EXACT same thing..i have been driving with my light on for the past week and its been fine..
JacobK is offline   Reply With Quote
Old 01-09-2007, 01:14 AM   #3
On The Tree
Thread Starter
 
Join Date: Mar 2004
Location: San Fernando, CA
Posts: 177
Default

Quote:
Originally Posted by JacobK
mine is doing the EXACT same thing..i have been driving with my light on for the past week and its been fine..
I guess we are on our own on this one. I guess I'll do the old trailer park method of fixing the problem, I'll put a SLP or Hooker headers sticker over the light on the dash! LoL No light, No problem!
MasterOfPuppets is offline   Reply With Quote
Old 01-09-2007, 02:03 AM   #4
TECH Fanatic
iTrader: (10)
 
JacobK's Avatar
 
Join Date: Mar 2004
Location: Hodgkins, IL
Posts: 1,962
Default

haha..
JacobK is offline   Reply With Quote
Old 01-09-2007, 02:45 AM   #5
TECH Addict
iTrader: (6)
 
Join Date: Nov 2001
Location: Tampa, Florida
Posts: 2,082
Angry

Mine's been on for over almost 2 years
The Dragon is offline   Reply With Quote
Old 01-10-2007, 12:26 AM   #6
bcs
Staging Lane
 
Join Date: Aug 2003
Posts: 82
Default

Almost a year for me..
bcs is offline   Reply With Quote
Old 01-10-2007, 02:42 AM   #7
On The Tree
 
Join Date: Mar 2006
Posts: 115
Default

I had that happen on my Camaro SS a couple of years ago. I would be driving an the security light would come on. I took it to the dealership a wire from the ignition switch was shorted. Dealership put a new ignition switch in for free thanks to my GMPP warrantry.
DavidH426 is offline   Reply With Quote
Old 01-10-2007, 02:59 AM   #8
hashtagBMW
iTrader: (38)
 
Speed Density's Avatar
 
Join Date: Jul 2005
Location: Boise, Idaho
Posts: 6,571
Default

My 93' Does the same thing, to bad 14yrs isnt on the warranty plan.

Tony.
Speed Density is offline   Reply With Quote
Old 01-10-2007, 03:13 AM   #9
12 Second Club
iTrader: (7)
 
razorclaw99's Avatar
 
Join Date: Oct 2006
Location: nj
Posts: 1,230
Default

im a bit different. Sometimes my security light would go on after i shut the car off and then i wouldnt be able to start it. How do you turn that off. I have no keyless entry. I use the key to open and the door to lock.
razorclaw99 is offline   Reply With Quote
Old 01-10-2007, 05:43 AM   #10
TECH Addict
iTrader: (6)
 
Join Date: Nov 2001
Location: Tampa, Florida
Posts: 2,082
Unhappy

Quote:
Originally Posted by DavidH426
I had that happen on my Camaro SS a couple of years ago. I would be driving an the security light would come on. I took it to the dealership a wire from the ignition switch was shorted. Dealership put a new ignition switch in for free thanks to my GMPP warrantry.
Damn. I wished I would have known this 2 years ago.

I had my ignition switch replaced under warranty . . . guess they screwed up the "switch"
The Dragon is offline   Reply With Quote
Old 01-10-2007, 11:54 PM   #11
On The Tree
Thread Starter
 
Join Date: Mar 2004
Location: San Fernando, CA
Posts: 177
Default

Quote:
Originally Posted by Speed Density
My 93' Does the same thing, to bad 14yrs isnt on the warranty plan.

Tony.
Tell me about it! I guess I'm going to go ahead with the sticker mod. LoL
MasterOfPuppets is offline   Reply With Quote
Old 01-13-2007, 05:08 PM   #12
10 Second Sleeper Club
iTrader: (4)
 
jitsumania's Avatar
 
Join Date: Aug 2005
Location: Victoria, Texas
Posts: 237
Default

Had this happen about a week ago also. I also have an annoying two honk thing goin on after the two chirps when keyless is enabled. Tried reprogramming the security system again with no success. Dam ignition switch is expensive cause I had it replaced about a year ago.
Somebody has got to have a solution !?!?!?!?!?!?!?!?!?!?!?!?!?
jitsumania is offline   Reply With Quote
Old 01-13-2007, 05:18 PM   #13
Teching In
 
Join Date: Jan 2007
Location: AZ!
Posts: 15
Default

when the light comes on when your driving it means your VATS is f'ed up...change the key out with your spare, or get a new one made...also if you disconnect the alarm in the kick panel on the passanger side that could asl oreset it...
camm3d&slamm3d is offline   Reply With Quote
Old 04-12-2007, 12:23 AM   #14
TECH Enthusiast
 
2001FireBird's Avatar
 
Join Date: May 2004
Location: San Jose, NorCal
Posts: 710
Default

Damn it. Mine just came on recently. I have an aftermarket alarm with remote start but this was never a problem until now, 3 years later. Car still runs fine and starts everytime but that light annoys me. I tried using the spare and cleaning the keys and the ignition with rubbing alcohol but no luck.

Camm3d - how do I disconnect the alarm in the kick panel? BTW, my car didnt come with keyless entry.
2001FireBird is offline   Reply With Quote
Old 04-12-2007, 07:41 AM   #15
Ungrounded Director
iTrader: (4)
 
WhiteBird00's Avatar
 
Join Date: Nov 2003
Location: Jacksonville, FL
Posts: 9,030
Default

Quote:
Originally Posted by 2001FireBird
Damn it. Mine just came on recently. I have an aftermarket alarm with remote start but this was never a problem until now, 3 years later. Car still runs fine and starts everytime but that light annoys me. I tried using the spare and cleaning the keys and the ignition with rubbing alcohol but no luck.

Camm3d - how do I disconnect the alarm in the kick panel? BTW, my car didnt come with keyless entry.
If you don't have keyless entry then you don't have the factory alarm ("the alarm in the kick panel"). Keyless entry was a requirement for the alarm system.

If you did have it then you can't disconnect it because it's built-in to the BCM but you can disable it by programming it off.
WhiteBird00 is offline   Reply With Quote
Old 04-13-2007, 06:49 AM   #16
TECH Regular
iTrader: (2)
 
*98Formula*'s Avatar
 
Join Date: Sep 2003
Posts: 405
Default

Mine just started doing this **** a few days ago as well. I dropped my key in a puddle of Oil so that maybe what is causing mine. I'm going to try cleaning it tonight. Mine will randomly turn off through. Sometimes it stays on awhile other times it comes on and then goes back off about a minute later. I don't know WTF is going on with this damned thing.
*98Formula* is offline   Reply With Quote
Old 04-13-2007, 11:31 AM   #17
On The Tree
iTrader: (4)
 
Join Date: Mar 2007
Location: Tenneessee
Posts: 126
Default

Damn and i thought i was the only one. But i got you guys beat....my security light comes on and the check engine soon light won't go off. I keep having it turned of my mechanics and the F'n thing just keeps coming back on! Stupid computers!
xddesign26 is offline   Reply With Quote
Old 04-13-2007, 05:03 PM   #18
TECH Addict
iTrader: (37)
 
Gun5's Avatar
 
Join Date: Feb 2006
Location: Tomball (H-Town), TX
Posts: 2,715
Default

if u have more then 3-4 keys on ur thing that will do it (the weight and it hanging) mine did it for awhile and i found out what it was
Gun5 is offline   Reply With Quote
Old 04-14-2007, 05:33 PM   #19
TECH Enthusiast
 
2001FireBird's Avatar
 
Join Date: May 2004
Location: San Jose, NorCal
Posts: 710
Default

Hmm. I'm going to try that Gun . But wahts wierd is I've had the same number of keys since high school and only recently has the security light given me a problem.

Thanks whitebird00 for the information. I'll try using more contact cleaner and clean the ignition and the resistor on the key.
2001FireBird is offline   Reply With Quote
Old 07-17-2007, 11:59 AM   #20
Staging Lane
 
99 H.O.S.S.'s Avatar
 
Join Date: Jul 2007
Location: Kansas City, MO
Posts: 51
Default

Mine been on for a month now, but I found this page on the net that might help yes. I just haven't had time to try it.

http://www.ls1.com/forums/showthread.php?t=9270

you might have to copy and paste it
99 H.O.S.S. is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
car is slow to turn over mezzoni General Maintenance & Repairs 15 02-13-2016 10:35 AM
Help Car won't start - Security Light randytj General Maintenance & Repairs 8 07-28-2010 06:40 PM
Passkey 3 system questions Syclone354 Cadillac CTS-V 2004-2007 (Gen I) 3 11-04-2009 10:43 AM
Car won't start, SECURITY lights stays on with key on tripps Generation III External Engine 29 09-25-2007 12:28 PM
Car will not start turn over, Security Light is on Mr.BigE General Maintenance & Repairs 20 06-21-2005 10:48 AM


Tags
1998, 1999, 2003, 96, 98, camaro, car, chevy, driving, formula, light, reprogramming, security, silverado, stays, z28

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:04 AM.