Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Stereo & Electronics
Sign in using an external account
Register Forgot Password?
Search

Stereo & Electronics Audio Components | Radars | Alarms

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 01-07-2007, 01:07 AM   #1
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Mar 2004
Location: San Fernando, CA
Posts: 185
Exclamation Security Light On while driving? What gives?

I own a 1998 Z28 camaro automatic. I went to the store tonight and when I started my car to leave, my security light stays on while all the other lights go off. The car starts perfect everytime and I cleaned the key with rubbing alcohol, but not the key insert yet. I even tried my new spare key and the car starts, but the light stays on. What should I do? Should I disconnect the battery or clean out the ignition hole with rubbing alcohol? Any help from fellow LS1 members would help!

I would hate to drive all day & night with the damn security light on or get raped at the dealer. Thanks everyone for looking at this and have a goodnight. Sam
MasterOfPuppets is offline   Reply With Quote
Old 01-07-2007, 01:14 AM   #2
TECH Fanatic
Garage is empty, add now
 
JacobK's Avatar
 
Trader Rating: 10
Join Date: Mar 2004
Location: Hodgkins, IL
Posts: 1,960
Send a message via AIM to JacobK
Default

mine is doing the EXACT same thing..i have been driving with my light on for the past week and its been fine..
__________________
1999 Black SS..M6 with bolt-ons and a "baby" cam
JacobK is online now   Reply With Quote
Old 01-09-2007, 01:14 AM   #3
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Mar 2004
Location: San Fernando, CA
Posts: 185
Default

Quote:
Originally Posted by JacobK
mine is doing the EXACT same thing..i have been driving with my light on for the past week and its been fine..
I guess we are on our own on this one. I guess I'll do the old trailer park method of fixing the problem, I'll put a SLP or Hooker headers sticker over the light on the dash! LoL No light, No problem!
MasterOfPuppets is offline   Reply With Quote
Old 01-09-2007, 02:03 AM   #4
TECH Fanatic
Garage is empty, add now
 
JacobK's Avatar
 
Trader Rating: 10
Join Date: Mar 2004
Location: Hodgkins, IL
Posts: 1,960
Send a message via AIM to JacobK
Default

haha..
__________________
1999 Black SS..M6 with bolt-ons and a "baby" cam
JacobK is online now   Reply With Quote
Old 01-09-2007, 02:45 AM   #5
TECH Addict
Garage is empty, add now
 
Trader Rating: 6
Join Date: Nov 2001
Location: Tampa, Florida
Posts: 2,006
Angry

Mine's been on for over almost 2 years
__________________
BLACK/PEARL BLUE-METALLIC '01 TA FIREHAWK Aluminum 402/ LS2, HRE 567R, Bilstein, Recaro Leather/CUSTOM Suede Seats.
Ported L92 Heads, 239/251 .624 .624, Ported FAST LSXR 102, NW 102 TB, 104Lid, Kooks Coated 1 7/8", Kooks 3" true-duals with 4" Tips, Spec 2+ Clutch, D&D tranny, CLSD, UMI Tubular K-member/Torque arm/A-arms/control arms/ etc. Complete Custom Interior.
The Dragon is offline   Reply With Quote
Old 01-10-2007, 12:26 AM   #6
bcs
Staging Lane
Garage is empty, add now
 
Trader Rating: 0
Join Date: Aug 2003
Posts: 82
Default

Almost a year for me..
__________________
96 Black Impala
MTI 396 with n20

01 SOM TA
Boltons

01 pew SS
Boltons
bcs is offline   Reply With Quote
Old 01-10-2007, 02:42 AM   #7
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Mar 2006
Posts: 115
Default

I had that happen on my Camaro SS a couple of years ago. I would be driving an the security light would come on. I took it to the dealership a wire from the ignition switch was shorted. Dealership put a new ignition switch in for free thanks to my GMPP warrantry.
__________________
2002 T/A Firehawk Convertible #814 NBM/Taupe 6-speed all GM/SLP Options.
2001 T/A Firehawk #301 1LE NBM/Taupe 6-speed all GM/SLP Options.
2000 Camaro SS #3492 NBM/Neutral Leather 6-speed all GM/SLP Options.
2009 Chevrolet Silverado HD 3500 LTZ Extended Cab Long Bed Dually 2WD Duramax Diesel Blue Granite Metallic Light/Dark Titanium all options.
CMS!
Zaino only!
DavidH426 is offline   Reply With Quote
Old 01-10-2007, 02:59 AM   #8
hashtagBMW
Garage is empty, add now
 
Speed Density's Avatar
 
Trader Rating: 38
Join Date: Jul 2005
Location: Boise, Idaho
Posts: 6,569
Default

My 93' Does the same thing, to bad 14yrs isnt on the warranty plan.

Tony.
__________________
Speed Density is offline   Reply With Quote
Old 01-10-2007, 03:13 AM   #9
12 Second Club
Garage is empty, add now
 
razorclaw99's Avatar
 
Trader Rating: 7
Join Date: Oct 2006
Location: nj
Posts: 1,231
Send a message via AIM to razorclaw99
Default

im a bit different. Sometimes my security light would go on after i shut the car off and then i wouldnt be able to start it. How do you turn that off. I have no keyless entry. I use the key to open and the door to lock.
__________________
razorclaw99 is offline   Reply With Quote
Old 01-10-2007, 05:43 AM   #10
TECH Addict
Garage is empty, add now
 
Trader Rating: 6
Join Date: Nov 2001
Location: Tampa, Florida
Posts: 2,006
Unhappy

Quote:
Originally Posted by DavidH426
I had that happen on my Camaro SS a couple of years ago. I would be driving an the security light would come on. I took it to the dealership a wire from the ignition switch was shorted. Dealership put a new ignition switch in for free thanks to my GMPP warrantry.
Damn. I wished I would have known this 2 years ago.

I had my ignition switch replaced under warranty . . . guess they screwed up the "switch"
__________________
BLACK/PEARL BLUE-METALLIC '01 TA FIREHAWK Aluminum 402/ LS2, HRE 567R, Bilstein, Recaro Leather/CUSTOM Suede Seats.
Ported L92 Heads, 239/251 .624 .624, Ported FAST LSXR 102, NW 102 TB, 104Lid, Kooks Coated 1 7/8", Kooks 3" true-duals with 4" Tips, Spec 2+ Clutch, D&D tranny, CLSD, UMI Tubular K-member/Torque arm/A-arms/control arms/ etc. Complete Custom Interior.
The Dragon is offline   Reply With Quote
Old 01-10-2007, 11:54 PM   #11
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Mar 2004
Location: San Fernando, CA
Posts: 185
Default

Quote:
Originally Posted by Speed Density
My 93' Does the same thing, to bad 14yrs isnt on the warranty plan.

Tony.
Tell me about it! I guess I'm going to go ahead with the sticker mod. LoL
MasterOfPuppets is offline   Reply With Quote
Old 01-13-2007, 05:08 PM   #12
10 Second Sleeper Club
Garage is empty, add now
 
jitsumania's Avatar
 
Trader Rating: 4
Join Date: Aug 2005
Location: Victoria, Texas
Posts: 237
Send a message via Yahoo to jitsumania
Default

Had this happen about a week ago also. I also have an annoying two honk thing goin on after the two chirps when keyless is enabled. Tried reprogramming the security system again with no success. Dam ignition switch is expensive cause I had it replaced about a year ago.
Somebody has got to have a solution !?!?!?!?!?!?!?!?!?!?!?!?!?
__________________

11 Second NA Killer....well maybe a little giggle juice for those 10 sec moments!!!Get in, sit down, strap up, hold on and enjoy the blur.
10 and low 11 runs: http://www.youtube.com/watch?v=wVCk2uzX00I
See my Ride and all the MODS at: http://www.cardomain.com/ride/2096333
jitsumania is offline   Reply With Quote
Old 01-13-2007, 05:18 PM   #13
Teching In
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jan 2007
Location: AZ!
Posts: 15
Send a message via AIM to camm3d&slamm3d
Default

when the light comes on when your driving it means your VATS is f'ed up...change the key out with your spare, or get a new one made...also if you disconnect the alarm in the kick panel on the passanger side that could asl oreset it...
__________________
'99 camaro SS M6 | 230/237 .598/.598 111lsa | hooker headers | TSP ORY | magnaflow cat-back | k&n | !CAGS | SPEC STG 3 |





camm3d&slamm3d is offline   Reply With Quote
Old 04-12-2007, 12:23 AM   #14
TECH Enthusiast
Garage is empty, add now
 
2001FireBird's Avatar
 
Trader Rating: 0
Join Date: May 2004
Location: San Jose, NorCal
Posts: 713
Send a message via AIM to 2001FireBird
Default

Damn it. Mine just came on recently. I have an aftermarket alarm with remote start but this was never a problem until now, 3 years later. Car still runs fine and starts everytime but that light annoys me. I tried using the spare and cleaning the keys and the ignition with rubbing alcohol but no luck.

Camm3d - how do I disconnect the alarm in the kick panel? BTW, my car didnt come with keyless entry.
__________________
2001FireBird is offline   Reply With Quote
Old 04-12-2007, 07:41 AM   #15
Ungrounded Director
Garage is empty, add now
 
WhiteBird00's Avatar
 
Trader Rating: 4
Join Date: Nov 2003
Location: Jacksonville, FL
Posts: 8,401
Default

Quote:
Originally Posted by 2001FireBird
Damn it. Mine just came on recently. I have an aftermarket alarm with remote start but this was never a problem until now, 3 years later. Car still runs fine and starts everytime but that light annoys me. I tried using the spare and cleaning the keys and the ignition with rubbing alcohol but no luck.

Camm3d - how do I disconnect the alarm in the kick panel? BTW, my car didnt come with keyless entry.
If you don't have keyless entry then you don't have the factory alarm ("the alarm in the kick panel"). Keyless entry was a requirement for the alarm system.

If you did have it then you can't disconnect it because it's built-in to the BCM but you can disable it by programming it off.
__________________
White 2000 Trans Am (sold)
White 2011 Mustang Convertible

Please DO NOT send PMs for questions that can be answered in the forums!
WhiteBird00 is offline   Reply With Quote
Old 04-13-2007, 06:49 AM   #16
TECH Regular
Garage is empty, add now
 
*98Formula*'s Avatar
 
Trader Rating: 2
Join Date: Sep 2003
Posts: 405
Default

Mine just started doing this **** a few days ago as well. I dropped my key in a puddle of Oil so that maybe what is causing mine. I'm going to try cleaning it tonight. Mine will randomly turn off through. Sometimes it stays on awhile other times it comes on and then goes back off about a minute later. I don't know WTF is going on with this damned thing.
__________________
Check out my Garage --> www.fquick.com/*98formula*
1998 Formula M6 from A4 FTRA, Ported LS1 heads, LS6 Intake, PaceSetter LT, Catted - Y, Hooker Catback, 3.73 gears, LID, and UD pulley.

From the SVT Forum: "Okay, who fucked up and told the LS1 guys about KB?"
*98Formula* is offline   Reply With Quote
Old 04-13-2007, 11:31 AM   #17
On The Tree
Garage is empty, add now
 
Trader Rating: 4
Join Date: Mar 2007
Location: Tenneessee
Posts: 126
Send a message via Yahoo to xddesign26
Default

Damn and i thought i was the only one. But i got you guys beat....my security light comes on and the check engine soon light won't go off. I keep having it turned of my mechanics and the F'n thing just keeps coming back on! Stupid computers!
xddesign26 is offline   Reply With Quote
Old 04-13-2007, 05:03 PM   #18
TECH Addict
Garage is empty, add now
 
Gun5's Avatar
 
Trader Rating: 35
Join Date: Feb 2006
Location: Waco (254), Texas
Posts: 2,711
Send a message via AIM to Gun5
Default

if u have more then 3-4 keys on ur thing that will do it (the weight and it hanging) mine did it for awhile and i found out what it was
__________________
2010 Camaro SS 2LT 6-Speed, 3" Drop... Murdered Completely
2003 Terminator HHP Tuning Twin Turbo's
2003 Terminator 2.8 upper 4 lower.. 450hp 480tq Sold
2006 ZX6-R Ninja 636 SE Sold
2000 Camaro Z28 H/C/I 455rwhp/412tq for sale $11.5K OBO!! 1/12/13
Gun5 is offline   Reply With Quote
Old 04-14-2007, 05:33 PM   #19
TECH Enthusiast
Garage is empty, add now
 
2001FireBird's Avatar
 
Trader Rating: 0
Join Date: May 2004
Location: San Jose, NorCal
Posts: 713
Send a message via AIM to 2001FireBird
Default

Hmm. I'm going to try that Gun . But wahts wierd is I've had the same number of keys since high school and only recently has the security light given me a problem.

Thanks whitebird00 for the information. I'll try using more contact cleaner and clean the ignition and the resistor on the key.
__________________
2001FireBird is offline   Reply With Quote
Old 07-17-2007, 11:59 AM   #20
Staging Lane
Garage is empty, add now
 
99 H.O.S.S.'s Avatar
 
Trader Rating: 0
Join Date: Jul 2007
Location: Kansas City, MO
Posts: 51
Default

Mine been on for a month now, but I found this page on the net that might help yes. I just haven't had time to try it.

http://www.ls1.com/forums/showthread.php?t=9270

you might have to copy and paste it
99 H.O.S.S. is offline   Reply With Quote
Old 07-17-2007, 11:59 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
1998, 1999, 2003, 96, 98, camaro, car, chevy, driving, formula, light, reprogramming, security, silverado, stays, z28


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 04:22 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details