Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Stereo & Electronics
Sign in using an external account
Register Forgot Password?
Search

Stereo & Electronics Audio Components | Radars | Alarms

2005 GTO Electrical Issues

Reply
 
Thread Tools Search this Thread
Old 05-01-2007, 07:23 PM   #1
On The Tree
Garage is empty, add now
 
PapaSmurf2005's Avatar
 
Trader Rating: 0
Join Date: Feb 2007
Posts: 196
Default 2005 GTO Electrical Issues

Well less than 2 weeks ago one night my "check alternator" light came on. I really didn't think anything of it, just figured it would be my battery going out. Plus it was late at night and I just didn't care.

The next day I go to see if I can't see what is wrong with the car. So I start it up to check the volts... 11.2 while running. I thought this to be strange so I grab another battery to try out, start up the car 11.2 volts. Next I checked the wires and they all seemed to be good, even ran a new power wire from the alt to the battery and still 11.2 volts... car is not charging. So I'm thinking ok my alt is dead. Though what was weird is my fans do not kick on (HP Tuned to be on all the time when car is on running). I also noticed that my electric water pump is not working... so yay my car will not cool itself.

So I take the car to a good dealer that I will will try to help me. They called me to tell my fans do work when they command them on with the Tech 2. All the wires seem to be fine. So they replaced my battery and alt, he said the car was charging now. Though my fans will still not come on by themself, he did not say if my EWP was working or not. He also said one of my fuel rails were leaking. So I goot rent another trailer to go get the car to bring it back to the house.

Anyways does anyone have any ideas? I'm just about ready to blow this car up... so sick of it.
__________________

http://pic50.picturetrail.com/VOL440.../312648213.jpg
11.9 @ 116 - 1.89 60' - n/a - stock suspension - stock trans

PapaSmurf2005 is offline   Reply With Quote
Old 05-01-2007, 07:23 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
05, 2005, alt, alternator, batteries, battery, changing, check, electrical, flash, gto, light, problem, problems, stereo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 03:13 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details