HU won't fit? - LS1TECH

Log In 


Stereo & Electronics Audio Components | Radars | Alarms

HU won't fit?

Reply
 
Thread Tools Search this Thread
Old 04-15-2008, 03:15 PM   #1
TECH Resident
Thread Starter
iTrader: (4)
 
xXSilencerXx's Avatar
 
Join Date: Feb 2007
Location: Patrick AFB, FL
Posts: 784
Default HU won't fit?

Alright I got a Kenwood KDC-X592 head unit. It's a single din, but it's too deep. There's a tab sticking up for the old stereo that's keeping it from going in. Does everybody have to cut that tab out to get their stereo in or is mine just too long?

If so how do you keep the head unit from sliding around once it's mounted? I got a HUmount but that only seems to keep it from falling out, but does nothing to keep it from sliding in.
xXSilencerXx is offline   Reply With Quote
Old 04-15-2008, 07:13 PM   #2
TECH Resident
Thread Starter
iTrader: (4)
 
xXSilencerXx's Avatar
 
Join Date: Feb 2007
Location: Patrick AFB, FL
Posts: 784
Default

Nevermind I got it.
xXSilencerXx is offline   Reply With Quote
Old 04-15-2008, 07:24 PM   #3
Launching!
iTrader: (4)
 
Navy01Z's Avatar
 
Join Date: Sep 2007
Location: Beacon Falls, CT
Posts: 256
Default

Just to let you know, I am pretty sure everyone has cut that tab out. I know I had to and every other fbody I ever worked on I had to cut it as well. I'm glad you figured out the issue tho.
Navy01Z is offline   Reply With Quote
Old 04-15-2008, 08:28 PM   #4
TECH Resident
Thread Starter
iTrader: (4)
 
xXSilencerXx's Avatar
 
Join Date: Feb 2007
Location: Patrick AFB, FL
Posts: 784
Default

Yea after I posted it I went and look on a website about the fitment and realized all of the stereos said they required that to be cut.

Thanks, the stereo looks great, and it sounds a hundred times better than the stock one.

I tried to take some pics but the camera just wouldn't take a decent pic. Here the best ones I could get.





xXSilencerXx is offline   Reply With Quote
Old 04-18-2008, 10:02 PM   #5
TECH Regular
iTrader: (12)
 
Join Date: Aug 2005
Posts: 421
Default

where did you get that wear it is trans am . do thay have one like where it says camaro on it so it could lite up like that
99 ss is offline   Reply With Quote
Old 04-19-2008, 01:05 AM   #6
Banned
iTrader: (6)
 
Join Date: Apr 2008
Location: South
Posts: 163
Default

Those are awesome.. Who makes those?
BigBlockCamaro is offline   Reply With Quote
Old 04-27-2008, 09:06 PM   #7
11 Second Club
iTrader: (13)
 
jsteele90's Avatar
 
Join Date: Mar 2007
Location: delaware
Posts: 2,873
Default

humount.com
jsteele90 is offline   Reply With Quote
Old 04-27-2008, 09:11 PM   #8
TECH Fanatic
iTrader: (7)
 
98boxer's Avatar
 
Join Date: Jun 2004
Location: Ventura County, California
Posts: 1,477
Default

glad you fixed the problem. for my stereo installation i had to remove the box you see after removing the stereo and put it too the side so my new stereo could fit.
98boxer is offline   Reply With Quote
Old 04-27-2008, 09:41 PM   #9
TECH Addict
iTrader: (70)
 
95GreenZ28's Avatar
 
Join Date: Apr 2007
Location: Amarillo, Texas
Posts: 2,157
Default

Looks good man
95GreenZ28 is offline   Reply With Quote
Old 04-27-2008, 09:47 PM   #10
TECH Veteran
iTrader: (4)
 
mycamaroSS's Avatar
 
Join Date: Aug 2006
Location: San Marcos/Plano, Texas
Posts: 4,824
Default

looks good, should have gotten blue instead of red led though
mycamaroSS is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:50 PM.