Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Suspension & Brakes
Sign in using an external account
Register Forgot Password?
Search

Suspension & Brakes
Springs | Shocks | Handling | Rotors
Sponsored by
Weld Racing

UMI LCA install

Reply
 
Thread Tools Search this Thread
Old 10-02-2005, 09:01 AM   #1
Launching!
Garage is empty, add now
 
Shutout's Avatar
 
Trader Rating: 4
Join Date: Aug 2004
Location: Long Island
Posts: 236
Default UMI LCA install

I installed UMI's tubular LCA's yesterday without to much trouble. It was pretty straightforward. Took the car out for a run, nailed it and all my wheelhop was gone . The car feels a little more solid also. My one complaint is the car seems to rattle more than before. Is this because the LCA's don't flex as much and is causing the car to rattle somewhere else?
Shutout is offline   Reply With Quote
Old 10-02-2005, 02:00 PM   #2
TECH Apprentice
Garage is empty, add now
 
nytmare1's Avatar
 
Trader Rating: 7
Join Date: Sep 2004
Location: Fredericksburg, VA
Posts: 342
Default

I installed UMI's poly and rod end LCAs and PHB this past Friday. I also noticed that they are a bit noisy. It's not bad by any means. I'm not getting any popping. Just a little rattling here and there. Mostly at lower speeds. I don't hear anything out of them at highway speeds. I double checked the torque on the bolts today and took them up to 90 ft/lbs. I guess the minor rattling noise is just the result when using rod ends. They're working great too!

Marc
nytmare1 is offline   Reply With Quote
Old 10-04-2005, 08:43 PM   #3
launching!
2000 Pontiac Trans Am
 
joblo1978's Avatar
 
Trader Rating: 14
Join Date: Nov 2003
Location: Colorado Springs
Posts: 2,224
Default

Quote:
Originally Posted by nytmare1
I installed UMI's poly and rod end LCAs and PHB this past Friday. I also noticed that they are a bit noisy. It's not bad by any means. I'm not getting any popping. Just a little rattling here and there. Mostly at lower speeds. I don't hear anything out of them at highway speeds. I double checked the torque on the bolts today and took them up to 90 ft/lbs. I guess the minor rattling noise is just the result when using rod ends. They're working great too!

Marc
You should hear poly/poly, heh. Sounds like someones gettin' busy on your spoiler. Squeak squeak sqeak squeak.
__________________
"AWOL"
Even better than as seen in GM High-Tech Performance
(May 2010)
One of few Magnacharged F-Bodies
joblo1978 is offline   Reply With Quote
Old 10-04-2005, 08:55 PM   #4
TECH Apprentice
Garage is empty, add now
 
nytmare1's Avatar
 
Trader Rating: 7
Join Date: Sep 2004
Location: Fredericksburg, VA
Posts: 342
Default

Quote:
Originally Posted by joblo1978
You should hear poly/poly, heh. Sounds like someones gettin' busy on your spoiler. Squeak squeak sqeak squeak.
LOL... in that case, mine sound like old people gettin' busy.
nytmare1 is offline   Reply With Quote
Old 10-05-2005, 10:07 AM   #5
Launching!
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jun 2004
Location: nowhere
Posts: 274
Default

I have wheel like like a **** also. will just new lcas do the trick to get rid of it? how much where they and do you recommend anything else, this is on a 95 z
95camaroz28 is offline   Reply With Quote
Old 10-05-2005, 10:07 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details