UMI torque arm relocation kit - LS1TECH



Suspension & Brakes Springs | Shocks | Handling | Rotors

UMI torque arm relocation kit

Reply
 
Thread Tools Search this Thread
Old 03-16-2008, 06:15 PM   #1
Staging Lane
Thread Starter
iTrader: (1)
 
Join Date: Mar 2008
Posts: 77
Default UMI torque arm relocation kit

Has any one used this and what you think of it and im a bit confused so it replaces the stock tranny mount because im thinkin about going M6 and using this as my tranny mount does it help with traction thanks for help
ls1slow is offline   Reply With Quote
Old 03-16-2008, 07:44 PM   #2
TECH Addict
iTrader: (6)
 
SpdFrk1990's Avatar
 
Join Date: May 2005
Location: Cincinnati
Posts: 2,572
Default

I got it on my car It seemed to throw my Pinion angle of I think with the stock TA. I got an adj TA that should be here tomorrow ill let you know how it does after I get that on. I really like how it took the TA off the transmission tho.
SpdFrk1990 is offline   Reply With Quote
Old 03-16-2008, 10:11 PM   #3
Staging Lane
Thread Starter
iTrader: (1)
 
Join Date: Mar 2008
Posts: 77
Default

so this will work for the tranny mount tho will that sucks it throw off your angle tho
ls1slow is offline   Reply With Quote
Old 03-16-2008, 10:19 PM   #4
TECH Addict
iTrader: (6)
 
SpdFrk1990's Avatar
 
Join Date: May 2005
Location: Cincinnati
Posts: 2,572
Default

Im pretty sure it threw mine off after lowering it and all with this. I get vibration 80 and over that was not there b4. Most people that get this get a TA also though.
SpdFrk1990 is offline   Reply With Quote
Old 03-17-2008, 01:46 AM   #5
TECH Fanatic
iTrader: (3)
 
hpjunky98's Avatar
 
Join Date: Mar 2005
Posts: 1,869
Default

The kit doesn't relocate the positioning of the T/A. It merely moves where it mounts, while keeping it in the same location. It shouldn't have effected your pinion angle at all. If anything, the added vibration is due to your T/A being mounted onto your chassis. You no longer have the rubber isolation offered by the transmission mount.
hpjunky98 is offline   Reply With Quote
Old 03-17-2008, 02:29 AM   #6
TECH Addict
iTrader: (6)
 
SpdFrk1990's Avatar
 
Join Date: May 2005
Location: Cincinnati
Posts: 2,572
Default

Im sure it lowers the position just a little. The vibration is not from it being chassis mounted it gets really bad and I didnt notice it at all before. Its a great piece Im not saying thats even the reason cause I changed other things at the time also.
SpdFrk1990 is offline   Reply With Quote
Old 03-17-2008, 04:59 AM   #7
Launching!
iTrader: (3)
 
soulless's Avatar
 
Join Date: Mar 2006
Location: searching for the perfect driving line
Posts: 289
Default

I have the t/a and relocation kit on the way, but plan on installing them at the same time. It does seem the relo kit moves the mount down some. With a stock t/a it could mess with the pinion angle. I'll take before and after pics, if anyone wants.
soulless is offline   Reply With Quote
Old 03-17-2008, 10:14 AM   #8
Staging Lane
Thread Starter
iTrader: (1)
 
Join Date: Mar 2008
Posts: 77
Default

so guys will this work as a new tranny mount if im starting with nothing
ls1slow is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:13 AM.