need to install cam bearings - LS1TECH

Go Back   LS1TECH > REGIONAL FORUMS > Texas Members
Log In 

Texas Members Our State Will Kick Your State's Ass

need to install cam bearings

Thread Tools Search this Thread
Old 02-03-2011, 05:03 PM   #1
Teching In
hdkarmy's Avatar
Trader Rating: 0
Join Date: Sep 2010
Location: Texas
Posts: 49
Default need to install cam bearings

I have an lq9 I'm putting together and the cam bearings are showing copper on the bottom and one side. the rod and main bearings look great. the motor is very clean inside. has anyone done a post on removing and installing them? the motor is on a stand, the heads are off getting a valve job and i have the pan off, just finished putting in the rod bolts. I will pull the crank, but I don't want to pull the pistons. I'm afraid of damaging the rings. Does any one know were to get or rent a remover/installer locally? Some help would be great, i'm in the Keen/Cleburne/Burleson area.
hdkarmy is offline   Reply With Quote
Old 02-03-2011, 05:17 PM   #2
TECH Junkie
454navyss's Avatar
Trader Rating: 47
Join Date: Jul 2007
Location: Providence Village, TX
Posts: 3,105
2002 silverado ecsb-5.3, A4
1963 Impala 2 Dr Hardtop-SBC, m4
454navyss is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -5. The time now is 06:42 PM.