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VCM Suite is a comprehensive tuning tool that allows performance tuning and 
diagnostics, whether you want to increase the fuel economy of your daily driver or 
maximize your performance on the race track. 

The suite has two components:

￭ VCM Editor allows users to adjust many of the parameters that control the 
operation of the engine and transmission.

￭ VCM Scanner allows users to monitor, log, and review key data that provides 
insight into the effectiveness of the vehicle's current tune. With such insight, a 
skil led tuner can return to VCM Editor and further refine the tune.

This guide covers the use of VCM Editor.

WHAT'S NEW IN VCM EDITOR?
Recent changes to VCM Editor are listed below.

VCM EDITOR 5.0

GENERAL

￭ MPVI3 and RTD gen 3 . VCM Scanner now supports our latest generation of 
interface devices.

￭ Multi-language support. It 's a work in progress, but we have begun to translate 
portions of the VCM Suite user interface. See Selecting the Displayed Language 
(Page 20) for more information.

VEHICLE SUPPORT

Added support for:

￭ 2007-2018 Audi TT 2.0 TFSI

￭ 2007-2020 Audi TTS 2.0 TFSI 
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GETTING STARTED WITH VCM EDITOR
1. It is recommended you have the following before you begin using VCM Editor:

￭ An account on hptuners.com.

￭ An interface device from HP Tuners that has been registered.

￭ An understanding how VCM Suite licenses system vehicles and of the HP 
Tuners credit system. 

NOTE: For detailed explanations of all of these topics (and more), see the 
VCM Suite Getting Started Guide.

NOTE: Certain vehicles may require modifications to their VCM or special 
cables to allow reading and writing of tuning files. See Manufacturer Locked 
Control Modules (Page 24).

2. When you are ready to begin tuning, ALWAYS check the vehicle for diagnostic 
trouble codes (DTCs)  before you do anything else. If there is a mechanical issue 
with the vehicle, it may affect performance and any performance data you want to 
monitor could be impacted. This makes it very difficult to tune the vehicle 
effectively.

IMPORTANT: Reading a vehicle will clear all DTCs, resulting in the loss of the 
troubleshooting information they contain. DO NOT proceed to the next step 
until you have resolved as many DTCs as possible and made note of those 
issues that cannot be resolved. 

3. Once you have resolved as many DTCs  as possible, the next step is usually to read  
of the vehicle's current sensor output using VCM Scanner. Obtaining this "data log" 
will often provide valuable information in understanding the vehicle's current 
behavior.

4. In VCM Editor, read the current tune of the of the vehicle. See Reading a Vehicle 
(Page 27) for instructions. 
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5. Before you do anything else, save this initial read to file (select File > Save in the 
menu bar). If something goes wrong with your tune, you may need to write this 
back to restore vehicle function.

CAUTION: Improperly tuning a vehicle can cause serious engine damage. 
Do not attempt to make any change to a vehicle's tune without 
thoroughly researching the potential impacts of the change.

6. Editing a tune file involves modifying the configurable parameters used by the 
vehicle controllers:

a. Locate a parameter you wish to modify. See Locating Parameters (Page 31).

b. Change the value of the parameter as needed. See Modifying Parameters (Page 
43).

NOTE: The color behind the names of parameters you have edited will 
change. See Parameter Colors (Page 47), for more information.

7. Select File > Save in the menu bar to save your changes.

8. When you are ready to test your changes, write the modified tune file back to the 
vehicle. See Writing Tunes Back to the Vehicle (Page 129).

9. Use VCM Scanner to check the impact of your changes and verify that all 
performance and emissions characteristics of the vehicle remain within limits 
acceptable to the vehicle owner and required by law.

10. Repeat steps 6 through 9 until your desired tuning goals have been met.
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The main window of the VCM Editor interface has the following components:

Item Description

1. Menu Bar. See Menu Bar (Page 13) for descriptions of individual 
menus.

2. Toolbar. See Main Toolbar (Page 18) for descriptions of 
individual items.

3. Favorites Icon. Click to open the Favorites window. See Using 
Favorites (Page 40).

4.
Tab Navigation Interface (Top Level). Click an icon to browse 
the parameters in the open tune file. See Tab Style Navigation 
(Page 32) for details.

5. Workspace. When you open additional windows in VCM Editor, 
they appear in this space.
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MENU BAR

VCM Editor's menu bar includes the following menus:

FILE MENU

Use this menu to open, close, and save tune files you wish to edit.

EDIT MENU
￭ Calibration Details. Opens the Tune Details window, which contains key 

information about the vehicle being tuned and its controllers. See Viewing Tune 
Details (Page 123).

￭ Remote Tuning. Opens the Remote Tuning window, which can be used to limit 
what remote customers can do with tune files you provide them. See Remote 
Tuning (Page 138).

￭ View / Change History Logs. Opens the Tune History window, which can be used 
to view all changes to the current tune file and to compare the current version of 
the file to any previously saved version. See Viewing Tune History (Page 119).

￭ Virtual Volumetric Efficiency. Certain GM vehicles pack VE data into a form that is 
difficult to modify in any meaningful way. If you are tuning such a vehicle, you can 
use this function to unpack the data and edit it in a format similar to a conventional 
VE table. See Virtual Volumetric Efficiency (Page 86).

￭ Virtual Torque. When tuning GM vehicles with Gen 4 and Gen 5 controllers, this 
option opens the Virtual Torque window, which is used to configure torque 
management. See Virtual Torque (Page 90).
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￭ Gear/Tire Wizard. This item appears if the Gear/Tire Wizard can be used with the 
vehicle being tuned. On supported vehicles, the wizard calibrates the speedometer 
and scales the transmission tables to adjust for a new gear ratio or tire size. See 
The Gear/Tire Wizard (Page 95).

￭ Change VIN Wizard. This item appears if VCM Editor supports changing the VIN of 
the vehicle being tuned. See Changing a Vehicle's VIN (Page 114).

￭ ETC Effective Area Calculator. When tuning Ford vehicles, this option opens the 
ETC Effective Area Calculator, which can be used to update the throttle body 
model used by the engine controller. See ETC Effective Area Calculator (Page 93).

￭ Torque Inverse Calculator. When tuning Ford vehicles, this option opens the 
Torque Inverse Calculator, which can be used when configuring the torque model 
on Ford vehicles. See Torque Inverse Calculator (Page 94).

￭ VE Neural Network Trainer. This item appears if the vehicle being tuned employs 
neural network technology and the Tuner Tools portal supports training its neural 
network. See Neural Network Training (Page 97).

￭ User Defined Parameters.  If you have information on parameters (switches, 
scalars, and/or tables) that we do not have defined currently in VCM Editor, this 
feature makes it possible to add them yourself and edit them in VCM Editor 
immediately. See User Defined Parameters (Page 83).

￭ Template Applicator. Opens the Template Applicator window, which applies 
templates created in Template Editor. See Templates (Page 70) for instructions on 
using the templates feature.

￭ Navigator. Opens the Parameter Navigator window, which lists parameters in a 
tree structure. See Parameter Navigator (Page 34).

￭ View. If you want to display only the parameters that are appropriate for less 
experienced tuners, select View Basic. To use the default (all parameters) display, 
select View Advanced.

Page 14



USER INTERFACE

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

COMPARE MENU

The options in this menu can be used to compare the parameter values in the open 
tune file to the corresponding values (if any) in another tune file. See Comparing Two 
Tune Files (Page 66).

If you are comparing two files with matching operating system IDs, you can also copy 
segments from the compare file to the tune file being edited. See Segment Swaps 
(Page 112) for more information.

FLASH MENU
￭ Read Vehicle. If there is a vehicle connected to your computer, select this option 

to read the vehicle's current tune. See Reading a Vehicle (Page 27).

￭ Write Vehicle. If there is a vehicle connected to your computer and you have a 
tune file appropriate for that vehicle open, select this option to write the tune in 
the open file to the vehicle's controllers. See Writing Tunes Back to the Vehicle 
(Page 129).

TOOLS MENU
￭ Unit Conversion. Opens the Unit Conversion window, which can quickly perform 

many common unit conversions. See Unit Conversion Window (Page 116).

￭ Calculator. Opens a window containing a simple calculator.

￭ Options. Opens the Options window, which contains user preference settings for 
the VCM Editor application. 

￭ Template Editor. Opens the Template Editor window, which is used to create and 
edit templates for parameters you need to modify in multiple tune files. See 
Templates (Page 70) for instructions on using the templates feature.
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WINDOW MENU

When you have multiple daughter windows open in VCM Editor's workspace, the 
options in this menu can be used to quickly position the open windows for easier 
viewing.

HELP MENU
￭ Help. Opens VCM Editor's help system.

￭ License Information. Opens the License Information window, which lists the 
vehicles and controllers that are licensed on the most recently connected 
interface device. It also shows you how many credits you have spent for those 
licenses and upgrade credits available (if any). See The License Information 
Window (Page 126) for more information.

￭ Resync Interface. Selecting this item when your interface device is connected to 
the computer will update the device to ensure that credits and licenses purchased 
since the last resync are properly stored on the device and will be available when 
you need them. 

NOTE: This function is also an important step in preparing a new interface for 
first time use. See The VCM Suite Getting Started Guide for more information.

￭ VCM Suite Information. Opens the VCM Suite Info window. When your interface 
device is connected to the computer, this window can be used to generate a log 
file that contains troubleshooting information. See How to Generate a VCM Suite 
Infolog (Page 146).

￭ MPVI Application Keys. Registration of older (MPVI) interface devices required 
entering an application key that was received by email. Selecting this menu option 
opens the window that allows application keys to be entered.
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NOTE: Newer devices (MPVI2/2+/3) do not use application keys. They use veri-
fication codes for online registration. See The VCM Suite Getting Started Guide 
for more information.

￭ MPVI2 Verification Code. When a new MPVI2 , 2+, or 3 is connected to the 
computer, this option will produce a verification code that is used for device regis-
tration. 

￭ About. Displays a window that shows what version of the VCM Suite you are using. 
If there is an update to the software available, the window will have a Download 
button that you can use to retrieve the new version.
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MAIN TOOLBAR

VCM Editor's main toolbar contains the following items:

Open an existing tune file. 

NOTE: If you already have a file open, this will also close the currently 
open file.

Save the open tune file.

Close the open tune file.

Opens the Tune Details window, which contains key information about the 
vehicle being tuned and its controllers. See Viewing Tune Details (Page 123).

Opens the Remote Tuning window, which can be used to limit what remote 
customers can do with tune files you provide them. See Remote Tuning 
(Page 138).

Opens the Tune History window, which can be used to view all changes to 
the current tune file and to compare the current version of the file to any 
previously saved version. See Viewing Tune History (Page 119).

Open a tune file that you want to compare to the tune file you are working 
on. See Comparing Two Tune Files (Page 66) for more information.

When using the compare feature to compare two tune files, show the 
values from the main file.

When using the compare feature to compare two tune files, show the 
values from the compare file.

Page 18



USER INTERFACE

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

When using the compare feature to compare two tune files, show how 
much each numerical value differs by.

Opens the Unit Conversion window, which can quickly perform many 
common unit conversions. See Unit Conversion Window (Page 116).

If there is a vehicle connected to your computer, select this icon to read the 
vehicle's current tune. See Reading a Vehicle (Page 27).

If there is a vehicle connected to your computer and you have a tune file 
appropriate for that vehicle open, select this icon to write the tune in the 
open file to the vehicle's controllers. See Writing Tunes Back to the Vehicle 
(Page 129).

Opens the VCM Suite Info window. When your interface device is connected 
to the computer, this window can be used to generate a log file that 
contains troubleshooting information. See How to Generate a VCM Suite 
Infolog (Page 146).
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SELECTING THE DISPLAYED LANGUAGE

NOTE: This feature requires VCM Suite version 4.13 (or later).

In the most recent builds of VCM Suite, we have begun to implement support for 
changing the displayed language of the suite's applications. Follow these steps:

1. In the menu bar of either VCM Suite application, select Tools > Options . The 
Settings window appears.

2. In the Language dropdown, select the desired display language.

3. Click OK .

4. Close the application. The selected language should be displayed the next time 
either VCM Suite application is opened.

NOTE: At the time of this writing, only a portion of the interface supports alternate 
languages and some of the translated text is still rough placeholder text rather 
than a polished translation. Please bear with us while we work on expanding this 
feature's implementation.
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The procedure for connecting to a vehicle varies by the type of interface device you 
are using.

MPVI2/2+/3 AND ALL RTD INTERFACES
When used with the VCM Suite, a USB connection to your PC is recommended:

1. Connect the larger end of the included USB cable to an available USB port on a 
laptop with VCM Suite Installed. 

2. Connect the other end of the USB cable to the USB type C port on the front of the 
interface device.

 

3. When you are ready to scan or reprogram the vehicle, plug the large, molded 
OBD-II connector on the other side of the interface device into the vehicle's 
diagnostic port.

When used with the TDN app for mobile devices, these devices connect to your 
mobile via Bluetooth® . The app provides on-screen instructions for establishing the 
connection and attaching the device to your vehicle. For more information, consult 
the documentation for the TDN app.
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MPVI
1. Connect the larger end of the included USB cable to an available USB port on a 

laptop with VCM Suite Installed. 

2. Connect the other end of the USB cable to the USB type B port on the interface 
device.

3. Connect the 15-pin side of the OBD-II interface cable to the matching connector 
on the interface device.

4. When you are ready to scan or reprogram the vehicle, connect the 16-pin side of 
the OBD-II interface cable to the vehicle's diagnostic port.
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MANUFACTURER LOCKED CONTROL MODULES
Some vehicle manufacturers now put locking devices in their VCMs to prevent third 
parties from tuning the vehicle. Although most of these vehicles can be read by the 
VCM Suite without any problem, writing an updated tune to these vehicles may 
require special hardware.

For many of these vehicles, HP Tuners can upgrade the existing VCM to allow it to be 
tuned by our software or exchange it for a controller that has already been upgraded. 
For other vehicles, a special cable may be required.

GM

Controller Vehicles
HP Tuners 
Solutions

E41 ECM

2017+ Chevrolet Silverado 
and GMC Sierra 2500/3500 
trucks with 6.6L Duramax 
diesel engines

L5P purchase, 
exchange, or 
upgrade

E99 ECM 2019+ Corvette ZR1
ZR1 modified 
purchase or 
exchange

E90 ECM

2019 - 2021 Chevrolet 
Silverado and GCM Sierra 
trucks with 5.3L L84 engines 
and 6.2L L87 engines

L84 & L87 – E90 
modified ECM 
exchange

T87A TCM
2017+ GM vehicles equipped 
with 8-speed and 10-speed 
transmissions

T87A unlock 
service

Unlocked T87A 
purchase
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DODGE / CHRYSLER / RAM / JEEP

Controller Vehicles
HP Tuners 
Solutions

2015+ PCMs
All 2015+ Dodge, Chrysler, 
RAM, and Jeep vehicles 
(except Dodge Viper)

Dodge PCM 
upgrade service

Dodge upgraded 
PCM purchase

2018+ PCMs
All 2018+ Dodge, Chrysler, 
RAM, and Jeep vehicles.

Dodge 2018+ smart 
access cable

(These vehicles also 
require the 
upgraded PCM 
above)

POLARIS

Controller Vehicles
HP Tuners 
Solutions

MG1CA007 ECM RZR-Pro R
MG1CA007 ECM 
upgrade service

All supported 
ECMS

Supported Ranger, Ace, 
Sportsman, RZR, and 
Scrambler models

OBD-II adapter 
cable for Polaris 
vehicles
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PUTTING A VEHICLE IN THE "ON" STATE
When connecting to a vehicle for read and write operations, HP Tuners software 
typically requires that the vehicle be put in an ON state without starting the vehicle's 
engine. The correct procedure varies from model to model. Here are some examples:

CONVENTIONAL KEY START IGNITIONS
1. Insert the key in the ignition.

2. Rotate the key to the ON (or RUN) position, but do not continue to the 
START position.

DODGE / CHRYSLER / RAM / JEEP WITH RED PUSHBUTTON IGNITION

Keep your foot off the brake and follow these steps.

1. Press the red START button once. The indicator around the button will change 
from OFF to ACC.

2. Wait 2 seconds.

3. Press the red START button again. The indicator should change to RUN.

GM VEHICLES WITH PUSHBUTTON IGNITION

Without putting your foot on the brake pedal, push and hold the ENGINE START button 
for eight to ten seconds.
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When you read a vehicle, you are transferring calibration information from the control 
module(s) in your vehicle to VCM Editor. The read process will automatically detect 
the presence of relevant VCMs in the vehicle and read them all in sequence. The 
various status messages and the progress bar give information about the current 
state of the read.

CAUTION: Ensure that the vehicle battery is charged before proceeding 
(keeping the battery attached to a charger during the procedure is 
recommended). Although it should not be possible to harm any of the 
vehicle's control modules during the read process, vehicle controllers can 
be left in an odd state if a power loss occurs.

If communication is lost, the program will automatically reset the module. It will then 
prompt you to correct the problem and/or try again.

READ PROCEDURE
To read the VCM, follow these steps:

1. Connect your HP Tuners interface device to a laptop with VCM Suite installed. 
Then, connect the device to the vehicle's OBD-II diagnostic port. See  Connecting 
to a Vehicle (Page 21) for more information.

2. If VCM Scanner is open, close it before proceeding.

3. Open VCM Editor.

4. If a tune file is open, close it by selecting File > Close in the menu bar.

5. Turn the vehicle ignition to the ON (or RUN) position, but do not start the engine.

NOTE: Some vehicles require special procedures to be put in the correct state. 
See Putting a Vehicle in the "ON" State (Page 26) for more information.

6. Make sure the doors are closed and all accessories are turned off. 

Page 28



READING A VEHICLE

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

CAUTION: Do not use any vehicle accessories, including the door locking 
mechanism, while the vehicle is being read.

7. In VCM Editor, select Flash > Read Vehicle . 

8. The Vehicle Reader window appears. Wait 10 to 15 seconds.

9. Click the Read button.

10. Allow VCM Editor to read the vehicle controllers until the status bar indicates the 
read is complete.

NOTE: During the read, the instrument panel may briefly display all sorts of 
indicators and error messages and some accessories may appear to turn on 
and off randomly. This is normal.
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NOTE: For vehicles with multiple VCMs (for example: LS2 A4 vehicles), there is 
a 15-second pause between reading each module.

11. Turn off the ignition and unplug the interface cable.

12. The file will automatically open in VCM Editor.

13. If this is the initial read of the stock controller, we strongly recommend that you 
save (and backup) the file before any modifications are made. You may wish to 
restore your vehicle to the stock tune at a later date.
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There are two ways to navigate to parameters you wish to modify:

￭ Tab Style Navigation displays all parameters on a series of tabbed windows. 
It 's often quicker to flip through a series of these tabs than it is to browse the 
parameter tree.

￭ The Parameter Navigator window displays all parameters in a tree structure. 
The search and filter features of this interface allow quick location of individual 
parameters.

TAB STYLE NAVIGATION
VCM Editor organizes vehicle parameters and DTC lists into a tab system. The top level 
of these tabs can be seen just below the main toolbar.

Clicking any of these icons brings up a window displaying the parameters in the cor-
responding group.

If there are enough parameters in the group, there will be one or two rows of tabs at 
the top of the window. The second row (if present) are subtabs of the first row. For 

example, the tab selected in the graphic below is a subtab of the Airflow tab in the 
first row.
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Once you have located the tab containing the parameter(s) you wish to modify, you 
can do the following:

￭ Hover over a parameter to see a brief description for the parameter at the bottom 
of the window.

￭ Edit parameters as needed. See Modifying Parameters (Page 43).

￭ Right-click on the colored background of any parameter name to see a menu 
containing options for the parameter. See Parameter Options (Page 49).
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PARAMETER NAVIGATOR
The Parameter Navigator window (sometimes called "tree view") can be useful if you 
need to quickly search through all available parameters to find a specific parameter 
you need to change.

To open Parameter Navigator, select Edit > Navigator in the menu bar.
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SELECTING AND EDITING PARAMETERS

Available parameters are listed in the tree on the left. Click on a listed parameter or 
parameter group to display that parameter or group in the pane on the right. 

NOTE: In the image above, we clicked on Engine > General > Engine. Both 
parameters in the group appeared on the right.

The user interface for the fields displayed on the right is no different than when the 
fields are displayed in tab view. You can interact with them the same way here:

￭ Hover over a parameter to see a brief description for the parameter at the bottom 
of the window.

￭ Edit parameters as needed. See Modifying Parameters (Page 43).

￭ Right-click on the colored background of any parameter name to see a menu 
containing options for the parameter. See Parameter Options (Page 49).
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FILTERING THE TREE DISPLAY

When you need to quickly find a specific parameter or group of parameters, there are 
a number of ways to filter the fields listed in the tree.

FILTERING BY PARAMETER NAME

To filter the tree display by parameter name, enter the text you wish to search for in 

the [Text Filter] box above the tree. The displayed tree items will be dynamically 
fi ltered as you type.

Page 36



LOCATING PARAMETERS

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

FILTERING BY DATA TYPE

The group of icons on the left end of this window's toolbar are used to filter displayed 
items by data type.

When a blue box appears around the icon, items of this type will be displayed. When 
the blue box does NOT appear, items of this type will NOT be displayed. Click the icon 
to turn the display off. Click again to turn it on.

Switches

Scalars

Tables

DTC Lists

Code Mods
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FILTERING BY PARAMETER GROUP

The middle group of icons in the window's toolbar are used to filter displayed 
parameters by group.

When a blue box appears around the icon, the corresponding parameter group will be 
displayed. When the blue box does NOT appear, the group will NOT be displayed. Click 
the icon to turn the display off. Click again to turn it on.

Operating System

Engine

Engine Diagnostics

Transmission

Transmission Diagnostics

System

Fuel System

Speedometer
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FILTER BY BASIC / ADVANCED

The final two icons in the window's toolbar filter by whether each parameter is 
considered to be "basic" (for beginners) or "advanced" (for more experienced tuners).

When a blue box appears around the icon, items of this type will be displayed. When 
the blue box does NOT appear, items of this type will NOT be displayed. Click the icon 
to turn the display off. Click again to turn it on.

Basic Parameters

Advanced Parameters
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USING FAVORITES
Adding your most commonly-used parameters to the Favorites window allows you to 
quickly access all of them in the same place.

Parameters displayed here can be modified using the same methods you would use in 
either the Tab Navigation interface or Parameter Navigator. See Modifying Parameters 
(Page 43).

To open this window, click the Favorites icon  in the toolbar.

NOTE: This window will display only the favorites included in the file you are 
currently editing. If the file does not contain one or more of your favorite 
parameters, the missing parameters will not be displayed.
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ADDING FAVORITES

To add a favorite to the Favorites window:

1. In either the Tab Navigation interface or Parameter Navigator , locate the 
parameter you wish to add.

2. Right click on the colored background of the parameter's name. The Parameter 
Options menu appears.

3. Select Favorites > Add to Favorites .

NOTE: If you are in the Table Editor, you can also add the table by clicking the Add 
Favorite icon  in the editor's toolbar.

REMOVING FAVORITES
1. Locate the parameter you want to remove in the Favorites Window or using either 

of the navigation interfaces.

2. Right click on the colored background of the parameter's name. The Parameter 
Options menu appears.

3. Select Favorites > Remove from Favorites .
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You can browse through the available parameters using either the Tab Navigation 
System or the Parameter Navigator . Each parameter displayed will be one of the 
following types:

￭ Switches

￭ Scalars

￭ Tables

￭ Code Modifications

Additionally, you can configure the behavior of Diagnostic Trouble Codes (DTCs). See 
Editing DTC Lists (Page 106) for more information.

MODIFYING SWITCHES
"Switches" are parameters that support only a handful of specific values. VCM Editor 
represents these as simple drop down menus.

To modify one of these, click the value to be modified and then select the new value 
from the drop down.
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MODIFYING SCALARS
"Scalars" are simply numerical values that can be entered in the spaces provided.

NOTE: To see the range of values permitted for a particular field, hover over the 
field. The range will be displayed in the lower right corner of the window.

To change the display units for a field (for example, from Fahrenheit to Celsius), click 
the green label to the right of the field. Each click will switch to the next supported 
unit type. It may take several clicks to find the units you want.

NOTE: When you change the displayed units, the value in the box will be displayed 
in the new unit and the displayed value may be rounded off. However, the 
underlying value does not change until you enter a new number in the box.

MODIFYING TABLES
In the parameter display, each table is represented as a colored button bearing the 
name of the table.

Click the button to open the table in Table Editor , which allows the table data to be 
viewed and edited.
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APPLYING CODE MODIFICATIONS
The Operating System group may contain one or more Code Modification buttons that 
look like this:

Clicking one of these buttons tells the VCM Suite to apply a custom HP Tuners patch to 
the operating system of your vehicle's ECM, TCM, or PCM.

CAUTION: Applying an OS mod can brick the controller being modified. When 
doing so, be sure to follow the instructions given on screen EXACTLY.

Follow these steps:

1. THOROUGHLY research the mod you wish to apply. Determine if:

￭ There is any additional hardware that needs to be installed in the vehicle to 
support this mod.

￭ There is any additional tuning required to support this modification. If so, what 
needs to be done?

2. In VCM Editor, open the tune file for the vehicle to be modified.

3. In the OS group, click the button for the code modification you wish to apply.

4. Immediately save the file under a different name and then close it. DO NOT make 
any other modifications to the file.

5. Open the new file again and flash the file to the vehicle using the WRITE ENTIRE 
option.
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PARAMETER COLORS
VCM Editor displays a colored background behind the name of each parameter. 
Initially, all parameters will have the same blue background. 

The colors change to indicate parameters that have changed since the last save or 
that differ from the same parameter in a comparison file.

SINGLE CALIBRATION FILE OPEN (NO COMPARE FILE)

When you only have one calibration file open, parameters that have changed since the 
last save are displayed in a different color.

No changes have been made to either table.

The High Octane table has changed since the last 
time the file was saved.

PRIMARY CALIBRATION FILE AND COMPARE FILE OPEN

When you have a second file open for comparison, the colors also indicate 
parameters that differ from the corresponding parameters in the compare file.

The values of these parameters in the primary file 
match the values in the compare file.     No changes 
have been made to either parameter since this last 
save.

The values of these parameters in the primary file 
match the values in the compare file. The High 
Octane table has changed since the last time it was 
saved to file.

Comparable fields do not exist in the compare file.  
Neither field has been changed since the last save.
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Comparable fields do not exist in the compare file.     
The High Octane table has changed since the last 
save.

The values of these parameters are different in the 
primary file than they are in the compare file.     No 
changes have been made to either table since the 
last save.

The values of these parameters are different in the 
primary file than they are in the compare file.     The 
High Octane table has been changed since the last 
time it was saved to file.
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PARAMETER OPTIONS
Right-clicking on the colored background of any parameter displayed in the Tab 
Navigation System or in the right pane of the Parameter Navigator will display a 
menu containing options for the parameter.

The options displayed are different for each type of parameter. They may include the 
following:

￭ Copy. Copy the value of this field to the clipboard. This allows the same value to be 
pasted into another field later.

￭ Paste. If you have copied the value of another field to the clipboard, select this 
option to paste it into the current field.

￭ Undo Changes. Select this option to revert the field back to the value in the last 
saved version of the tune file.

￭ Units. Select this option to change the displayed units for this field.

￭ Decimals. Select this option to add or remove decimal places from the value 
displayed in this field (increase or decrease the precision of the displayed value).

￭ Favorites. Select this option to add this field your favorites (or remove it from your 
favorites).
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TABLE EDITOR
Editing tables is one of the key tasks required when modifying a tune. A good under-
standing of the Table Editor's display, layout, and functions will make many tuning 
tasks much easier.

OPENING A TABLE
1. Find the table you wish to view in either the Tab Navigation System or the 

Parameter Navigator . Both of these windows represent tables as buttons with a 
colored background.

2. Click the button for the table you wish to open.

BASIC LAYOUT

When you first open the table editor, you will see data presented in a normal table 
view. This is the primary view for editing table data and the majority of the editor's 
functions are available only in this view. 
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You can also switch to either a 2D or a 3D graph view:

Switch to 3D graph view. In addition to zooming and rotating the chart, 
this view allows you to drag click and drag individual data points. See 
Using 3D Graph View (Page 64) for more information.

Selects the 2D graph view. This view allows you to click and drag 
individual data points. See Using 2D Graph View (Page 63).

Return to the default table view.

NOTE: See The Table Editor Toolbar (Page 54) for a full list of toolbar functions).

EDITING CELL DATA IN TABLE

Editing cell data has two basic steps:

1. Select the cell(s) you wish to modify.

2. Enter the new cell data or specify how the cell data should be transformed.

NOTE: Right-clicking on a cell produces a menu that contains additional options 
for manipulating cell data. See Table Editor Right-click Menu (Page 58) for more 
information.
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SELECTING CELLS

To select... Procedure

A single cell Click on the cell.

A row or 
column

Click the row or column header.

All cells Click the box in the upper-left corner of the table.

A block of cells

1. Left click on one corner of the desired block, but do 
not release the mouse button yet.

2. Drag the mouse pointer to the opposite corner of 
the desired block.

3. Release the left mouse button.

ENTERING A SPECIFIC VALUE

To enter a specific value in a selected cell or group of cells, just type the new value.

- or -

Type the value in the space next to the math symbols in the toolbar and then click the 
equals sign.

ADDING A VALUE TO SELECTED CELLS

To add a desired value to the selected cell(s):

1. Enter the value to be added in the space next to the math symbols in the toolbar.

2. Click the plus sign.

NOTE: If you wish to subtract a value rather than add one, enter the desired value 
as a negative number.

Page 52



MODIFYING PARAMETERS

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

MULTIPLYING SELECTED CELLS BY A DESIRED VALUE

To multiply the selected cell(s) by a desired value:

1. Enter the value to multiply by in the space next to the math symbols in the 
toolbar.

2. Click the multiplication sign.

NOTE: If you wish to divide by a value rather than multiply, enter the reciprocal of 
the desired value as a decimal. For example, to divide by two, you would enter 0.5 
(the decimal equivalent of 1/2).

HOT KEYS

The following hot keys are available in table view only:

+/- Increment and decrement value(s)

CNTRL+C Copy value(s)

CNTRL+V Paste value(s)

CNTRL+Z Undo last modification
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THE TABLE EDITOR TOOLBAR

The toolbar in Table Editor has many options for viewing and modifying tables.

TABLE OPEN, SAVE AND PRINT

Import a table from a file and overwrite current table.

Save the table to a file.

Print the table.

FAVORITES

Add this table to your favorites.

Remove this table from your favorites.

See Using Favorites (Page 40) for more information.
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FILE COMPARE

View the table for the primary calibration

View the table for the compare calibration

View the differences between the primary and compare calibrations

NOTE: These icons change the view for the current table only. To change the view 
for all open tables, use the icons in VCM Editor's main toolbar or in the Compare 
menu. See Comparing Two Tune Files (Page 66) for more information.

RELOAD

Reload the current table

COPY AND PASTE

Copy table selection to clipboard

Paste table selection from clipboard
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MODIFY

Replace selected cells with the value in the box

Add the value in the box to the selected cells

Multiply the selected cells by the value in the box

SINGLE VIEW VS. SPLIT VIEW

View only one data representation (table or 2D/3D graph)

Use a horizontal split with the table display on top and the graph on the 
bottom

Use a vertical split with the table display on the left and the graph on the 
right

SELECT VIEW

Selects the table view. In split view mode, the table is always one of the 
views in the split.

Selects the 3D graph view. In split view mode, this changes between 2D 
and 3D graph view.

Selects the 2D graph view.  In split view mode, this changes between 2D 
and 3D graph view.
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PRECISION

NOTE: The functions of these two icons were swapped in VCM Suite version 4.12. 
(If you are using an older release, use the description for the other icon in this 
list).

Increase decimal precision (add a decimal place)

Decrease decimal precision (remove a decimal place)

SMOOTHING AND INTERPOLATION

Smooth the entire selection

Smooth the selection only using a horizontal pass

Smooth the selection only using a vertical pass

When using the smoothing functions, the level of smoothing will be 
determined by your current precision. To increase the effected area of your 
smoothing, increase your precision

Interpolate the entire selection (flat plane)

Interpolate between horizontal bounds (creates lines)

Interpolate between vertical bounds (creates lines)
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TABLE EDITOR RIGHT-CLICK MENU

Right clicking on a table in the table editor displays the following options:

COPY

Copy a selected cell or section of the table to the clipboard.

COPY WITH AXIS

This function copies a selected cell or section of a table and includes the axis data. 
When used in conjunction with the Paste Special function, Copy With Axis allows the 
data to be pasted into another table without selecting the destination cell. Because 
the data was copied with axis labels, the software will automatically place the pasted 
data accordingly. 

NOTE: This is similar to the function in VCM Scanner's Graph panel and RTT Editor.

PASTE

Pastes a cell or table section into a selected cell. When pasting a copied region, the 
selected cell will become the top left cell in the pasted region.
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PASTE SPECIAL 

This function pastes data copied using the Copy With Axis feature into the current 
table.

The contents of the clipboard must be of the same dimensions as the contents of 
your table.

Add Add the contents of the clipboard to the table

Subtract Subtract the contents of the clipboard from the table

Multiply %
Multiply the contents of the table by the clipboard values as a 
percentage

Multiply % - Half
Multiply the contents of the table by the clipboard values as a 
percentage divided in half

Average Average the values between the clipboard and the table

Pasting Histogram Data from VCM Scanner

When using tables in VCM Scanner's Graph panel properly, the Paste Special function 
can be used to import the learned graph data  into the current table.

An example of this is building a knock retard graph and importing it into your main 
spark tables. 

UNDO LAST

Undo your last action.

UNDO ALL

Undo all actions.
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UNITS

If there are multiple unit types available for the data in this table, this option allows 
you to choose the units of the displayed data.

COLUMN AXIS

Includes options to copy the labels from the column axis, edit the column axis , or 
change the units of the column axis.

ROW AXIS

Includes options to copy the labels from the row axis, edit the row axis , or change 
the units of the row axis.

VIEW INVERTED

Select this option to display the table as inverted (swap the X and Y axes). When a 

table has been inverted, the word INVERTED appears above the upper-right corner of 
the table.

RENUMBERING TABLE AXES

If a table axis has a name displayed AND the name is underlined, it is possible to adjust 
the numerical values along the table axis.

NOTE: Changing the axis values does not update the data in the body of the table. 
Once you are finished adjusting the axis values, you will need to update the cell 
data to be appropriate.
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CHANGING THE LABEL OF AN INDIVIDUAL ROW OR COLUMN

To change the value of the label for an individual row or column:

1. Click the name of the axis that you wish to adjust. The axis editor window appears.

2. In the row of numbers above the graph, click the value that you wish to change.

3. Enter the new value.

NOTE: If you are not changing one of the endpoints, the new value entered 
should fall between the values on either side of it.

4. To apply your changes, close the window.
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EXPANDING OR CONTRACTING THE RANGE OF THE TABLE

If you need to expand or contract the range of values on a table axis, you can do this 
by adjusting the axis endpoint values.

NOTE: On some tables, the vehicle PCM will limit how far the range of the axes can 
be expanded. You cannot use this function to change an endpoint beyond the 
maximum or minimum value supported by the PCM.

1. Click the name of the axis that you wish to adjust. The axis editor window appears.

2. In the row of numbers above the graph, click either the value on the far left or the 
value on the far right (depending on which endpoint you wish to move).

3. Enter the new endpoint value.

4. Click the  icon in the toolbar. This will adjust the axis values in the middle to be 

evenly spaced between the new endpoint values.

5. To apply your changes, close the window.
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USING 2D GRAPH VIEW

MODIFYING A DATA POINT

1. Left click on the data point to modify.

2. Drag the data point to the desired position.

3. Release the left mouse button.
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USING 3D GRAPH VIEW

You can control the rotation, shift, zoom of the 3D graph as well as modify data points 
with the left mouse button.

MODIFYING A DATA POINT

1. Left click on the data point to modify.

2. Drag the data point to the desired position.

3. Release the left mouse button.

ADJUSTING THE ZOOM LEVEL 

1. Click and hold on the graph with both the left and right mouse buttons sim-
ultaneously.

2. Move the mouse up to zoom in or down to zoom out.
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3. Release the mouse buttons.

ROTATING THE GRAPH

1. Right click the graph. 

2. Move the mouse in the direction of rotation desired.

3. Release the right mouse button.
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COMPARING TWO TUNE FILES
VCM Editor's compare feature can provide a very quick overview of the differences 
between any two tune files available.

Major points of comparison:

￭ You can compare any files regardless of make/model/operating system.

￭ When comparing files of different operating system, only parameters of similar 
types are compared.

￭ For tables to be compared they must be of the same dimensions in both files.

￭ DTC differences will not be compared.

OPENING FILES FOR COMPARISON
1. Open the first of the two files you wish to compare by selecting File > Open in the 

menu bar. 

2. Once the first fi le has been opened, the Compare menu becomes available. Select 
it in the menu bar.

3. Select Open Compare File and browse for the second file to compare.
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SELECTING A VIEW

Once you have opened both files, you will have three separate views available.

￭ Show Main File 

￭ Show Compare File 

￭ Show Differences

You can access these views either by selecting them in the Compare menu or by 
clicking the appropriate button in the toolbar of the main VCM Editor window.

TOOLBAR ICONS

View the calibration values in the main file

View the calibration values in the compare file.

View the differences between the two files. (For each numerical parameter 
and table cell, this option displays the amount by which the two values 
differ).

NOTE: These icons also appear in the toolbar at the top of each table you open. 
When you change the compare view of an individual table, it will affect only that 
table. To change the display view of all open parameters, you must use either the 
Compare menu or the toolbar in the main VCM Editor window.
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VIEWING THE COMPARISON LOG

The comparison log displays a quick overview of differences between the two files. To 
open the comparison log,

￭ In the menu bar, select Compare > View Comparison Log .

Only parameters supported by both calibrations and of similar types are displayed.
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COPYING A SINGLE PARAMETER OR GROUP

To easily copy a single parameter or group from the compare file to the main file:

1. Left click the parameter or group you wish to copy.

2. Right click and select Copy Over Selected Differences .

COPYING ALL DIFFERENCES

To copy ALL differences from the compare file to the main file:

1. Right click on any parameter or group.

2. Select Copy Over All Differences .

When copying over differences between files of different operating system IDs, some 
parameters may copied over as a close approximation rather than as an exact value. 
In this case, the parameter will stil l show up in the list.
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TEMPLATES
Templates are user created files that represent a set of parameter values.

They are useful for when you want to automate, or expedite the tuning process by 
applying a known set of parameter values onto a target tune.

TYPICAL USAGE SCENARIO
￭ You develop a kit that requires the idle be adjusted.

￭ You open up your stock development tune.

￭ In your tune, you adjust your idle rpm.

￭ Creating a template file that contains these changes allows you to quickly apply 
them to additional customer tunes quickly and easily.

CREATING AND APPLYING TEMPLATES

The process has two basic steps:

1. Create and edit the template in Template Editor. See Creating a New Template 
(Page 71).

2. Use Template Applicator to apply the template to a tune. Applying a Template to a 
Tune (Page 75).
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CREATING A NEW TEMPLATE

Follow these steps to create a template:

1. In VCM Editor's toolbar, select Tools > Tune Template Editor . The Template 
Editor window appears. 

2. In the Template Editor toolbar, click .

A new, empty template opens in the editor. 

3. Add parameters to the new template using one or more of the following toolbar 
icons:

Import parameters from an existing template. See Importing Another 
Template (Page 74).

Select specific parameters from the currently loaded tune. See Adding 
Specific Parameters (Page 73).

Import unsaved changes from the currently loaded tune. See Importing 
Unsaved Parameters (Page 74).
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When comparing two tune files, import the compare file version of 
parameters that differ from the main file. See Importing Compare File 
Differences (Page 74).

4. The imported parameters should now be displayed on the right side of the 
window. If desired, edit the values of the imported parameters.

5. Click  to save your changes.
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ADDING SPECIFIC PARAMETERS

When editing a template in Template Editor, you can manually select parameters to 
add.

1. Open the tune file that contains the parameters you wish to import.

2. In the Template Editor toolbar, click . The Parameter Selector window appears.

3. Check the box for each parameter or group of parameters you wish to add.

4. Click OK .
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IMPORTING ANOTHER TEMPLATE

When editing a template in Template Editor, you can import all the parameters in 
another template.

1. In the Template Editor toolbar, click . 

2. Browse for and select the template file that you wish to import.

3. Click Open .

IMPORTING UNSAVED PARAMETERS

When editing a template in Template Editor, you can import the unsaved changes 
from the current tune file.

1. Open the tune file that contains the parameters you wish to import. 

2. Make the desired changes.

3. In the Template Editor toolbar, click .

IMPORTING COMPARE FILE DIFFERENCES

When editing a template in Template Editor, you can the parameters the differ 
between two tune files. 

1. If they're not already open, open the two tune files to compare:

a. Open the first of the two files you wish to compare by selecting File > Open in 
the menu bar and then browsing for the file.

b. Once the first fi le has been opened, select Compare > Open Compare File in 
the menu bar.

c. Browse for and select the compare file.

2. In the Template Editor window, click .

The parameters that differ will be imported from the compare file.
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APPLYING A TEMPLATE TO A TUNE
1. Open the tune file to which you want to apply the template.

2. In the menu bar, select Edit > Template Applicator . The Template Applicator 
window appears.

3. In the Template Applicator toolbar, click the  icon.

4. Browse for and select the template you wish to apply. The parameters in the 
selected template appear in the left pane of the window.
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NOTE: By default, the box next to each parameter in the template will be 
checked. If you do not wish to apply a particular parameter to the open tune, 
uncheck the box.

5. If you want to make changes to the values of the included parameters before 
application, they can be edited on the Preview tab. However, template changes 
made in this window cannot be saved.

6. Select the Apply Changes tab.

7. Click the  icon. VCM Editor will apply the parameters that can be applied. 
Success or failure of the application will appear below.

If the application was successful, you should see no entries in the Failed or Not 
Found columns.

You can now save the tune with the template applied.
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TEMPLATE EDITOR

The Template Editor allows you to create and edit templates containing a collection of 
parameter values.

To open this window, select Tools > Tune Template Editor in the toolbar.
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CREATING, OPENING, AND CLOSING TEMPLATES

The four icons on the left end of the toolbar are used to create, open, and close 
template files:

Create a new, empty template. See Creating a New Template (Page 71).

Open an existing template.

Save the current template.

Close the current template.

ADDING PARAMETER VALUES

The four icons on the right end of the toolbar add parameters to a template. Each icon 
represents a different method:

Import parameters from an existing template. See Importing Another 
Template (Page 74).

Select specific parameters from the currently loaded tune. See Adding 
Specific Parameters (Page 73).

Import unsaved changes from the currently loaded tune. See Importing 
Unsaved Parameters (Page 74).

When comparing two tune files, import the compare file version of 
parameters that differ from the main file. See Importing Compare File 
Differences (Page 74).
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EDITING PARAMETER VALUES

You can edit the values of parameters in the Template. However, there are some 
limitations to this process.

Editing Switches

￭ The values of switches are stored as character strings. Although other windows in 
VCM Editor will l ist all possible values for the switch in a dropdown menu, in this 
window, you must enter the actual character string.

￭ For a modified switch value to be applied properly, the string you enter must be a 
supported value of the parameter you are modifying.

Editing Scalars

There are no restrictions on scalars.

Editing Tables

￭ You can edit the cell contents of the tables, but not the axis.

￭ For tables to be applied properly, they must have the same axis sizes and axis 
values as the corresponding tables in the tune to which they are being applied. 
Moreover, the unit type of the cell values must be the same.

EDITING DTC LISTS

￭ For DTC values to apply to the target, they must have the same Key and the Value 
must also be supported on the target.

￭ To add new DTC value to the list, the easiest way is to change the property you 
desire in your tune and import unsaved changes.

DELETING A PARAMETER

1. In the tree view, click on the parameter you want to delete.

2. Press the "Delete" key.

Page 79



VCM EDITOR USER GUIDE

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

DELETING A DTC LIST ENTRY

1. Click on the row containing the entry you want to delete.

2. Press the "Delete" key.
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TEMPLATE APPLICATOR

The Template Applicator allows you to apply a saved set of parameter values to your 
currently loaded tune.

The parameters included in the template are selected in Template Editor , but you 
can edit the values of the parameters in this window before you apply them.

To open this window, select Edit > Template Applicator in the toolbar.

OPENING A TEMPLATE FILE

To open a saved template file, click the  icon and browse for the template file that 

contains the parameters you want to apply.

THE PARAMETER TREE

When a template file is open, the parameters included in the template will be listed in 
the tree on the left side of the window. There are two things you can do with this l ist:

￭ Parameters that have a check next to them will be applied to the current tune file. 
If you do not wish to apply a particular parameter, uncheck the box.

￭ Select a parameter or group of parameters. The selected parameter(s) will be 

displayed in the Preview tab to the right. 
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PREVIEW TAB

The parameters selected in the tree to the left will be displayed on this tab. You can 
edit the values of the parameters here before you apply them to a tune. However, this 
process has the same limitations as editing parameters in the Template Editor 
window. See Editing Parameter Values (Page 79) for more information.

APPLY CHANGES TAB

Select this tab when you are ready to apply the template's parameters to the tune 
being configured.

Click  the  icon to apply the parameters that are checked in the tree to the left. The 

results of the application process will be indicated in the space below:

￭ Skipped: These are template parameters that were not checked.

￭ Success: These template parameters applied OK.

￭ Failed: The template parameter failed to apply. Error messages will be included 
describing the parameter and error.

￭ Not Found: These are template parameters that do not exist in the currently 
loaded Tune.
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USER DEFINED PARAMETERS
User Defined Parameters is an optional feature that can be purchased on the HP 
Tuners website.

If you have information on parameters (switches, scalars, and/or tables) that we do 
not have defined currently in VCM Editor, this feature makes it possible to add them 
yourself and edit them in VCM Editor immediately. 

NOTE: Parameters added must be supported by the operating system on the 
controller being tuned. You are simply telling VCM Editor about parameters that it 
does not have any information on yet. Adding a parameter that is NOT supported 
by the controller's operating system will have no effect because the controller 
won't use it.

A summary of the procedure for adding user defined parameters can be found below. 

See the User Defined Parameter Guide for full instructions.

PROCEDURE
1. Use TunerPro to define the parameters to be added. Save as an .xdf fi le.

2. In VCM Editor, open the .HPT file to which you want to add parameters.

3. In the menu bar, select Edit > User Defined Parameters .
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4. Click .

5. Select the TunerPro (.XDF) file that contains the parameters you wish to import.

6. Click Open . Your parameters will be imported into VCM Editor.

Page 84



MODIFYING PARAMETERS

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

If you would like parameters added to VCM Editor permanently, email HP Tuners 
support to request that they be added. 

NOTE: Not all controllers supported by VCM Suite support User Defined 
Parameters, please start a support ticket for more information.

WHAT ARE THE "ALLOWED ADDRESSES" IN THE USER DEFINED 
PARAMETERS WINDOW?

The allowed addresses are address ranges that you are allowed to define parameters 
in. If you try to define a parameter outside these ranges, they will not import and you 
will not be allowed to edit them.
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VIRTUAL VOLUMETRIC EFFICIENCY
Rather than a traditional VE table, certain GM vehicles use something called "VE coef-
ficients" for volumetric efficiency. If you are tuning such a vehicle, you can use the 
Virtual Volumetric Efficiency Table Editor window to unpack the VE coefficient data 
and edit it in a format similar to a conventional VE table. 

To access this window, select Edit > Virtual Volumetric Efficiency in the menu bar.
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EDITING VIRTUAL VE TABLES

A brief summary of the procedure for modifying a virtual VE table can be found below. 

See the HP Tuners Live Training session on Speed Density Tuning for details.

NOTE: If you have changed the fuel injectors, it is critical that you have accurate 
data for the new injectors entered under Engine > General > Injector Control. If 
the injectors are not accurately described here, your VE table configuration will 
not be correct.

1. If the engine also has a MAF sensor, it is necessary to temporarily force the engine 
to use speed-density mode in order to gather the data necessary for VE table 
calibration. See Forcing Speed-Density Mode on a GM Vehicle (Page 89).

2. Use the VE Mode and Camshaft Angle controls to select a version of the VE table 
to configure.

3. Configure the data in the VE table using the same methods you would use for a 
conventional VE table.

4. When you have a version of the table data that you want to flash to the vehicle, 
click Calculate Coefficients to update the VE Coefficients tables based on your 
modifications.

5. Flash the revised tune file to the vehicle.

6. In VCM Scanner, create a log containing fuel trim data at various rpms. 

7. Use the observed fuel trim data to determine what changes to the virtual VE table 
(if any) are needed. If further changes are needed, return to step 3 and make 
further modifications.

8. If the vehicle has a MAF sensor, restore MAF sensor operation by reversing the 
changes made in step 1.
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VE MODE

Some vehicles have a (runner control) switch in the intake manifold that can be open 
or closed. It is possible to configure a separate VE table for each position of the 
switch. 

On vehicles that support Displacement on Demand (DoD), an alternate version of 
each table can be configured for use when cylinders have been deactivated.

Use this dropdown menu to select the version of the VE table to configure.

￭ Manifold Switch Closed

￭ Manifold Switch Closed (DoD)

￭ Manifold Switch Open (DoD)

￭ Manifold Switch Open

Vehicles that do not have an intake manifold runner control switch use only the 
Manifold Switch Open version(s) of the table. 

Vehicles that do not support DoD use only the non-DoD versions of the table.

CAMSHAFT ANGLES

On VVT vehicles, a separate VE table can be configured for each CAM angle 
combination. Select a combination of intake and exhaust cam angles to configure the 
VE table used for that combination.

On fixed cam (non-VVT) vehicles, these can be left at 0.
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FORCING SPEED-DENSITY MODE ON A GM VEHICLE

When modifying a VE table, it is necessary to temporarily force the vehicle into speed-
density mode so that the effect of your changes can be accurately observed in VCM 
Scanner.

NOTE: This procedure involves changing parameters whose original values will 
need to be restored later. Make note of the initial value of each parameter before 
you change it.

Follow these steps.

1. Navigate to Engine > Airflow > Dynamic . 

2. Set High RPM Disable to an rpm value higher than the engine will reach. (8000 is 
usually good)

3. Navigate to Engine Diagnostics > Airflow .

4. Set MAF Frequency Fail High to 0 Hz.

5. Some GM trucks will also have two parameters named High Count Thresh and 
Low Count Thresh in the Mass Airflow Sensor group. If you see these parameters, 
set them both to 0.

6. Navigate to Engine Diagnostics > DTCs .

7. Change the Error Mode for codes P0101, P0102, and P0103 to MIL on First Error.
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VIRTUAL TORQUE
The Virtual Torque window is used to configure torque management on GM vehicles 
with Gen 4 and Gen 5 controllers. In these controllers, torque management is 
designed to protect the transmission by setting limits on how much torque the engine 
can deliver. However, this can be a concern to some tuners because it may limit the 
amount of power delivered by performance modifications.

CAUTION: Boosting the limits set here reduces the ability of the vehicle to 
protect its transmission. Proceed at your own risk. NEVER configure these 
tables to handle more torque than the engine will actually produce.
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The window displays a series of tables, each of which correspond to an amount of 
spark advance or retard. When the engine is running, the ECM will use the table 
closest to the amount of spark advance employed at the moment.

The X-axis of these tables is rpm. The Y-axis is either cylinder airmass (in mg) or 

manifold air pressure (in kPa), depending on what is selected in the Table Group 
dropdown.

CONFIGURING A TABLE GROUP

NOTE: Since manifold air pressure and airmass are key inputs to these tables, it is 
important that Virtual VE tuning be complete and as accurate as possible before 
you begin. Without accurate input, achieving a good output is highly unlikely.

1. Use the Table Group dropdown to select the group of tables to be modified.

2. Edit the tables in the group as needed.

3. Click Extrapolate Coefficients .

4. Click Calculate Torque Tables .

EDITING THE TABLES IN TANDEM

Because the displayed tables perform the same function at different levels of spark 
advance, you may wish to make similar changes to all of them at the same time. VCM 

Editor helps you do this by providing the Link Selections checkbox.

When Link Selections is checked, selecting a cell or group of cells in one table will 
select the same cell(s) in the other tables. Changes made to the selected cells will 
then apply to all tables. 
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TABLE GROUP

There are several different versions of the virtual torque tables. Select a table group 
here to specify which version of the tables is displayed to the right. There are two 
basic table groups:

￭ Airmass. In this group of tables, the Y axis is cylinder airmass (in mg)

￭ MAP. In this group of tables, the Y axis is manifold air pressure (kPa)

Additionally, there is an E85 version of each table group. These tables will be used if 
the vehicle is configured for flex fuel applications and has been fil led with E85 (high 
ethanol content) fuel.

There is also a DoD version of each table group. In vehicles that support Displacement 
on Demand, these tables will be used when cylinders have been deactivated.

Y AXIS MIN, MAX, AND INCREMENT

These fields configure the Y-axis labels for the table group selected above.

CAMSHAFT ANGLE

On VVT vehicles, a separate version of each table group can be configured for each 
CAM angle combination. Select a combination of intake and exhaust cam angles to 
configure the table group used for that combination.

On fixed cam (non-VVT) vehicles, these can be left at 0.

SPARK ITERATIONS

These fields configure the amount of spark advance or retard that each of the tables is 
keyed to. 
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ETC EFFECTIVE AREA CALCULATOR
The ETC Effective Area Calculator is a tool that can be used when configuring Ford 
vehicles to work with a different model throttle than was installed previously. 

The X-axis of this table is the effective area of the throttle body. The Y-axis is throttle 
vacuum.

Entering throttle angle data in this table and clicking Calculate Effective Area updates 
the two Throttle Body Model tables at Engine > Airflow > Electronic Throttle:

￭ Effective Area. The engine controller uses this table to calculate the airflow 
through the throttle body. It is (roughly) the inverse of the table here.

￭ Predicted Throttle Angle. The engine controller uses this table to determine the 
throttle angle required to deliver the desired airflow. The angles entered here will 
be copied into the body of this table.

NOTE: The axis labels in this window are copied from the Predicted Throttle Angle 
table. If you wish to change them, they must be changed in that table rather than 
in this window.
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TORQUE INVERSE CALCULATOR
The Torque Inverse Calculator is a tool that can be used when configuring the torque 
model on Ford vehicles.

Entering torque data in this table and clicking Calculate Inverse updates the two 
Torque Calculation tables at Engine > Torque Model > General:

￭ Engine Torque. This table specifies the amount of torque (before friction and 
accessory losses) that the engine makes based on rpm and engine air load. 
Changes to the torque values in the Torque Inverse Calculator are copied directly 
into the corresponding cells in the Engine Torque table.

￭ Inverse. When the scheduled torque (the final amount of torque that the engine 
controller will request, including all adjustments) has been calculated, this table is 
used to covert the scheduled torque to the amount of engine air load  that would 
be needed to achieve that torque. The Inverse table is (roughly) the inverse of the 
table in the Torque Inverse Calculator. 
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NOTE: The axis labels in this window are copied from the Engine Torque table. If 
you wish to change them, they must be changed in that table rather than in this 
window.

THE GEAR/TIRE WIZARD
When tuning GM vehicles, the Gear/Tire Wizard can be used to calibrate the 
speedometer and scale the transmission tables to adjust for a new gear ratio or tire 
size.

1. In the menu bar, select Edit > Gear/Tire Wizard . The Gear/Tire Wizard window 
appears.

2. In the column on the right, enter the new Tire Size in inches. If the size has not 
changed, enter the same value.

NOTE: This value is the height of the tires. It must be entered in inches, even if 
metric units are selected.
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3. In the column on the right, enter the new Gear Ratio . If the ratio has not changed, 
enter the same value.

4. Normally, the wizard will automatically determine a Multiplier for scaling the 
transmission tables that maintains similar shift RPMs.If you would prefer to 
manually enter a different multiplier:

a. In the upper-right corner of the window, select Manual Scale .

b. Enter the new value in the Multiplier box.

5. Click the Adjust button. 
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NEURAL NETWORK TRAINING
Neural Network Trainer is an online tool from HP Tuners that allows tuners to 
configure the complex neural networks used by some modern vehicle controllers to 
model Volumetric Efficiency.

NOTE: Select 2010+ FCA and 2019+ GM vehicles are eligible for neural network 
training

Neural networking is an artificial intelligence concept that can be used to "train" 
computing systems. Such systems "learn" by recognizing patterns in sample input and 
output data and then apply that learning to determine a reasonable result from any 
input data received.

In the past, aftermarket calibration tools have been unable to configure neural 
networks because the calibration data produced by a neural network is often too 
complex to configure directly. 

Neural Network Trainer takes a different approach: it allows you to specify the sample 
data used to train the neural network. You teach the network. It learns from you.
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CONFIGURATION OVERVIEW

NOTE: It takes 25 Tuner Tools Tokens to license a vehicle for one month of neural 
network training. Tokens can be purchased from the My Account page of the 
Tuner Tools website.

1. Use VCM Editor to read the vehicle's current tune.

2. Export a training file.

3. Upload the training file to the Tuner Tools website. Neural Network Trainer will 
process the base file and produce files containing configurable VE tables.

4. Download the VE table files produced by the Tuner Tools website and open them 
in the Neural Network Trainer window of VCM Editor.

5. Modify the VE tables as desired and export a new training file.

6. Upload the new training file to the Tuner Tools website. Neural Network Trainer 
will process the base file and produce trained files.

7. Open the trained files in VCM Editor and flash the updated tune to the vehicle.

See Detailed Training Procedure (Page 98) for more information.

DETAILED TRAINING PROCEDURE

Follow these steps to train a vehicle using Neural Network Trainer:

1. Using VCM Editor, read the vehicle's current tune. When the read is complete, the 
current tune will open in VCM Editor.

2. In the menu bar, select Edit > VE Neural Network Trainer .

NOTE: This menu option is displayed only for vehicles that are eligible for 
neural network training. At present, only select 2010+ Fiat Chrysler and 2019+ 
GM vehicles are eligible.

3. In the toolbar of the Neural Network Trainer window, click .
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4. VCM Editor will display a prompt like the following for each supported neural 
network found in the tune.

5. If you wish to train the indicated network, create a training file:

a. Select Yes . 

b. Enter a name for the new training file.

c. Click Save .

NOTE: Some vehicle calibrations may support multiple neural networks. If you 
wish to train all supported networks, you will need to create and edit a file for 
each.

6. Navigate to tunertools.hptuners.com.

7. Log into your account.

8. Select Neural Network Trainer .

Page 99



VCM EDITOR USER GUIDE

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

9. Upload all fi les created in steps 3 through 5.

10. Once all fi les have been processed, a Download button will become available. 
Download all fi les.

11. Return to the Neural Network Trainer window in VCM Editor. 

12. In the menu bar of this window, click .

13. Browse for and open the file saved in Step 10. The VE tables generated from the 
vehicle's initial tune should now be available for viewing and editing.

NOTE: There will be one table per camshaft angle combination. This could 
total 25 or more tables.

14. Modify the generated VE tables as desired. Follow these steps for each table:
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a. Use the dropdown menus on the left to select a cam angle combination. The 
corresponding VE table will appear on the right.

b. If you want to use this table for training, check the Use Table for Training box.

NOTE: You can accelerate the process by selecting fewer tables for 
training. However, this reduces training accuracy. 

NOTE: Deselecting a table can also be used to disable unused VE tables. 
For example, Dodge/RAM/Jeep vehicles with  Hellcat engines only use a 
fraction of  the 25 available tables.

c. If you are using this table, edit the table values as desired.

NOTE: Editing a large number of tables may take several sessions. If needed, 
you can save your progress using the Save Current Progress button and then 
come back later.
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15. Once all tables that are selected for training have been modified, click Export for 
Training .

16. Return to tunertools.hptuners.com and ensure that you are logged in.

17. Select Neural Network Trainer .

18. Upload the file generated in Step 15. Neural Network Trainer will begin training the 
file.

NOTE: This process may take several minutes.

When training is complete, a Download button appears.

19. Click Download to save the trained file.

20. Return to the Neural Network Trainer window in VCM Editor. 

21. In the menu bar of this window, click .

22. Browse for and open the file saved in Step 19. VCM Editor will prompt you to 
update the file with the new calibration values.

￭ If you want to flash the vehicle with these values, click Yes . This will close the 
Neural Network Trainer window and update the tune  to include the trained 
values. Proceed to Step 23.

￭ If you would like to continue editing the trained tables, click No and return to 
Step 14.

Page 102



MODIFYING PARAMETERS

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

23. Flash the updated tune to the vehicle using VCM Editor.

24. If additional adjustments are needed, they can be made by returning to Step 20 
and editing the last saved training file.
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NEURAL NETWORK TRAINER WINDOW

If the vehicle being tuned supports Neural Network Training , this window can be 
used to prepare volumetric efficiency data to be submitted to the Neural Network 
Trainer at tunertools.hptuners.com. Files processed by the trainer can be edited here 
to prepare them for further training or exported to the tune file.

Item Description

1. Create New. Click this icon to create a new training file from 
the current tune.

2. Open Trained File. Click this icon to open a saved training file.

3.

Cam Angle Selectors. Use these dropdowns to select a 
combination of cam angles. The VE table that corresponds to 
the selected cam angle combination will be displayed to the 
right.
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Item Description

4.

Use Table for Training. If this box is checked, the table 
displayed to the right will be included in the VE data submitted 
to Neural Network Trainer.

If this box is NOT checked, the table will not be used for 
training.

5.
VE Table. This area displays the VE table for the combination of 
camshaft angles selected to the left. Table cells can be modified 
as needed here.

6.

Save Current Progress. Saves all the VE tables configured in 
this window to a file. This allows you to load the file and 
continue editing later.

This DOES NOT export these tables to your tune file and files 
saved with this method cannot be opened by Neural Network 
Trainer.

7.

Export for Training. Saves the VE tables configured in this 
window in a format that can be submitted to Neural Network 
Trainer.

Files in this format cannot be re-opened in this window.
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EDITING DTC LISTS
Lists of Diagnostic Trouble Codes (DTCs) that can be produced by the vehicle are 

located in the Engine Diag group and the Trans Diag group. In most cases, VCM Editor 
allows you to specify whether a particular DTC is reported and whether it will cause 
the Malfunction Indicator Light (MIL) to be lit.

NOTE: Tampering with emissions control devices (including emissions-related 
DTCs) can be illegal. Check local laws as well as national rules and regulations to 
determine what is legal to modify. Emission controls should be disabled only in 
the case of vehicles whose intended use exempts them from emissions 
regulations (for example, vehicles that are for track use only).

￭ To view the list of engine-related DTCs, select Engine Diag > DTCs .

￭ To view the list of transmission-related DTCs, select Trans Diag > DTCs .

Configuration options available for DTCs vary by vehicle manufacturer.

CONFIGURING GM DTCS
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On GM vehicles, you can configure whether each DTC is reported and whether it 
triggers the Malfunction Indicator Lamp (MIL) and the SES lamp.

SES ENABLE

Checking this box enables the display of the SES/Check Engine/Service Vehicle Soon 
lamp when this DTC occurs.

Unchecking this box disables the lamp.

NOTE: In some regions, emissions testing will fail automatically if monitoring for 
emissions-related faults is disabled.

ERROR MODE

The option selected in this dropdown specifies whether the MIL is l it for this DTC and 
whether the error is reported. 

￭ MIL on First Error. I l luminates the MIL the first time the error is detected. This is 
appropriate for emissions-related faults that should be reported immediately.

￭ MIL on Second Error. I l luminates the MIL if the fault is active for 2 consecutive 
driving cycles. This is appropriate for emissions-related faults that should trigger 
the MIL if they are detected consistently, but should NOT trigger the MIL when they 
are detected infrequently.

￭ No MIL Light. The MIL will not be il luminated for this fault, but the SERVICE lamp 
will be il luminated. This is appropriate for non-emissions-related faults that should 
be reported to the driver.

￭ No Error Reported. Neither the MIL nor the SERVICE lamp will be il luminated for 
this fault. This is appropriate for non-emissions related faults that should not be 
reported to the driver.
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CONFIGURING FORD DTCS

On Ford vehicles, the Error Mode dropdown specifies whether each DTC should be 
reported and whether the MIL should il luminate when the fault occurs. It has three 
settings:

￭ MIL Light. The MIL will be il luminated when this fault is detected. This is 
appropriate for emissions-related faults.

￭ No MIL Light. The MIL will not be il luminated when this fault is detected. However, 
the fault will be reported. This is appropriate for non-emissions-related faults that 
should be reported.

￭ No Error Reported. The MIL will not be il luminated when this fault is detected and 
the fault will not be reported. This is appropriate for non-emissions-related faults 
that should not be reported.
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CONFIGURING DODGE/RAM/JEEP/CHRYSLER DTCS

On these vehicles, there are two settings for each DTC:

￭ SES Enable. Checking this box enables monitoring for this fault. Unchecking it 
disables the monitor. 

NOTE: In some regions, emissions testing will fail automatically if monitoring 
for emissions-related faults is disabled.

￭ MIL .Check this box if the MIL should be il luminated when this fault is detected.
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SEGMENT SWAPS
Segment Swaps can only be performed with files whose Operating System IDs match 
exactly.

The Operating System ID can be found in the Tune Details window. (In the menu bar, 

select Edit > Calibration Details .

To perform the segment swap, follow the instructions below:

1. In the menu bar, select File > Open .

2. Select the tune file that you wish to move segments to.

3. Once the first fi le has been opened, the Compare menu becomes available. 

4. In the menu bar, select Compare > Open Compare File .
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5. Select the file containing the segments you want to copy.

6. Select the Segment Swapper feature in the Compare menu.

7. Select the segments you would like to move to the base file.

8. Click Import Selected Segments .

9. Click Close and save the file.
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CHANGING A VEHICLE'S VIN
For certain vehicles, VCM Editor supports changing the VIN. However, the new 
VIN must be valid for the operating system that VCM Editor finds on the VCM you are 
programming.

This method changes the VIN without having to write a new tune file to the vehicle. 
Using the Change VIN Wizard will not change the VIN of the file you currently have 
open.

NOTE: For some vehicles, you will be required to purchase an additional license 
for the new VIN.

PROCEDURE

To make VIN changes permanent please use the following steps:

1. Connect the laptop running VCM Editor to the vehicle whose VIN you wish to 
change. See Connecting to a Vehicle (Page 21) for instructions.

2. If you do not already have a tune file read from this vehicle, perform a read now. 
See Reading a Vehicle (Page 27).

3. With this vehicle's tune file open in VCM Editor, select Edit > Change VIN Wizard 
in the menu bar. The Change VIN Wizard appears.
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4. Enter the new VIN and click Commit .

5. Wait 15 seconds after VIN changes have completed.

6. Turn Ignition off for 30 seconds.

7. Turn Ignition on for 30 seconds.

8. Turn Ignition off for 30 seconds.

9. Turn Ignition on for 30 seconds.

The new VIN is now stored.
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UNIT CONVERSION WINDOW
The Unit Conversion window is a handy tool for performing common unit 
conversions.

To open this window, do either of the following:

￭ In the menu bar, select Tools > Unit Conversion

￭ In the toolbar, click 
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COMMON UNIT CONVERSIONS

The Temperature, Speed, Pressure, Mass Flow, and Volume on the left side of the 
window represent the most common unit conversions. Just type a value in any of 
these fields to obtain the other values in the category.

DYNAMIC CONVERTER

The dynamic converter can be used to perform many unit conversions that aren't 
included in the common unit conversions displayed above it. 

1. In the Quantity Type dropdown, select the type of unit that you would like to 
convert (Acceleration, Area, Length, etc.).

2. In the From dropdown, select the unit that you would like to convert FROM.

3. Enter the value that you would like to convert in the box below the From 
dropdown. 

4. Use the To dropdown to select the unit that you would like to convert TO.

TIRE SIZE CALCULATOR

This tool can be used to quickly find the height in inches of a metric sized tire. 

USING THE TOOL

To use the tire size calculator, just enter the three values from the metric tire size in 
the boxes in the top row of the tool. The tire height in inches will appear in the Tire 
Height box.

For example, a metric size of 225/70R16 would be entered as shown below:
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HOW METRIC SIZING WORKS

Metric tire sizes are written in the format:

<width in mm>/<sidewall height as a percentage of width> R<rim diameter>

For example tire whose size is given as 225/70R16 has:

￭ a width of 225 mm

￭ sidewalls that are 157.5 mm (70% of 225 mm) high

￭ a 16 inch rim diameter

GRAMS PER CYLINDER (AIRMASS) CALCULATOR

This tool is a quick way to calculate the mass of air in each cylinder.

1. In the Grams/sec box, enter the dynamic airflow.

2. Enter the RPM .

3. Select the number of cylinders.

The cylinder airmass will appear in the Grams/cyl box.

FUEL INJECTOR CALCULATOR

This calculator can be used to find the correct flow rate for a new fuel injector.  

1. In the first two boxes, enter the injector flow rate (in g/sec) and the fuel rail 
pressure of the injectors you are replacing. If you are replacing the stock injectors, 
use the vehicle manufacturer's spec. values for both.

2. In the New Fuel Pressure box, enter the fuel rail pressure for the new injectors.
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VIEWING TUNE HISTORY
The Tune History window can be used to view all changes to the current tune file and 
to compare the current version of the file to any previously saved version.

To open this window, do one of the following:

￭ In the menu bar, select Edit > View Change/History Logs .

￭ In the toolbar, select the  icon.

The window has two tabs:

￭ Current Unsaved Changes

￭ Complete Saved History Logs

CURRENT UNSAVED CHANGES

The Current Unsaved Changed tab lists all changes made since the last time the file 
was saved.
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EXAMINING CHANGED PARAMETERS

To examine the parameters changed since the last save:

1. Expand the tree  to locate the parameter you wish to view.

2. Double-click a parameter to view and edit its value.

TOOLBAR

The toolbar at the top of this tab includes the following:

Refresh. Update the list to include any new items changed since you opened 
the window.

Collapse all items in the list.

Expand all items in the list.

Page 120



TUNE FILE UTILITIES

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

COMPLETE SAVED HISTORY LOGS

Each time you save a tune file, a time stamped record of the changes made since the 
last save is added to the Complete Saved History Logs tab. 

This is useful if you want to compare the file to an earlier version of itself or roll back 
to an earlier version of the file.

COMPARING THE CURRENT FILE TO A PREVIOUS VERSION

1. Select the version of the file to use for the comparison.

2. Click . The selected version opens as the compare file. 

See Comparing Two Tune Files (Page 66) for more information on  the file compare 
feature.
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ROLLING BACK TO A PREVIOUS VERSION

1. Select the version of the file to roll back to.

2. Click . The selected version opens in a new window.

3. Save the file from the new window.

EXAMINING CHANGED PARAMETERS

To examine the parameters changed in any particular saved version:

1. Expand the tree under the desired save. You can drill down all the way to the 
individual changed parameters.

2. Double-click a parameter to view its value.

TOOLBAR

The toolbar at the top of this tab includes the following:

Open the selected version of the file in a new window. 

Open the selected version of the file as the compare file. 

Collapse all items in the list.

Expand all items in the list.
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VIEWING TUNE DETAILS
The Tune Details window contains key information about the vehicle being tuned and 
its controllers.

To open this window, do one of the following:

￭ In the menu bar, select Edit > Calibration Details .

￭ In the toolbar, select the  icon.

TUNE OVERVIEW TAB

The tune overview tab contains general information about the tune file being edited, 
including:

￭ The date and time of the file's creation. This typically indicates when the file was 
read from the vehicle. However, if you built this fi le using the Stock File Provider on 
the Tuner Tools website, this will reflect the date the file was built.

￭ The VIN and model description of the vehicle from which this fi le was read.
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ADDING NOTES

You can add your own notes to the tune file by typing them in the Notes box.

COPYING INFORMATION FROM THIS WINDOW

Click the  icon to copy the text from both tabs in this window to the clipboard. This is 

useful if you need to paste any of this data (VIN, controller serial numbers, etc.) 
elsewhere.

CONTROLLERS TAB

For each ECM, TCM, or PCM in the tune file, this tab will display a box that shows the 
controller name, serial number, and operating system ID.

SECURITY KEY

Some GM ECMs have a security key which can be used to lock access to the controller. 
This type of security is called "Tuner Lock". See Tuner Lock (Page 134) for more 
information.
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ADDING A CONTROLLER

If the vehicle has a supported controller that is not in the current tune file, you can 
add the controller to the file in this window. For example, you might need to do this if 
you chose not to include this controller in the initial read of the vehicle.

1. Click the Add Controller button.

2. Select a tune file that includes the controller to be added. 

REMOVING A CONTROLLER

In some cases, a controller can be removed from the tune file. You might do this for 
reasons such as:

￭ If your file contains a TCM, but you do not wish to make any modifications to the 
TCM configuration, you might want to remove the TCM from the file so that you 
don't have to license it.

￭ If you replace a TCM with a completely different model, you can remove the old 
TCM here and then add the new one.

If a controller can be removed, the text <Double Click to Remove> appears in the 
controller information. Double-clicking this box will force you to save the tune to a 
new file and reopen. The new file will not contain the removed controller.
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THE LICENSE INFORMATION WINDOW
The License Information window lists your current licenses and includes a summary of 
how many upgrade credits you have available. 

To access the License Information window, select Help > License Information in the 
menu bar.

PAID LICENSES TAB

This tab lists each vehicle license that you have paid for and how many credits you 
paid for each of these licenses.

In the example above, the user has licensed 2 specific controllers: 1 Engine Control 
Module and 1 Transmission Control Module. In this case, both controllers reside in the 
same vehicle.
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FREE LICENSES TAB

If you have purchased one more unlimited Year/Model l icenses, vehicles that you have 
been able to flash for free because you have this type of l icense will be listed here.

There are two types of l icenses that are listed here:

￭ Specific Vehicle. These are individual vehicle licenses that were covered by an 
unlimited Year/Model l icense you had already purchased.

￭ Vehicle Type. These are year/model l icenses that you received because the 
vehicles covered are essentially the same vehicle type as an unlimited license you 
had already purchased.
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LICENSE UPGRADE PATHS TAB

The License Upgrade paths tab displays the number of upgrade credits you have 
earned and how many additional credits you would need to purchase each upgrade.

In the example above, each row represents a vehicle model year that the user has 
earned upgrade credits for by purchasing single vehicle licenses:

￭ The Upgrade Credits column shows the number of upgrade credits earned 
toward the corresponding Year/Model l icense.

￭ The Credits Required column shows the number of additional credits that would 
be needed to upgrade to the unlimited license for the corresponding Year/Model.

￭ The Description column shows the Year/Model upgrade that these credits apply 
to.

Page 128



Page 129

WRITING TUNES BACK 
TO THE VEHICLE

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

WRITING TUNES BACK TO THE VEHICLE



VCM EDITOR USER GUIDE

HP Tuners, LLC
700 Eastwood Lane
Buffalo Grove, IL 60089 , USA

Before you begin, ensure that:

￭ The vehicle has a fully charged battery. Connecting the vehicle's battery to a 
battery charger before writing a tune is recommended.

￭ Your laptop has a fully charged battery.

Follow these steps to write a tune back to the vehicle:

1. Plug the interface cable into the vehicle's OBD-II port. Connect the other end to 
your PC's USB port. See Connecting to a Vehicle (Page 21) for more information.

2. If VCM Scanner is open, close it now.

3. Open VCM Editor. Ensure that a valid tune file for this vehicle is currently open.

4. Select Write Vehicle from the Flash menu.

NOTE: The first time you attempt to write to each vehicle, you will be 
prompted to purchase a license for that vehicle. See Licensing Vehicles in the 
VCM Suite Getting Started guide for details.

5. Turn the vehicle ignition to the ON (or RUN) position, but do not start the engine.

NOTE: Some vehicles require special procedures to be put in the correct state. 
See Putting a Vehicle in the "ON" State (Page 26) for more information.

6. Make sure the doors are closed and all accessories are turned off.

CAUTION: Do not use any vehicle accessories, including the door locking 
mechanism, during reading or writing procedures.

7. Wait 10 to 15 seconds.

8. Click the Write button.

9. Allow the PC to write the VCM until the status bar indicates the write has been 
completed.
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10. Turn off the ignition and unplug the interface cable. Wait at least 15 seconds 
before restarting the vehicle.

11. The new calibration has now been written to the PCM.

CAUTION:

￭ Do not disrupt the programming session.

￭ Do not open vehicle doors or use vehicle accessories.

￭ Do not attempt to program vehicles whose battery voltage is lower 

than 11.5 Volts.

￭ Do not attempt to use the vehicle to power or charge the laptop. If it 
is necessary to provide additional battery power to the laptop, use an 
external battery that is not connected to the vehicle.

REWRITE ENTIRE (SELECTED VEHICLES ONLY)
This is a useful feature for the tuner shop or mail order tuner and doesn't apply much 
to a single-vehicle tuner. What this can allow you to do is program a VCM that came 
from another vehicle for your specific vehicle type. You must make sure that the VCM 
hardware matches. This is a very powerful feature and must be used with caution. If 
you write a VCM with a file that doesn't belong on it, you could damage the VCM and 
cause it to be unrecoverable. It is not available for all vehicle types.

VCM RECOVERY
When rewriting the VCM, critical components of the VCM software must be erased 
and re-written. If the VCM loses power during the writing of these critical system 
components, the VCM may become unrecoverable. Do not power down the VCM 
under any circumstances during a write failure using these advanced options.
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"WRITE VCM" FAILED AND NOW MY CAR WON'T 
START, WHAT DO I DO?
Don't panic. An error has occurred during the write process. Follow these guidelines:

￭ Make sure the vehicle has sufficient battery voltage for programming.

￭ Make sure your laptop has sufficient power.

￭ Make sure all communications cables are connected firmly.

￭ DO NOT pull your VCM's fuse or disconnect battery power in an attempt to correct 
the problem.

￭ Restart VCM Editor and open up the same file you wrote to the VCM when the 
error occurred. It is very important that you use the same file. Try to Write VCM 
again.

￭ If the problem persists, contact customer support. See Contacting Customer 
Support (Page 145).
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Some tuners prefer to lock their tunes in order to make it more difficult for customers 
and other tuners to view and modify them. VCM Editor supports two methods of doing 
this:

￭ Tuner Lock: This method takes advantage of a security key built into the operating 
system of some GM controllers. Changing the security key prevents anyone who 
does not have the new key from reading or flashing the vehicle. VCM Editor will 
also require this key to view or modify the tune file. See Tuner Lock (Page 134) for 
more information.

￭ Master/Slave Security: This method locks the tune file so that your Tuner ID is 
needed to open it, view it, or edit it. Additionally, a fi le locked this way can be 
flashed to the vehicle only by interface devices whose serial numbers you have 
specified. See Remote Tuning (Page 138).

TUNER LOCK
Tuner Lock is an ECM locking mechanism built into the operating system of certain GM 
controllers. Applying this type of lock is one way to lock your tune so that it cannot be 
opened by other users. 

CAUTION: Tuner Locked ECMs cannot be read or written to by anyone who 
does not have the Tunerlock ID used to lock the vehicle. If you lose track of 
this ID, the ECM will likely need to be replaced.
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IS MY VEHICLE SUPPORTED?

You can find out if the vehicle's controller supports Tuner Locking by doing the 
following: 

1. Open the tune file that you want to lock.

2. In the menu bar, select, Edit > Calibration Details . The Tune Details window 
appears.

3. Select the Controllers tab.

4. If the ECM supports Tuner Lock, the words Security Key appear here, with the 
actual key directly to the right. Below the key, the words <Double Click to Change 
Lock> will be displayed. 
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ENABLING TUNER LOCK
1. Open the tune file that you want to lock.

2. Navigate to the Controllers tab of the Tune Details window (see steps above).

3. Double-click on <Double Click to Change Lock> . 

4. Select the Tunerlock ID you want to use to lock the controller.

5. Click OK . This will change the Security Key from the stock Security Key to a 
different Security Key and apply the selected Tunerlock ID. 

6. Write the file to the vehicle.

NOTE: A Write Entire must be used for all controllers EXCEPT E38 PCMs. For 
vehicles equipped with an E38 PCM, you must select "Write VIN/Tu-
nerlock/VATS" in the Vehicle Writer window.
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DISABLING TUNER LOCK
1. Open the tune file that you want to unlock.

NOTE: The VCM Editor on your PC must have been synced with the MPVI2/2+ 
whose ID was used to lock the controller (or with a device that shares the 
same Tunerlock ID). For older (MPVI) devices, you must have entered the 
Application Key for the device.

2. Navigate to the Controllers tab of the Tune Details window.

3. Double-click on <Double Click to Change Lock> . The text next to the security key 
should revert to "(Unlocked)."

4. Write the file to the vehicle.

NOTE: A Write Entire must be used for all controllers EXCEPT E38 PCMs For 
vehicles equipped with an E38 PCM, you must select "Write VIN/Tu-
nerlock/VATS" in the Vehicle Writer window.

SUPPORTED ECMS

￭ L4Big

￭ P01

￭ P04

￭ P05

￭ P05b

￭ P10

￭ P11

￭ P59

￭ E38
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REMOTE TUNING
The Remote Tuning form allows you to configure Master/Slave Security, which 
restricts opening, viewing, and editing of the current file: 

￭ Setting a Master Tuner ID ties the file to your interface device. Only you will be 
able to view and edit the file.

￭ Adding Slave Interface IDs specifies additional interface devices that are allowed 
to flash the file to a vehicle, but cannot but used to view or edit the file.

NOTE: Do not add Slave Interface IDs without first setting a Master Tuner ID. This 
will prevent everyone (including you) from viewing and editing the file.

This feature locks the tune file only. It does not lock the controller.

ENABLING AND DISABLING MASTER / SLAVE SECURITY

Master / slave security is enabled by specifying master and slave IDs.
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APPLYING MASTER / SLAVE IDS TO A FILE

1. In the menu bar, select Edit > Remote Tuning .

2. Click Insert or Change . 

3. Select the Tunerlock ID you want to use for your Master Tuner ID.

4. Click OK .
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5. In the Slave Interface IDs box, enter the serial numbers of the HP Tuners 
interface devices that will be allowed to flash the file to the vehicle, but not view or 
edit fi les. Enter only one ID per line. 

CLEARING MASTER/SLAVE RESTRICTIONS

To clear the Master Tuner ID and all of the Slave Interface IDs:

1. Open the tune file that you want to unlock.

NOTE: The VCM Editor on your PC must have been synced with the MPVI2/2+ 
whose ID was used to lock the file (or with a device that shares the same 
Tunerlock ID). For older (MPVI) devices, you must have entered the 
Application Key for the device.

2. In the menu bar, select Edit > Remote Tuning .

3. Click the Clear Master/Slave button. 
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ADDITIONAL SLAVE RESTRICTIONS

If you have entered master and slave interface IDs on the Master/Slave tab, the 
settings on the Slave Restrictions tab can be used to further restrict what slave 
interfaces can do.

Entering any of the values on this tab restricts what vehicles slave interfaces can write 
this tune to. The target vehicle must have matching entries for every value entered. 
The fields include:

￭ VIN

￭ Controller Serial #

￭ Controller Operating System ID
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FLASHING RESTRICTIONS

If you have entered master and slave interface IDs on the Master/Slave tab, the 
settings on the Flashing tab specify what type of write slave interfaces will be allowed 
to perform.

ALLOWED WRITE METHODS

These fields specify which write methods slave devices will be allowed to perform. By 
default, both methods are permitted (both boxes are checked). To remove permission 
to use a particular method, remove the corresponding check mark.
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NEXT WRITE FORCE METHOD

These two fields allow you to force slave devices to use a particular write method for 
the next write. Follow these steps each time you want to use this feature:

1. Using the Next Write Force Method dropdown, select the write method to be 
used.

2. Click the Generate New button to generate a new unique ID for this event. This ID 
is used to identify and record the next write instance.

A new unique id is required each time you wish to force a particular write method.
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OVERVIEW
HP Tuners does not currently offer incoming phone support. The best way to reach 

our Support Department is to create a ticket . If you prefer to speak with someone on 
the phone, just let us know in the ticket and we'll call you back as soon as possible.

When you contact us, we may ask for an infolog, a debug.dat fi le, or a license file. 
Having these files ready may speed up the support process.

HOW TO GENERATE A VCM SUITE INFOLOG
When contacting customer support, it 's often helpful for us to have a copy of a VCM 
Suite Infolog. The Infolog must be generated while connected to your vehicle.

GENERATING AN INFOLOG
1. Click the VCM Suite Info button in either VCM Editor or VCM Scanner.

NOTE: make sure your cable is connected to the vehicle and the vehicle's key 
is in the ON position before proceeding. 

2. Click the blue circle "i " icon to poll the software and the vehicle. 
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NOTE: This step may take five to twenty seconds to complete.

3. When Infolog generation is finished, click on the Save icon. Once the file is saved, it 
is ready to email to our Support team.
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LOCATING THE DEBUG.DAT AND LICENSE.DAT FILES
For many support issues, we ask that you provide us with a debug.dat fi le. This fi le can 

be found in This PC > Documents > HP Tuners > Settings :

We may also ask for a license.dat fi le. This can found in the same file path.
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AIRMASS
Also known as "Dynamic Cylinder Air", airmass is the amount of air (by weight not 
volume) in a cylinder at any given time. This is a very important number for tuners 
because the higher the mass of air is in the cylinder, the more fuel can be added. 
Essentially, more air = more power.

DISPLACEMENT ON DEMAND (DOD)
Also known as "Active Fuel Management", DoD is GM's name for the ability of some 
engines to deactivate half of their cylinders when operating in light load conditions. 
Theoretically, this feature enhances fuel economy and reduces emissions slightly.

DYNAMIC AIRFLOW
The mass airflow obtained either from reading the MAF sensor or from speed-density 
calculations, after corrections are applied.

ELECTRONIC THROTTLE CONTROL (ETC)
In vehicles that employ ETC, there is no longer any mechanical l inkage between the 
accelerator pedal and the throttle. The engine (or powertrain) controller dictates the 
amount of throttle applied based on a number of factors including (among other 
factors) current engine rpm and vehicle speed  as well as the position of the 
accelerator pedal. 

ENGINE CONTROL MODULE (ECM)
In some vehicles, the ECM (sometimes called the Engine Control Unit / ECU) is the 
computer that is primarily responsible for controlling the operation of the engine. 
Other vehicles have a Powertrain Control Module (PCM) that controls both the engine 
and the transmission.
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FUEL TRIMS
Although the MAF sensor and/or speed-density tuning will give the engine controller a 
rough idea of the amount of fuel that needs to be injected in a variety of cir-
cumstances, it 's not always perfect. Changes in engine load and other conditions may 
cause the air/fuel mix to be less than ideal. For this reason, the engine controller 
constantly monitors the amount of oxygen in the engine's exhaust and applies 
adjustments to the amount of fuel injected. These adjustment are called "fuel trims". 

There are two types of fuel trim:

￭ Short Term Fuel Trims (STFT): These trims are an immediate response to the 
amount of oxygen seen in the exhaust at the moment. As such, they are being 
adjusted constantly.

￭ Long Term Fuel Trims (LTFT): These trims are the result of monitoring changes in 
the exhaust oxygen content over long periods of time and determining the average 
amount of adjustment required based on long term trends.

INTAKE AIR TEMPERATURE (IAT) SENSOR
IAT sensors measure temperature of the air coming into the engine. In speed-density 
tunes, this data is used in conjunction with a pressure (MAP) sensor and the VE tables 
to determine the mass air flow.

MANIFOLD ABSOLUTE PRESSURE (MAP) SENSOR
MAP sensors measure the air pressure in the intake manifold. In speed-density tunes, 
this data is used in conjunction with a temperature (IAT) sensor and the VE tables to 
determine the mass air flow.

In naturally aspirated engines, the pressure measured will be roughly 1 bar (14.7 psi / 
100 kPa), which is the normal pressure of the air we breathe at sea level. Therefore, 
these engines typically use a "1 bar" MAP sensor. Components such as turbochargers 
and superchargers that force more air into the engine increase the pressure 
measured and may require a MAP sensor rated for more than 1 bar.
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MASS AIR FLOW (MAF) SENSOR
MAF sensors measure the mass of air entering the throttle body. Some engines use 
this type of device to measure the mass air flow directly rather than (or in addition 
to) using speed density techniques to determine it by calculation. 

Engines with MAF sensors typically have a MAF Calibration Table to translate the signal 
level (a voltage or a frequency) coming out of the MAF sensor to the amount of airflow 
represented by that signal.

POWERTRAIN CONTROL MODULE (PCM)
In some vehicles, a single computer is responsible for controlling both the engine and 
the transmission. In such vehicles, this computer is called the PCM. Other vehicles 
have a separate Engine Control Module (ECM) and Transmission Control Module 
(TCM).

PULSE WIDTH
The amount of time (in mill iseconds or microseconds) a fuel injector remains open. 
Varying pulse width is typically how engines control the amount of fuel being injected 
into the cylinder.

SPARK ADVANCE
The timing of the spark provided by the spark plugs. Spark plugs typically ignite while 
the piston is moving upward towards the top of the cylinder. Spark advance is how far 
before the piston reaches the top that the spark plugs ignite. It is usually measured as 
a number of degrees of crankshaft rotation. So, a spark advance of 10 would indicate 
that ignition occurs when crankshaft rotation is 10 degrees before the piston reaches 
top dead center.
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SPEED-DENSITY
A mode of operation that calculates the mass of air present in the cylinder rather than 
measuring the mass air flow. The calculation is based on air temperature and pressure 
gathered from the sensors as well as the values in the VE table(s).

TRANSMISSION CONTROL MODULE (TCM)
In some vehicles, the TCM is the computer that is primarily responsible for controlling 
the operation of the transmission. Other vehicles have a Powertrain Control Module 
(PCM) that controls both the engine and the transmission.

VARIABLE VALVE TIMING (VVT)
In a typical engine with fixed cams, the valve timing remains the same, regardless of 
engine speed and other conditions. This tends to create a sweet spot, where 
performance and emissions are best at a particular rpm.

Engines with variable valve timing can vary the timing of their intake and exhaust 
valves in order to achieve more optimal results across the board. This is typically 
achieved by rotating their cams to a position appropriate for the current rpm.

VEHICLE CONTROL MODULE (VCM)
The computer that is primarily responsible for engine   and transmission operation. In 
some vehicles, there is a single Powertrain Control Module (PCM) that controls both 
the engine and the transmission. In other vehicles, there are actually two   modules: an 
Engine Control Module (ECM) and a Transmission Control   Module (TCM).
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VOLUMETRIC EFFICIENCY (VE)
The actual amount of air flowing through the cylinders, compared to the theoretical 
maximum they can hold.

In naturally aspirated engines, VE is normally less than 100%. Components that force 
air into the cylinders (turbos, superchargers, etc.) may boost VE above 100%.
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