Jeep YJ LY6 6.0L swap wiring issue - LS1TECH - Camaro and Firebird Forum Discussion



Conversions & Hybrids LSX Engines in Non-LSX Vehicles
Sponsored by:
Sponsored by:

Jeep YJ LY6 6.0L swap wiring issue

Reply
 
Thread Tools Search this Thread
Old 12-16-2016, 04:21 AM   #1
Registered User
Thread Starter
 
Join Date: Dec 2016
Location: Texas
Posts: 2
Default Jeep YJ LY6 6.0L swap wiring issue

Hello everyome, long time viewer, first time poster. I'm having an LY6 6.0L out of a 2009 2500HD put into my 1987 Jeep YJ and my mechanic is having a few problems with the wiring. It currently runs and drives but we can't get the obdII port to work (no serial data) and we can't get the fan to turn on because the ground doesn't seem to be working on it. It also seems to be idling high but I have a feeling that has something to do with the maf sensor pinout or the wrong maf sensor all togetherbecause apparently the pinout was different from year to year. It's running an e38 and an SM465 manual trans. I had the wiring harness redone by Novak and the tune done by them as well. We've been trying to resolve the obdII port for some time with no luck and we're almost to the point of ordering a new harness from psi or something but I'd really not like to go that route so any help would be greatly appreciated! Thanks!
Andrew Miller is offline   Reply With Quote
Old 12-16-2016, 12:02 PM   #2
TECH Enthusiast
iTrader: (2)
 
tfi racing's Avatar
 
Join Date: Jun 2010
Location: Cedar,BC
Posts: 636
Default

What steps have you tried to find the cause of the OBDII port issue? How about pinning one in directly at the PCM to eliminate the harness wiring?
tfi racing is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
L92 wiring pinout, help n Jeep09 Generation IV External Engine 5 10-31-2017 08:18 PM
Ly6 swap startup issues magnumbk Conversions & Hybrids 8 09-12-2017 09:06 PM
Jeep YJ 5.3L swap (completed) Docked Wage Conversions & Hybrids 252 06-14-2017 05:43 PM
MAF sensor housing? Andrew Miller Conversions & Hybrids 1 12-25-2016 08:58 PM
can't connect to VCM daveS Generation IV External Engine 3 07-20-2016 08:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: