Notices
Dynamometer Results & Comparisons Dyno Records | Dyno Discussion | Dyno Wars

Huron Speed T4 V1 turbo kit dyno

 
Old 02-21-2018, 10:00 AM
  #1  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default Huron Speed T4 V1 turbo kit dyno

This is the latest dyno for my car after going to E85 with this kit. I am wanting to either go to a T6 or twin turbo kit from them, I feel like this T4 is holding me back some. Build on car is:

LME 408, LJMS cam,TEA TFS245s, LS6 intake, ID1700s, Twin Walbro 450s, Huron Speed V1 T4 Turbo kit with Borg Warner S480 turbo.


necrocannibal is offline  
Old 02-22-2018, 10:45 AM
  #2  
On The Tree
iTrader: (8)
 
INIT2WIN's Avatar
 
Join Date: Apr 2007
Location: Lafayette, LA
Posts: 167
Default

How much boost and what trans is in the car?
INIT2WIN is offline  
Old 02-22-2018, 10:51 AM
  #3  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by INIT2WIN View Post
How much boost and what trans is in the car?
It's a 6 speed and that was on roughly 20 pounds. I think the T4 flange is holding it back on that many cubes.
necrocannibal is offline  
Old 02-22-2018, 10:33 PM
  #4  
On The Tree
 
T.Man's Avatar
 
Join Date: Oct 2010
Location: Desert
Posts: 120
Default

Pretty bad ***! What's traction like?
T.Man is offline  
Old 02-23-2018, 09:00 AM
  #5  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by T.Man View Post
Pretty bad ***! What's traction like?
Well the suspension was set up right by whoever had it before. With Mickey Thompson ET Street Radials it isn't too bad in second gear on, first is obviously useless.
necrocannibal is offline  
Old 02-23-2018, 11:24 AM
  #6  
TECH Junkie
iTrader: (14)
 
Join Date: Feb 2004
Location: MA
Posts: 3,912
Default

what size cam?
RealQuick is offline  
Old 02-23-2018, 11:27 AM
  #7  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by RealQuick View Post
what size cam?
Don't know the exact specs on it but it is a LJMS cam that was told to me to be about stage 3, whatever that means.
necrocannibal is offline  
Old 02-28-2018, 01:02 PM
  #8  
Staging Lane
iTrader: (9)
 
FrankieD's Avatar
 
Join Date: Dec 2008
Location: Richmond Hill, Ont, Canada
Posts: 80
Default

Sure looks like an exhaust back pressure issue. What is your exhaust setup from the turbo back?
FrankieD is offline  
Old 02-28-2018, 01:07 PM
  #9  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by FrankieD View Post
Sure looks like an exhaust back pressure issue. What is your exhaust setup from the turbo back?
4 inch pipe dumped right off the turbo through a cut out. With it being a 408 I assumed the T4 flange would be holding it back more than anything no?
necrocannibal is offline  
Old 02-28-2018, 02:21 PM
  #10  
Staging Lane
iTrader: (9)
 
FrankieD's Avatar
 
Join Date: Dec 2008
Location: Richmond Hill, Ont, Canada
Posts: 80
Default

Seeing you have a 4 inch straight dump it is looking like the T4 housing is the issue,
How about any possibility of valve float ? at 20psi are your valve springs appropriate?
FrankieD is offline  
Old 02-28-2018, 02:29 PM
  #11  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by FrankieD View Post
Seeing you have a 4 inch straight dump it is looking like the T4 housing is the issue,
How about any possibility of valve float ? at 20psi are your valve springs appropriate?
Now that you say that I am not sure about the valve springs. The heads are TEA TFS245s and I just assumed the springs would be ok. I got the heads from someone on here, they were new in the box, and I asked him about the springs and he said they were going to go on his boosted truck so I just assumed they were ok. Maybe I need to look into that but I thought for sure my T4 flange was holding me back up top.
necrocannibal is offline  
Old 02-28-2018, 04:24 PM
  #12  
Staging Lane
iTrader: (9)
 
FrankieD's Avatar
 
Join Date: Dec 2008
Location: Richmond Hill, Ont, Canada
Posts: 80
Default

"Assembled CNC-ported LS1 heads come equipped with 1.300" dual valve springs (for hydraulic roller camshafts up to .625" of valve lift), Viton canister-style valve seals, 7 machined steel valve locks, and 7 titanium retainers."

These may be questionable.

May want to look at what springs you really have

Last edited by FrankieD; 02-28-2018 at 04:32 PM.
FrankieD is offline  
Old 02-28-2018, 04:37 PM
  #13  
Staging Lane
iTrader: (9)
 
FrankieD's Avatar
 
Join Date: Dec 2008
Location: Richmond Hill, Ont, Canada
Posts: 80
Default

according to Trickflow website the springs should be good to .700
https://www.trickflow.com/parts/tfs-3061t003-c74

this is getting to be confusing
FrankieD is offline  
Old 03-01-2018, 07:52 AM
  #14  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by FrankieD View Post
according to Trickflow website the springs should be good to .700
https://www.trickflow.com/parts/tfs-3061t003-c74

this is getting to be confusing
Yeah tell me about it. It is one of the reasons I hate buying parts form an individual instead of new from a dealer. I am not sure exactly what springs are in it but the guy told me they were good for boost and I am thinking I remember him saying .700 but not exactly sure now. I got them for a good amount less than buying new from a dealer though.
necrocannibal is offline  
Old 03-01-2018, 07:58 AM
  #15  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

What is kind of odd is the shop that did the work and tuning didn't say anything about it to me after they tuned it. The only thing they said was needed to upgrade my coils because anything above about 20 psi it misfires because my coils are old and not strong enough to run that much boost. They said to get some LS3 coils since they will pretty much bolt right in.
necrocannibal is offline  
Old 03-01-2018, 08:53 AM
  #16  
Banned
iTrader: (2)
 
Join Date: May 2008
Location: South Florida
Posts: 11,291
Default

necrocannibal,

What size wheels are in that turbo....compressor and turbine..?

.
LS6427 is offline  
Old 03-01-2018, 09:02 AM
  #17  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by LS6427 View Post
necrocannibal,

What size wheels are in that turbo....compressor and turbine..?

.
It is a billet 96mm turbine wheel and 1.25 A/R exhaust housing. It was the largest T4 I could get to be a direct fit on the kit I have.
necrocannibal is offline  
Old 03-01-2018, 02:54 PM
  #18  
Banned
iTrader: (2)
 
Join Date: May 2008
Location: South Florida
Posts: 11,291
Default

Originally Posted by necrocannibal View Post
It is a billet 96mm turbine wheel and 1.25 A/R exhaust housing. It was the largest T4 I could get to be a direct fit on the kit I have.
I have the Huron Speed V2 A/C T4 single turbo kit. Not sure if yours is the A/C type kit.

I was hoping to make over 1,000 RWHP also....... But doesn't look like it'll happen with a T4. Unless I do a little modding and use the Borg Warner ETR 85/96 with V1 race cover from Forced Inductions. JZ estimated I could make 1,300 RWHP on my 390ci. Even if that isn't possible, anything over 1,000 would be nice.

Yours made some kick *** power though.....good job.

.
LS6427 is offline  
Old 03-01-2018, 02:58 PM
  #19  
10 Second Club
Thread Starter
iTrader: (5)
 
necrocannibal's Avatar
 
Join Date: Jan 2003
Location: Memphis,TN
Posts: 1,473
Default

Originally Posted by LS6427 View Post
I have the Huron Speed V2 A/C T4 single turbo kit. Not sure if yours is the A/C type kit.

I was hoping to make over 1,000 RWHP also....... But doesn't look like it'll happen with a T4. Unless I do a little modding and use the Borg Warner ETR 85/96 with V1 race cover from Forced Inductions. JZ estimated I could make 1,300 RWHP on my 390ci. Even if that isn't possible, anything over 1,000 would be nice.

.

Yeah I am in the same boat as you, I wanted to get to 1000 with this set up but I don't think the T4 flange is going to get there. I am planning on pulling this kit off and just doing twin 76s or something and making sure it gets over 1000.
necrocannibal is offline  
Old 10-22-2018, 06:16 PM
  #20  
TECH Fanatic
iTrader: (5)
 
pyro719's Avatar
 
Join Date: Aug 2007
Location: colorado springs Elevation: 6035 ft
Posts: 1,051
Default

Got any pics of the s480 on the V1 huron kit? I have the same kit and looking to go to a s480 from a billet 7875
pyro719 is offline  

Thread Tools
Search this Thread

About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: