Go Back  LS1TECH - Camaro and Firebird Forum Discussion > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Forced Induction
Reload this Page >

NEW Best - 403/D1SC with twin 4.5" coolers/4L60E/3800#/9.82 et/139mph

Notices
Forced Induction Superchargers | Turbochargers | Intercoolers

NEW Best - 403/D1SC with twin 4.5" coolers/4L60E/3800#/9.82 et/139mph

 
Old 09-30-2009, 10:49 AM
  #1  
9 Second Club
Thread Starter
iTrader: (94)
 
helicoil's Avatar
 
Join Date: Aug 2006
Posts: 1,518
Likes: 0
Received 0 Likes on 0 Posts
Default NEW Best - 403/D1SC with twin 4.5" coolers/4L60E/3800#/9.82 et/139mph

Made it to the track again last night. After some more tuning/tweeking I got the old turd to break into the 9's.

Made three runs.

10.10 @ 139, 1.58 60' spinning
10.02 @ 136 1.50 60'
9.82 @ 138 1.46 60' shock adjustments

http://s160.photobucket.com/albums/t...1013992909.flv

http://s160.photobucket.com/albums/t...1369592909.flv



http://s160.photobucket.com/albums/t...8213892909.flv


For those not familiar with my car. The basic combo is as follows. This car is 100% street car with AC.

403 LS2
AFR 225
FAST 90
EPP cam
4L60E/PY3600
3.70 rear
27x11.5 QTP
1 7/8" Kooks with 3.5" cut-out
D1SC with twin 4.5" coolers/SDCE
Methanol injection

The only weight reduction is drag wheels (Bogart D10's). 3800# plus raceweight. Many things have been added to this car, but very few things have been removed.

I will get some vids up tonight.
Attached Thumbnails NEW Best - 403/D1SC with twin 4.5" coolers/4L60E/3800#/9.82 et/139mph-9-sec-slip.jpg  

Last edited by helicoil; 09-30-2009 at 09:39 PM. Reason: vids added
helicoil is offline  
Old 09-30-2009, 10:52 AM
  #2  
10 Second Club
iTrader: (24)
 
'Trust''s Avatar
 
Join Date: Aug 2004
Location: Eternity
Posts: 7,978
Likes: 0
Received 0 Likes on 0 Posts
Default

Heck yea man! Another 4L60E car in the 9's . I'll be going back Friday with a new converter, hopefully my problems are solved. Awesome work.

What do you have your shocks setup? Mine are 3 in the front, 5 in the rear for the track. But it comes down a little hard and I scraped the pan/header so I'm curious to see what you're at.
'Trust' is offline  
Old 09-30-2009, 10:55 AM
  #3  
TECH Enthusiast
iTrader: (4)
 
Join Date: Nov 2005
Location: Florida
Posts: 712
Likes: 0
Received 0 Likes on 0 Posts
Default

Wow! awesome! Ive been wondering how many people run the twin 4.5" intercoolers successfully. Great time.
Hi-Po is offline  
Old 09-30-2009, 10:56 AM
  #4  
10 Second Club
iTrader: (24)
 
'Trust''s Avatar
 
Join Date: Aug 2004
Location: Eternity
Posts: 7,978
Likes: 0
Received 0 Likes on 0 Posts
Default

ATI twins FTW!
'Trust' is offline  
Old 09-30-2009, 11:00 AM
  #5  
TECH Enthusiast
iTrader: (4)
 
Join Date: Nov 2005
Location: Florida
Posts: 712
Likes: 0
Received 0 Likes on 0 Posts
Default

Do you have the SA or DA shocks? Brand? Whats the details on the bottom end?
Hi-Po is offline  
Old 09-30-2009, 11:10 AM
  #6  
TECH Fanatic
iTrader: (12)
 
T/A KID's Avatar
 
Join Date: Jul 2004
Posts: 1,798
Likes: 0
Received 0 Likes on 0 Posts
Default

How do you like that PY3600, just sent back my py3400 and turned it into a py3600.

Also times for such heavy weight.
T/A KID is offline  
Old 09-30-2009, 11:47 AM
  #7  
TECH Fanatic
iTrader: (2)
 
lt170chevelle's Avatar
 
Join Date: Jul 2006
Location: BS,TX
Posts: 1,153
Likes: 0
Received 0 Likes on 0 Posts
Default

wow man those are some good times for that weight! How much boost are you running?
lt170chevelle is offline  
Old 09-30-2009, 03:25 PM
  #8  
12 Second Club
iTrader: (19)
 
Join Date: Mar 2005
Location: Waco, TX
Posts: 3,081
Likes: 0
Received 0 Likes on 0 Posts
Default

Damn awesome time man! Congrats. Have a dyno sheet.. I'd like to see the hp and tq.
LS1RedZ is offline  
Old 09-30-2009, 04:02 PM
  #9  
TECH Regular
iTrader: (19)
 
02 z/28's Avatar
 
Join Date: Feb 2006
Posts: 487
Likes: 0
Received 0 Likes on 0 Posts
Default

congrats,tell us more about your suspension setup
02 z/28 is offline  
Old 09-30-2009, 05:34 PM
  #10  
11 Second Club
iTrader: (6)
 
Join Date: Jun 2004
Location: Ann Arbor, MI
Posts: 419
Likes: 0
Received 0 Likes on 0 Posts
Default

Congrats!

Glad to see you put her in the 9's.

This car is one of a kind for sure, ultimate sleeper. Probably the cleanest car I have seen outside of a showroom.

Wish I could have put it in my garage.

Did you end up swaping out the converter to get these new times?
Bill'sWS6 is offline  
Old 09-30-2009, 05:34 PM
  #11  
8 sec potential, 12 sec slip
iTrader: (50)
 
ChevyChad's Avatar
 
Join Date: Apr 2002
Location: Savannah, GA
Posts: 4,093
Likes: 0
Received 0 Likes on 0 Posts
Default

Huge congratz man!! Very nice setup ya got there
ChevyChad is offline  
Old 09-30-2009, 07:16 PM
  #12  
10 Second Club
iTrader: (18)
 
WS6 SRT-8's Avatar
 
Join Date: Oct 2006
Location: Imperial MO.
Posts: 579
Likes: 0
Received 0 Likes on 0 Posts
Default

Congrats on the time. It was good talking to you last night. You'll have to ask Jason if he heard my clutch slipping on the 10.90 pass. Holy crap. I think I'm a little past what the Powergrip HD likes. Probably could've been a .70 or so. Oh well. I'm sure there were alot of new bests with the weather like it was. I hope your glad you kept it now.
WS6 SRT-8 is offline  
Old 09-30-2009, 08:25 PM
  #13  
9 Second Club
Thread Starter
iTrader: (94)
 
helicoil's Avatar
 
Join Date: Aug 2006
Posts: 1,518
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by 'Trust' View Post
Heck yea man! Another 4L60E car in the 9's . I'll be going back Friday with a new converter, hopefully my problems are solved. Awesome work.

What do you have your shocks setup? Mine are 3 in the front, 5 in the rear for the track. But it comes down a little hard and I scraped the pan/header so I'm curious to see what you're at.
Yeah, my converter is working pretty well, I had my PY3400 loosened to a 3600, I think it worked better with the tune up at 9# though. Now that it is at 14# I think it is borderline. My trap speed is pretty good for the weight and et, it is just that the RPM graph looks like it would benefit from a tighter one. It would be nice to have the PY3400 to try again now, but I am not going back. The PY3600 flashes pretty high, thus the reason I am spinning the tires a bit. Before the pulley swap it stuck like glue. If I get a few more runs on it I should be able to line out the chassis better to handle the new power.

I have stock front suspension minus the front bar being removed. The rears are set on 5 also, at least now.


Originally Posted by Hi-Po View Post
Do you have the SA or DA shocks? Brand? Whats the details on the bottom end?
SA HALs

Bottom end details can be found here.

https://ls1tech.com/forums/forced-in...et-driver.html

Originally Posted by T/A KID View Post
How do you like that PY3600, just sent back my py3400 and turned it into a py3600.

Also times for such heavy weight.
The jury is still out. I changed several things since I ran the 10 teens last fall with the PY3400 at 700' DA. During the summer months I have been in the 10.40's with the 9# tune, which was making about 7.8# peak at 6300 RPM. I changed the exhaust around a bit and had the converter loosened a couple of months back because I had noticed my RPM drop between gear changes was around 1400 with the PY3400. With the PY3600 they were about 900 RPM at the 9# set up, but loosening it didn't do anything for the ET. Still went 10.40's at 2600-2800 DA back to back weekends a month or so ago in 85 degree weather.

Originally Posted by lt170chevelle View Post
wow man those are some good times for that weight! How much boost are you running?
Thanks, last night I was at 14# at 6700 RPM. DA was very low, about 600'. I run a 7.25 crank and a Riechard 3.2 head unit pulley. I have 0 belt slip with the set up currently.

Originally Posted by LS1RedZ View Post
Damn awesome time man! Congrats. Have a dyno sheet.. I'd like to see the hp and tq.
Not big on the dyno. It has made 680 RWHP on 12# un-locked for reference through the 9" and 609 RWHP at 9#. Tuning was done on the track last night. The first run was a little aggressive (21* and 11.5:1), the next two were scaled back a bit on timing and were richer - 10.4:1 AFR

Originally Posted by 02 z/28 View Post
congrats,tell us more about your suspension setup
Stock front end, no sway bar.
Rear:
BMR torque arm/crossmember mount - 5 holes up from bottom
Adjustable LCA - extended lower mounts on rear
SA rear shocks - set at 5 clicks, been anywhere from 3 to 7
BMR Extreme rear Drag bar
Hoosier QTP's 27x11.5 - 14psi

Originally Posted by Bill'sWS6 View Post
Congrats!

Glad to see you put her in the 9's.

This car is one of a kind for sure, ultimate sleeper. Probably the cleanest car I have seen outside of a showroom.

Wish I could have put it in my garage.

Did you end up swaping out the converter to get these new times?
Thanks, and Yes on the converter, but not to the 4000SS. You could have a had nice 9 sec sleeper. How is your New one doing?

Originally Posted by WS6 SRT-8 View Post
Congrats on the time. It was good talking to you last night. You'll have to ask Jason if he heard my clutch slipping on the 10.90 pass. Holy crap. I think I'm a little past what the Powergrip HD likes. Probably could've been a .70 or so. Oh well. I'm sure there were alot of new bests with the weather like it was. I hope your glad you kept it now.
I will, the air was really good last night, although the humidity was High, the DA was still very low with the 50 degree temps. Couldn't have asked for too much better. Fall is nice! The track could have been better on the starting line though, many of the fast cars were spinning. Basically, Gateway sucks, and has for years. Personnel is the problem.

Congrats on the 10's BTW!
helicoil is offline  
Old 10-01-2009, 10:12 AM
  #14  
10 Second Club
 
Join Date: Dec 2008
Location: Stl, Mo Area
Posts: 620
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by helicoil View Post
Yeah, my converter is working pretty well, I had my PY3400 loosened to a 3600, I think it worked better with the tune up at 9# though. Now that it is at 14# I think it is borderline. My trap speed is pretty good for the weight and et, it is just that the RPM graph looks like it
The first run was a little aggressive (21* and 11.5:1), the next two were scaled back a bit on timing and were richer - 10.4:1 AFR

How did you get away with so much timeing? I'm at 12 degrees running 93, 9.8 to 10.5 afr.
01Z28Camaro is offline  
Old 10-01-2009, 10:49 AM
  #15  
10 Second Club
iTrader: (24)
 
'Trust''s Avatar
 
Join Date: Aug 2004
Location: Eternity
Posts: 7,978
Likes: 0
Received 0 Likes on 0 Posts
Default

I'm on 21*, 9.62 CR, 93+Meth. I need to get it backed down for the street after this weekends set of videos. Sorry for the
'Trust' is offline  
Old 10-01-2009, 12:16 PM
  #16  
9 Second Club
Thread Starter
iTrader: (94)
 
helicoil's Avatar
 
Join Date: Aug 2006
Posts: 1,518
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by 01Z28Camaro View Post
How did you get away with so much timeing? I'm at 12 degrees running 93, 9.8 to 10.5 afr.
At 9# (3.55 pulley) of boost it was happy at 21 with meth of course. With the 3.2 pulley it doesn't like it, I actually pushed some water on that first pass (first time).

On the second pass, the 10.02, I backed it down to 16* and added some fuel and it ran pretty good (no water) lost a little MPH. Then for the third pass (the 9.82) I put it up 2 degress to 18* and took out a little of the fuel I added in the PE/boost tables on the second pass. Still no water. Seems to be happy here at this boost level (14.5#) in the really good air. I ran it RICH, as I am not convinced it needs to be up at 11.5:1 to run good with the meth. The target AFR will come down a bit the more meth that is sprayed. As it gets warmer I may have to change it again.

I actually doubled the surface area of my met nozzles when I changed to the 3.2 pulley. So now I am running two #14's instead of two #6's.

According to the knock sensors, there has been no knock, but I don't trust them on the LS2 really at all. I adjust off of performance, the LM1 and look at the plugs every now and again.

Monitoring the water push also works well.
helicoil is offline  
Old 10-01-2009, 12:18 PM
  #17  
9 Second Club
Thread Starter
iTrader: (94)
 
helicoil's Avatar
 
Join Date: Aug 2006
Posts: 1,518
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by 'Trust' View Post
I'm on 21*, 9.62 CR, 93+Meth. I need to get it backed down for the street after this weekends set of videos. Sorry for the
I am also running 93 octane, not sure I mentioned that earlier. Do you run a single nozzle or dual set up, what size nozzles and what is your pump output rated at for psi?
helicoil is offline  
Old 10-01-2009, 12:20 PM
  #18  
10 Second Club
iTrader: (24)
 
'Trust''s Avatar
 
Join Date: Aug 2004
Location: Eternity
Posts: 7,978
Likes: 0
Received 0 Likes on 0 Posts
Default

I wish I knew all that, just a single nozzle kit from Alkycontrol. I told Julio what it was for and he said it would take care of it. Lol, sorry for the nonspecifics.
'Trust' is offline  
Old 10-01-2009, 12:28 PM
  #19  
TECH Resident
iTrader: (23)
 
Join Date: Oct 2008
Location: Rhode Island
Posts: 994
Likes: 0
Received 0 Likes on 0 Posts
Default

wow! between you and trust i think i might have to upgrade to the 4.5's. anyone know where i can get just the 4.5's?

congrads! so i guess your temps are fine? no overheating at all?
airforcemanss is offline  
Old 10-01-2009, 12:39 PM
  #20  
9 Second Club
Thread Starter
iTrader: (94)
 
helicoil's Avatar
 
Join Date: Aug 2006
Posts: 1,518
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by airforcemanss View Post
wow! between you and trust i think i might have to upgrade to the 4.5's. anyone know where i can get just the 4.5's?

congrads! so i guess your temps are fine? no overheating at all?
Thanks, no real problems with IATs. On those passes they were 120 to start and then dropped to 78 or so at onset of meth and towards the end of the run they were slowly creeping into the mid/high 80's.

I run straight meth. They could maybe be cooler with a mix of water/meth.
helicoil is offline  

Thread Tools
Search this Thread
Quick Reply: NEW Best - 403/D1SC with twin 4.5" coolers/4L60E/3800#/9.82 et/139mph


About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: