Ddnspider's D1SC Build Thread- Screw Turbo's!!! - LS1TECH - Camaro and Firebird Forum Discussion



Forced Induction Superchargers | Turbochargers | Intercoolers
Sponsored by:
Sponsored by:

Ddnspider's D1SC Build Thread- Screw Turbo's!!!

Reply
 
Thread Tools Search this Thread
Old 12-12-2016, 10:23 AM   #1
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default Ddnspider's D1SC Build Thread- Screw Turbo's!!!

I kiiid I kiiiid, I love turbo's! I've played with turbo's, N2O wet and dry, H/C, etc., but I've never played with or been in a centrifugal/Procharged car before. I sold my 98 turbo trans am awhile back with the intention of taking a break from cars....that didn't last long when I came across the cleanest F-Body I've ever seen in person inside and out and the price was right so I jumped on it. He has all the original documentation from the window stick and SLP order sheet, to the mods receipts with dyno graph. Current mods:

Yank SS3600
Futral F13 cam with titanium retainers, Patriot double valve springs, etc.
Pacesetter coated 1 3/4" headers
Borla catback with the bypass plate, I may add an electric cutout at some point
LS6 intake and SLP lid

I added:
SFC's
adjustable LCA's
new BTR 660" springs since the old springs had 20k miles on them
TA girdle for the 10 bolt
FTRA

The previous owner went back to back 11.9's in the car back in 2009 or something. According to him the car always had trouble idling with the cam and surged including during the test drive. I did a complete retune of the car and she drives like stock now (minus the slushiness of the stall). My wife has no issues hopping in and driving it. I finally got it to the track a couple weeks ago and had all sorts of traction issues, but still managed an 12.1 so I feel comfortable that its solid enough for the blower to go on.


Here's a couple photo's:






I'm keeping it clean and going with black cold side piping and a black FMIC with black vacuum lines. I'll be putting a filter on the bypass valve to quiet it down a bit. Build list:

CX Racing 31x11x3 black bar and plate FMIC
Black 3" FMIC kit with black couplers
D1SC kit bought from a member on here that included the 8 rib upgrade, a 4.5" and 3.4" pulleys along with fuel pumps, bypass valve, inlet, filter, etc.
Siemens 60lb injectors
Prerequisite ATI balancer that costs a million bucks lol
I'm going to use 2 LT1 fans and make a shroud so I can keep them as "stockish" pullers cause stock fans rulle
I'm also going to fit the stock LS1 coolant crossover under the LS6 intake (not going to argue this, I think it helps and to each his own)


Let the build begin!
ddnspider is online now   Reply With Quote
Old 12-12-2016, 10:24 AM   #2
TECH Fanatic
iTrader: (7)
 
ls1charged's Avatar
 
Join Date: May 2005
Location: FL
Posts: 1,409
Default

Hater!
ls1charged is offline   Reply With Quote
Old 12-12-2016, 10:34 AM   #3
TECH Resident
iTrader: (8)
 
mOtOrHeAd MiKe's Avatar
 
Join Date: Mar 2007
Location: Ottawa Ontario, Canada - where arguing "DA" is for the slow and weak...
Posts: 776
Default

I love me some D1SC.
mOtOrHeAd MiKe is offline   Reply With Quote
Old 12-12-2016, 11:18 AM   #4
TECH Enthusiast
 
svslow's Avatar
 
Join Date: Oct 2015
Location: Royal Oak, MI
Posts: 721
Default

So weird, my Dad's name is Mark Edwards and we had a car tuned by Mike a while back.
svslow is offline   Reply With Quote
Old 12-12-2016, 11:26 AM   #5
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default

Quote:
Originally Posted by mOtOrHeAd MiKe View Post
I love me some D1SC.
what's your setup?

Quote:
Originally Posted by svslow View Post
So weird, my Dad's name is Mark Edwards and we had a car tuned by Mike a while back.
haha that is random. Mikes a good dude.
ddnspider is online now   Reply With Quote
Old 12-12-2016, 07:07 PM   #6
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default

Fuel pump trap door ftw. anyone know what the extra port is on the outlet side of a walbro pump? it's a small port/nipple, but don't recall what it's used for.
ddnspider is online now   Reply With Quote
Old 12-12-2016, 10:41 PM   #7
TECH Fanatic
iTrader: (7)
 
ls1charged's Avatar
 
Join Date: May 2005
Location: FL
Posts: 1,409
Default

i believe its called the venturi port..... i lost the tube that was on mine and didnt replace it lol never had a problem so who knows
ls1charged is offline   Reply With Quote
Old 12-12-2016, 11:19 PM   #8
TECH Senior Member
iTrader: (5)
 
conan's Avatar
 
Join Date: May 2004
Location: 7,000ft
Posts: 6,403
Default

conan is offline   Reply With Quote
Old 12-13-2016, 07:38 AM   #9
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default

Quote:
Originally Posted by ls1charged View Post
i believe its called the venturi port..... i lost the tube that was on mine and didnt replace it lol never had a problem so who knows
hmm interesting. wish I knew what it was. I've got 2 walbros 1 with and 1 without the port.

ps....I'll leave this here
ddnspider is online now   Reply With Quote
Old 12-13-2016, 07:41 AM   #10
TECH Enthusiast
 
svslow's Avatar
 
Join Date: Oct 2015
Location: Royal Oak, MI
Posts: 721
Default

Similar to the weather here, except the 8 and 3 were used to describe the 8.3" of snow we got yesterday.
svslow is offline   Reply With Quote
Old 12-13-2016, 07:55 AM   #11
TECH Fanatic
iTrader: (7)
 
ls1charged's Avatar
 
Join Date: May 2005
Location: FL
Posts: 1,409
Default

found this on another GM forum, looks like its more for a cooling affect.... you dont typically run your car less then 1/4 tank so i wouldnt think it would matter.... like i said, been running mine for almost two years with no issue lol
Attached Thumbnails
Ddnspider's D1SC Build Thread- Screw Turbo's!!!-vent.jpg  
ls1charged is offline   Reply With Quote
Old 12-13-2016, 08:15 AM   #12
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default

Quote:
Originally Posted by svslow View Post
Similar to the weather here, except the 8 and 3 were used to describe the 8.3" of snow we got yesterday.
ouch! sorry to hear that. it's only right considering August and Sept you can cook an egg on the hood of a car lol


Quote:
Originally Posted by ls1charged View Post
found this on another GM forum, looks like its more for a cooling affect.... you dont typically run your car less then 1/4 tank so i wouldnt think it would matter.... like i said, been running mine for almost two years with no issue lol
I never even noticed when I had twin walbros in tank if they had the ports or not. The 1 pump I went to install last night had that nipple pop off so no idea.
ddnspider is online now   Reply With Quote
Old 12-13-2016, 12:43 PM   #13
TECH Resident
iTrader: (8)
 
mOtOrHeAd MiKe's Avatar
 
Join Date: Mar 2007
Location: Ottawa Ontario, Canada - where arguing "DA" is for the slow and weak...
Posts: 776
Default

Quote:
Originally Posted by ddnspider View Post
what's your setup?
https://ls1tech.com/forums/11-second...-tbss-11s.html

Meh.
mOtOrHeAd MiKe is offline   Reply With Quote
Old 12-13-2016, 12:54 PM   #14
TECH Fanatic
iTrader: (7)
 
ls1charged's Avatar
 
Join Date: May 2005
Location: FL
Posts: 1,409
Default

Quote:
Originally Posted by mOtOrHeAd MiKe View Post
how do you like that LS9 cam with the blower?
ls1charged is offline   Reply With Quote
Old 12-13-2016, 01:14 PM   #15
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default

Quote:
Originally Posted by mOtOrHeAd MiKe View Post
awesome! I <3 the TBSS.


Update...fuel pump finally done after sorting through fuel socks at advance auto.
ddnspider is online now   Reply With Quote
Old 12-13-2016, 01:33 PM   #16
TECH Fanatic
iTrader: (7)
 
ls1charged's Avatar
 
Join Date: May 2005
Location: FL
Posts: 1,409
Default

Quote:
Originally Posted by ddnspider View Post
awesome! I <3 the TBSS.


Update...fuel pump finally done after sorting through fuel socks at advance auto.
lol you should have told me, i kept the box with the part number for mine cause it took me forever in searching to find the right one haha
ls1charged is offline   Reply With Quote
Old 12-13-2016, 01:56 PM   #17
TECH Resident
iTrader: (8)
 
mOtOrHeAd MiKe's Avatar
 
Join Date: Mar 2007
Location: Ottawa Ontario, Canada - where arguing "DA" is for the slow and weak...
Posts: 776
Default

Quote:
Originally Posted by ls1charged View Post
how do you like that LS9 cam with the blower?
I am very happy with it - the ET and power are spot on. When I set out to build the truck I promised my wife it would still drive like stock, and it does.

Quote:
Originally Posted by ddnspider View Post
awesome! I <3 the TBSS.
Thanks!
mOtOrHeAd MiKe is offline   Reply With Quote
Old 12-14-2016, 04:19 PM   #18
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default

Update- got the ATI damper on....what a giant PITA and the instructions sucked big time. In addition, the hub is already keyed with a square hole, but the ATI crank pinning kit makes a round hole, also stupid. On the plus side I found out the old owner put a Powerbond 25% underdrive setup on it, so I'll be able to resell that and make some cash, but it also meant I had to get a new serpentine and ac belts. I'm also tempted to sell the Katech mechanical belt tensioner that came on the car to get some cash out of it, but wonder if I should keep it until I see what's up once the blower is installed.
ddnspider is online now   Reply With Quote
Old 12-15-2016, 02:59 PM   #19
Registered User
 
Join Date: Dec 2016
Posts: 1
Default

Ordering myself a d1sc in January.. I can't wait sounds like you guys love em!!
maunder is offline   Reply With Quote
Old 12-16-2016, 04:50 PM   #20
10 Second Club
Thread Starter
iTrader: (24)
 
ddnspider's Avatar
 
Join Date: Aug 2004
Location: FL
Posts: 5,450
Default

My goodness what a day. I got everything all torn down and ready for the next steps. Got the horns relocated too. Then everything went to crap. 1 of the studs that replace the alternator bolts decided to strip in the block....going to just tap both of them so both studs and bolts are all the same. Got a busy weekend so it may be a couple days before I make much progress.





ddnspider is online now   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mark's LS1 2nd Gen Camaro build Marktainium Conversions & Hybrids 555 01-04-2017 05:55 PM
Weld RTS 18"s on C6 Z06 Pics and info El_Diablo Corvette Performance 22 11-08-2015 09:44 PM
1999 Camaro SS, H/C 347, MWC fab 9", T56 BAADGOAT Vehicle Classifieds 12 04-14-2015 07:24 AM
Took some pictures this weekend... medwar11 Florida Members 5 07-28-2008 08:14 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:05 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send