Notices
Forced Induction Superchargers | Turbochargers | Intercoolers

81 fairmont -new project LSX turbo

 
Old 05-05-2018, 02:50 PM
  #121  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

Don't forget to put a cheapo kid size football in the pass side spring for full sloppy points!
truckdoug is offline  
Old 05-07-2018, 02:51 PM
  #122  
TECH Resident
iTrader: (2)
 
408GT's Avatar
 
Join Date: Jan 2008
Location: GA
Posts: 882
Likes: 0
Received 2 Likes on 2 Posts
Default

I think he (Denmah) ended up using kids softballs instead of the football.
408GT is online now  
Old 07-02-2018, 08:58 PM
  #123  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default

Sloppy 3rd gear spool mod all ready to go. I changed waste gate springs itís somewhere between 10-15lbs now. Track time this weekend......


68roadrunner is offline  
Old 07-19-2018, 12:43 PM
  #124  
TECH Apprentice
 
Join Date: Dec 2016
Location: Silsbee Tx
Posts: 333
Likes: 0
Received 1 Like on 1 Post
Default

any updates?
Kyle.t91 is offline  
Old 08-08-2018, 11:44 PM
  #125  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default

Originally Posted by Kyle.t91 View Post
any updates?
I went to the track and I kept blowing off intercooler pipes. Iím going to need to find a solution. The angles of some of the pipes are less than desirable. Iím going to have my buddy weld up some more of the joints that keep blowing so sheíll hold more boost.

on a side note Iíve taken the car on a 800 mile road trip last week. It did great and didnít skip a beat !

68roadrunner is offline  
Old 08-08-2018, 11:51 PM
  #126  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default









Also did some some ďrust slowing treatmentĒ hahaha
68roadrunner is offline  
Old 08-09-2018, 11:49 AM
  #127  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

hell yeah

or as my body guy says:

"bury it, don't marry it"
truckdoug is offline  
Old 10-12-2018, 07:46 PM
  #128  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default

Well I was on my way to the track today. I made a couple of long pulls on my way. The car started overheating and then motor locked up. looks like I blew a head gasket (15lbs) on the 7875. It was running like an absolute animal.

Gen 4 4.8 will be swapped in soon. I may also have circle D loosen up my converter as itís having trouble coming out of the hole.

68roadrunner is offline  
Old 10-12-2018, 08:10 PM
  #129  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

damn dude sorry to hear it

how are you launching it? when i had the 4.8 7875 combo it REALLY liked the revs.

I'd footbrake it about 3/4 throttle with the sloppy brake engaged, bump the second light. dump the sloppy brake on the first bulb and mat it.

you have to enable PE mode at like 50% throttle though

also helps to keep some timing in it until positive pressure. spark map looks like a cliff in 3D but it works really good.
truckdoug is offline  
Old 10-14-2018, 10:56 AM
  #130  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default

Originally Posted by truckdoug View Post
damn dude sorry to hear it

how are you launching it? when i had the 4.8 7875 combo it REALLY liked the revs.

I'd footbrake it about 3/4 throttle with the sloppy brake engaged, bump the second light. dump the sloppy brake on the first bulb and mat it.

you have to enable PE mode at like 50% throttle though

also helps to keep some timing in it until positive pressure. spark map looks like a cliff in 3D but it works really good.
truckdoug: I havenít had a chance to play with the sloppy spool mod much. Thanks for the tip ! Iíll try that when I get the thing back up and running.

Theres some metal shavings in the oil. And the damn thing Locked up pretty hard all of a suden. Iím concerned I may have also damaged the turbo. I guess my only option is to pump some oil in there and spin it a bit. If anyone has any suggestions for that thanks !

68roadrunner is offline  
Old 10-14-2018, 11:13 AM
  #131  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

when I killed a 4.8 by overheating (lost the WP belt) it spun a cab bearing and plugged the filter with glitter causing the filter to bypass a lot of debris and feed it direct to the turbo.

I ran a bunch of kerosene though it and it seemed okay. No more noticeable shaft play than usual. No smoke.

I gave that turbo to a friend and it immediately started spewing oil into the exhaust and intake.

Thats just one data point though.

I will say viren from VSR sold me a complete CHRA for it $289 shipped. He has them in stock, both the cast and billet wheels (which do not interchange as the compressor cover has a different contour where it meets the inducer.
truckdoug is offline  
Old 10-14-2018, 04:51 PM
  #132  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default

More bad news looks like turbo is shot as well
Doesnít turn freely , has resistance oh well
68roadrunner is offline  
Old 10-15-2018, 08:54 AM
  #133  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

ah man thats a bummer. was it blowing oil?
truckdoug is offline  
Old 10-16-2018, 11:25 AM
  #134  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default

Originally Posted by truckdoug View Post
ah man thats a bummer. was it blowing oil?
i donít think so.
Iím going to pull the turbo apart and check out the housing. If itís good Iíll just order a new center section.

alao because the motor locked up Iím sure it took out my cam too. Itís part of the fun right !
68roadrunner is offline  
Old 10-17-2018, 11:13 PM
  #135  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

ah man I have lost a cam before. fuggin sucks. cam cost more than the whole motor !
truckdoug is offline  
Old 10-21-2018, 09:53 PM
  #136  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default

Truckdoug: I think Iím going to go with another sloppy stage 2 it works great and I really just canít justify the added expense of lil John Motorsports stage 2 turbo cam.

Well we we pulled the motor and did some inspection. This thing was overheated like hell. You can tell by the heat bands on the cam and crank. I think it was a low oil pressure that took out the main bearings.

68roadrunner is offline  
Old 10-21-2018, 10:00 PM
  #137  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

my next cam is gonna be one of the shorter duration grinds like the 1839p

the dyno runs I did showed me its all about making that cylinder pressure!
truckdoug is offline  
Old 10-22-2018, 10:17 AM
  #138  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default


the 4.8 will make it's return BACK to the junkyard! haha

you can see the heat warping on the crank. The motor got crazy hot before it locked up. Unfortunately I don't have a temp or oil pressure gauge.

see bearings peaking out....
68roadrunner is offline  
Old 10-22-2018, 10:43 AM
  #139  
TECH Veteran
iTrader: (22)
 
truckdoug's Avatar
 
Join Date: Nov 2013
Location: Portlandia
Posts: 4,878
Received 2 Likes on 2 Posts
Default

gruesome!
truckdoug is offline  
Old 01-04-2019, 12:33 PM
  #140  
On The Tree
Thread Starter
 
Join Date: May 2007
Posts: 132
Likes: 0
Received 2 Likes on 2 Posts
Default





Guys could this have been the cause of the catastrophic failure ? I have 2 o rings on my ls1 fbody pickup

maybe I left the original o-ring on? And also installed the new one by mistake ?
68roadrunner is offline  

Thread Tools
Search this Thread
Quick Reply: 81 fairmont -new project LSX turbo


About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: