New fuel rails, now won't run - Page 2 - LS1TECH - Camaro and Firebird Forum Discussion

Notices
Fueling & Injection Fuel Pumps | Injectors | Rails | Regulators | Tanks
Sponsored by:
Sponsored by:

New fuel rails, now won't run

 
Old 11-09-2018, 10:16 PM
  #21  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default

Originally Posted by qweedqwag View Post
Pull the plugs and see it she turns over.
I pulled the plugs a couple days ago. She won't budge. Even trying to turn it by hand... FROZE
I also disconnected the battery and let it set over nite…..
2010Imperial is offline  
Old 11-09-2018, 11:13 PM
  #22  
TECH Senior Member
 
Join Date: Jun 2016
Location: Central Cal.
Posts: 9,359
Default

Tear-down time.....
G Atsma is online now  
Old 11-09-2018, 11:17 PM
  #23  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default

This is BS. How can I go from a perfectly running engine, to a locked up engine, just from doing a simple fuel rail swap???????????
2010Imperial is offline  
Old 11-09-2018, 11:23 PM
  #24  
Teching In
 
Join Date: Mar 2016
Posts: 46
Default

Originally Posted by 2010Imperial View Post
This is BS. How can I go from a perfectly running engine, to a locked up engine, just from doing a simple fuel rail swap???????????
Just a guess, but debris in new fuel rails got in an injector and caused an injector to stick open and hydrolock the engine. Does oil have a fuel smell to it? I would pull the injectors and test with a 9v battery to make sure they are all working.
Longblue is offline  
Old 11-09-2018, 11:31 PM
  #25  
TECH Senior Member
 
Join Date: Jun 2016
Location: Central Cal.
Posts: 9,359
Default

I said it earlier; it might be a coincidence. OR it could be hydro-lock. Either way, pull the heads and see what is going on, rather than persist trying to turn over a stuck engine. Speculation can go on forever....
G Atsma is online now  
Old 11-10-2018, 07:22 PM
  #26  
TECH Addict
 
Join Date: Mar 2013
Posts: 2,617
Default

Or something fell into the intake through one of the injector holes and now has a valve jammed open etc.
RockinWs6 is offline  
Old 11-10-2018, 08:18 PM
  #27  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default

Hopefully I can start tearing it down tomorrow night. And I am praying, whatever damage there might be, is limited to the top end. We will see.....
2010Imperial is offline  
Old 11-14-2018, 04:12 PM
  #28  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default

I have only had time to take the intake off. So far nothing suspicious. Heads are next. So if I am going that far, guess it's time for a cam/heads combo! Any suggestions? I've always said I would get a GPI cam and keep the VVT stuff...
2010Imperial is offline  
Old 11-15-2018, 10:29 AM
  #29  
Staging Lane
 
AUS Injection's Avatar
 
Join Date: Aug 2018
Posts: 85
Default

Before you go any farther, have your injectors checked to see if they're are clogged or stuck open from fuel rail debris. it would suck to tear down your motor and just find out it was debris in the injectors. LMK pm
AUS Injection is offline  
Old 11-15-2018, 11:02 AM
  #30  
TECH Senior Member
 
Join Date: Jun 2016
Location: Central Cal.
Posts: 9,359
Default

Originally Posted by AUS Injection View Post
Before you go any farther, have your injectors checked to see if they're are clogged or stuck open from fuel rail debris. it would suck to tear down your motor and just find out it was debris in the injectors. LMK pm
The engine is locked up. Hydraulic lock would only do that until it drains off. He has mechanical issues.
G Atsma is online now  
Old 11-15-2018, 11:05 AM
  #31  
Staging Lane
 
AUS Injection's Avatar
 
Join Date: Aug 2018
Posts: 85
Default

Originally Posted by G Atsma View Post
The engine is locked up. Hydraulic lock would only do that until it drains off. He has mechanical issues.
Gotcha, but regardless those injectors should get cleaned. Time and time again we always see customers with clogged injectors from using a brand new fuel rail. Hope you get it figured out and get her on the road again!
AUS Injection is offline  
Old 11-15-2018, 11:11 AM
  #32  
TECH Senior Member
 
Join Date: Jun 2016
Location: Central Cal.
Posts: 9,359
Default

Good points! I too hope he gets it going.
G Atsma is online now  
Old 11-15-2018, 08:30 PM
  #33  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default

Tomorrow the heads come off. Just double checking that I can safely rule out any computer BS being the problem? I don't want to have to buy new gaskets and bolts to find that out... Thanks for the well wishes!
2010Imperial is offline  
Old 11-16-2018, 09:41 PM
  #34  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default

I didn't get to the heads, raking leaves was a higher priority. But, I did notice when I took the intake off, there were some "pebbles" rattling around in there. Not to sure what they were when they fell out. I know there shouldn't be any thing like that rattling around in there, but anything is possible at this point!
2010Imperial is offline  
Old 11-16-2018, 09:50 PM
  #35  
TECH Senior Member
 
Join Date: Jun 2016
Location: Central Cal.
Posts: 9,359
Default

Did you save them? Are they metallic?
G Atsma is online now  
Old 11-17-2018, 07:42 PM
  #36  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default

No. I had the music cranked up and didn't notice it until pretty much they fell out. No telling what they were. So now I am stuck on one stripped header bolt. Everything else is apart and ready for the big reveal. I hope I see something.....
2010Imperial is offline  
Old 11-18-2018, 01:05 PM
  #37  
TECH Fanatic
 
Join Date: Jun 2003
Posts: 1,446
Default

Did you look or remove the mechanical fuel pump under the manifold to see if the drive mechanism for it failed?
dlandsvZ28 is offline  
Old 11-18-2018, 04:21 PM
  #38  
TECH Senior Member
 
Join Date: Jun 2016
Location: Central Cal.
Posts: 9,359
Default

Originally Posted by dlandsvZ28 View Post
Did you look or remove the mechanical fuel pump under the manifold to see if the drive mechanism for it failed?
Which mechanical pump? This is a Gen IV, not a Gen V. Gen IV's don't have a mechanical pump.
G Atsma is online now  
Old 11-19-2018, 12:27 PM
  #39  
Restricted User
 
Join Date: Mar 2014
Location: Ohio
Posts: 6,695
Default

Originally Posted by 2010Imperial View Post
There is no middle, or end to this story.
There is certainly a moral to the story, and a reason I still run factory rails on all of my setups.

JoeNova is offline  
Old 11-19-2018, 07:46 PM
  #40  
Staging Lane
Thread Starter
 
2010Imperial's Avatar
 
Join Date: May 2018
Posts: 64
Default


2010Imperial is offline  

Thread Tools
Search this Thread

About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: