Turn Signal Fuse Keeps Blowing (06 GTO) - LS1TECH - Camaro and Firebird Forum Discussion



General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

Turn Signal Fuse Keeps Blowing (06 GTO)

Reply
 
Thread Tools Search this Thread
Old 03-20-2017, 05:15 AM   #1
Teching In
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Default Turn Signal Fuse Keeps Blowing (06 GTO)

Turn signal fuses keeps blowing when engaging stick to reverse. Replaced the reverse light switch once, worked for a few weeks, then turn signal fuse blew again. Now, the fuse will keep blowing when car is engaged in reverse. All rear bulbs and sockets are fine. I have not checked the socket on reverse light switch, yet, but will in the next couple of days. Is this a short or a ground issue? Still a novice at all things electrical. Any suggestions or advice will help. Thank you.
Limbaga09 is offline   Reply With Quote
Old 03-20-2017, 02:03 PM   #2
TECH Addict
iTrader: (14)
 
chrysler kid's Avatar
 
Join Date: Feb 2005
Location: Mckinney Plano Frisco
Posts: 2,644
Default

Are you using any led bulbs? If so swap them for regular

Check bulb sockets for corrosion or damage wires
chrysler kid is offline   Reply With Quote
Old 03-20-2017, 07:12 PM   #3
Teching In
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Default Turn Signal Fuse Keeps Blowing

Turn signal fuses keeps blowing when engaging stick to reverse. Replaced the reverse light switch once, worked for a few weeks, then turn signal fuse blew again. Now, the fuse will keep blowing when car is engaged in reverse. All rear bulbs and sockets are fine. I have not checked the socket on reverse light switch, yet, but will in the next couple of days. Is this a short or a ground issue? Still a novice at all things electrical. Any suggestions or advice will help. Thank you.
Limbaga09 is offline   Reply With Quote
Old 03-20-2017, 07:18 PM   #4
Teching In
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Default

Quote:
Originally Posted by chrysler kid View Post
Are you using any led bulbs? If so swap them for regular

Check bulb sockets for corrosion or damage wires
No LED bulbs, just standards. As I mentioned in my post, no corrosion on any of the rear bulb sockets. They also passed the continuity test on the multimeter.
Limbaga09 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Left turn on as long as ignition is on but does flash with switch wore out Appearance & Detailing 1 05-29-2017 05:22 PM
02 WS6 Turn signals/reverse lights C598LS1 Pontiac Firebird 1967-2002 20 10-14-2016 04:08 PM
Signal fuse blows when put in reverse sdxp787 Stereo & Electronics 19 10-05-2016 07:47 AM
Keep blowing a fuse, no turn signals/back up lights ACDenali Stereo & Electronics 7 01-03-2016 05:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:39 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: