Lt1 383 stroker dying at wot. - LS1TECH - Camaro and Firebird Forum Discussion

Notices
LT1-LT4 Modifications 1993-97 Gen II Small Block V8

Lt1 383 stroker dying at wot.

Old 08-20-2018, 06:08 AM
  #1  
Teching In
Thread Starter
 
Join Date: Aug 2018
Posts: 7
Default Lt1 383 stroker dying at wot.

Lt1 dying at wot started running rough at idle. New plugs new coil newer icm. Figuring itís the opti but wanted to get some info.when it dies it does start right back up. Check engine light comes on and goes off while driving.
Humphries94z is offline  
Old 08-20-2018, 06:26 AM
  #2  
On The Tree
iTrader: (1)
 
Join Date: Apr 2008
Posts: 179
Default

Did you use a scanner to determine what the code was for the engine light?
Greg88 is offline  
Old 08-20-2018, 07:03 AM
  #3  
Teching In
Thread Starter
 
Join Date: Aug 2018
Posts: 7
Default

Have not yet. Do not have a cord currently. Iím trying to get one now.
Humphries94z is offline  
Old 08-20-2018, 09:51 AM
  #4  
Village Troll
iTrader: (2)
 
SS RRR's Avatar
 
Join Date: Oct 2002
Location: Jackstandican
Posts: 9,506
Default

Check fuel pressure. Your pump may be on its way out.
SS RRR is offline  
Old 08-20-2018, 11:24 AM
  #5  
Teching In
Thread Starter
 
Join Date: Aug 2018
Posts: 7
Default

Wouldnít it spit and spuder like itís running out of gas? This dies like someone shut a kill switch off
Humphries94z is offline  
Old 08-21-2018, 01:51 PM
  #6  
TECH Veteran
 
Join Date: Apr 2008
Posts: 4,343
Default

Originally Posted by Humphries94z View Post
newer icm.
how "newer"...and what brand?

typically a failed fuel pump the motor sputters/stumbles first then dies. Certainly check FP just to rule it in/out as the problem. If good move on to ignition.

immediate shut off is likely ignition...ICM, opti or coil...or wiring going to them
BALLSS is offline  
Old 08-21-2018, 02:56 PM
  #7  
Teching In
Thread Starter
 
Join Date: Aug 2018
Posts: 7
Default

Msd coil pry 2-3 weeks old, icm is pry a month old.
Humphries94z is offline  
Old 08-21-2018, 03:09 PM
  #8  
TECH Veteran
 
Join Date: Apr 2008
Posts: 4,343
Default

Originally Posted by Humphries94z View Post
icm is pry a month old.
is it a AC Delco ICM?
BALLSS is offline  
Old 08-21-2018, 06:09 PM
  #9  
Teching In
Thread Starter
 
Join Date: Aug 2018
Posts: 7
Default

No oriley special 91 bucks lol. I know I should spend the money on a delco
Humphries94z is offline  
Old 08-21-2018, 06:17 PM
  #10  
TECH Veteran
 
Join Date: Apr 2008
Posts: 4,343
Default

Originally Posted by Humphries94z View Post
No oriley special 91 bucks lol. I know I should spend the money on a delco
well I would not rule out the ICM then...

Certainly AC Delco anything can also fail....just off brand stuff has a higher fail rate
BALLSS is offline  
Old 08-21-2018, 06:18 PM
  #11  
Teching In
Thread Starter
 
Join Date: Aug 2018
Posts: 7
Default

When it does it itís like someone turns a power switch off. Engines dead right now! No spitting studering quits now
Humphries94z is offline  
Old 08-21-2018, 06:36 PM
  #12  
Village Troll
iTrader: (2)
 
SS RRR's Avatar
 
Join Date: Oct 2002
Location: Jackstandican
Posts: 9,506
Default

Now that it's dead, you can do a test to determine if the ICM/coil are getting a signal. Have you looked into the condition of your opti harness?

http://shbox.com/1/4th_gen_tech2.html#opti_test
SS RRR is offline  
Old 08-21-2018, 08:14 PM
  #13  
Teching In
Thread Starter
 
Join Date: Aug 2018
Posts: 7
Default

No no sorry. Engine is not dead it runs. Just dies under wot sometimes.
Humphries94z is offline  


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: