Just nervous about oil pressure - LS1TECH



New LS1 Owners - Newbie Tech Basic Technical Questions & Advice
Sponsored by:
Sponsored by:

Just nervous about oil pressure

Reply
 
Thread Tools Search this Thread
Old 02-01-2017, 07:26 AM   #1
Teching In
Thread Starter
 
Join Date: Jan 2017
Posts: 5
Default Just nervous about oil pressure

I need help. I'm new to the ls1 game. My car at start up runs 40 psi and wot 60. But warm idol about 25 to 30 psi at 209 degrees. No knocking or anything. It goes to 40 when I hit the gas. Car has 143 on her. Thanks for helping. Nervous just picked her up last weekend.

Last edited by Mike Whetzel; 02-01-2017 at 07:42 AM. Reason: Oil pressure
Mike Whetzel is offline   Reply With Quote
Old 02-01-2017, 01:18 PM   #2
LS1Tech Administrator
iTrader: (3)
 
RPM WS6's Avatar
 
Join Date: Nov 2001
Location: Lincolnwood, IL Member: #317
Posts: 22,702
Default

Sounds quite normal to me.

Auto trans cars have a bit lower OP readings at idle than manuals, as their idle speed in gear is 30% lower than manuals.

'98-'00 cars have the older oil pump, which also tends to show lower readings than '01+ cars with the revised LS6 pump.
RPM WS6 is offline   Reply With Quote
Old 02-01-2017, 02:14 PM   #3
Launching!
 
Join Date: Aug 2015
Posts: 263
Default

That sounds like where mine is. Once it warms up the viscosity changes and the pressure reflects that. I hope you aren't going WOT before the car warms up, though. lol
SouthernRex is offline   Reply With Quote
Old 02-01-2017, 06:37 PM   #4
12 Second Club
iTrader: (2)
 
murphinator's Avatar
 
Join Date: Sep 2009
Location: southern Maine
Posts: 1,602
Default

my 98 is on the low side like yours been like that since I got it about 3.5 years ago , has 155k now haven't hurt it yet and its still quiet cold , hot ,etc...
murphinator is offline   Reply With Quote
Old 02-01-2017, 08:18 PM   #5
TECH Enthusiast
 
Cajun ELESS-ONE's Avatar
 
Join Date: Jan 2013
Location: Thibodaux LA
Posts: 525
Default

seems normal to me. as long as its over 15-20 psi and hot idle its good. if it concerns you, get a melling standard volume high pressure pump and put it in. not to hard to install.
Cajun ELESS-ONE is offline   Reply With Quote
Old 02-02-2017, 02:49 PM   #6
TECH Regular
 
Michael Yount's Avatar
 
Join Date: Jun 2015
Posts: 400
Default

Data point -- brand new LS3 crate engine -- @ 210F oil temp, 28-35 psig idle, rev the motor and instant increases up to 60-65 psig depending on rpm.
Michael Yount is online now   Reply With Quote
Old 02-02-2017, 08:22 PM   #7
Pontiacerator
iTrader: (12)
 
RevGTO's Avatar
 
Join Date: Nov 2003
Location: Wichita KS / Rancho San Diego
Posts: 5,071
Default

Also the ribs on the inside of the pressure sender wear over time, giving lower readings. My pressure bumped up when it was replaced during a rear main seal job.
RevGTO is offline   Reply With Quote
Old 02-02-2017, 09:16 PM   #8
Teching In
 
Join Date: Jan 2017
Posts: 19
Default

My 06 with 143k on it sits about the same and I haven't had any issues. I do think I have a lifter problem now that starts ticking and then goes right away every once in a while
Bartrking is offline   Reply With Quote
Old 02-10-2017, 04:11 PM   #9
12 Second Club
iTrader: (7)
 
z28_YOU_HO's Avatar
 
Join Date: Aug 2007
Location: O-town FL
Posts: 1,439
Default

My car is 40 at cold idle and 15-20 at hot idle lol... You're fine
z28_YOU_HO is offline   Reply With Quote
Old 02-19-2017, 12:04 AM   #10
TECH Fanatic
 
Join Date: Mar 2013
Posts: 1,878
Default

Honestly if you are reading the factory gauge it doesn't mean very much other than you have oil pressure. It could be accurate or it could be WAY OFF. Only way to tell is to have it tested with a calibrated gauge. I personally wouldn't give it another thought. You're fine. I have high oil pressure readings and the engine is a bit noisy so there you go, my oil pressure could be anything but as long as the gauge moves I know its got something. I smoked alotta bananas in the 60's and I still have oil pressure.............
RockinWs6 is offline   Reply With Quote
Old 02-20-2017, 07:51 AM   #11
12 Second Club
iTrader: (7)
 
z28_YOU_HO's Avatar
 
Join Date: Aug 2007
Location: O-town FL
Posts: 1,439
Default

UPDATE - I switched out my oil pressure sending unit over the weekend. 60 psi cold now and 40 hot. That's probably your problem
z28_YOU_HO is offline   Reply With Quote
Old 02-20-2017, 02:17 PM   #12
Launching!
 
Chevyguy2001's Avatar
 
Join Date: Feb 2003
Location: Macedon,NY
Posts: 290
Default

Was it difficult to do?
Chevyguy2001 is offline   Reply With Quote
Old 02-20-2017, 02:50 PM   #13
12 Second Club
iTrader: (7)
 
z28_YOU_HO's Avatar
 
Join Date: Aug 2007
Location: O-town FL
Posts: 1,439
Default

I was switching to a LS6 intake manifold, so it was easy for me. I hear you CAN do it without removing it if you have the right tools however.
z28_YOU_HO is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil pressure Mike Whetzel Conversions & Hybrids 4 02-01-2017 11:10 AM
Funky Oil pressure thetransamkid LT1-LT4 Modifications 3 08-23-2016 09:43 PM
Oil pressure question mak23 Generation III Internal Engine 3 05-23-2016 01:59 PM
Wife's first real autocross! smitty2919 Road Racing 9 01-21-2016 06:48 PM
I proposed too my girl last night and she said yes!!!! Loudmouth LS1 Florida Members 20 12-19-2005 08:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:18 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send