LS1TECH - Camaro and Firebird Forum Discussion

LS1TECH - Camaro and Firebird Forum Discussion (https://ls1tech.com/forums/)
-   PCM Diagnostics & Tuning (https://ls1tech.com/forums/pcm-diagnostics-tuning-7/)
-   -   2000 Chevy Pickup P0300 & P0153 codes (https://ls1tech.com/forums/pcm-diagnostics-tuning/535179-2000-chevy-pickup-p0300-p0153-codes.html)

Nakoz 07-02-2006 06:25 PM

2000 Chevy Pickup P0300 & P0153 codes
 
I currently have a 2000 chevy 1500 pickup that is showing the following codes in HPT:

P0153 H02S Slow Response Bank 2 Sensor 1 (old) (Immature)
P0300 Engine Misfire Deteced (Immature)

Also while I am running scans on it I noticed that the INJ B1 & B2 and the 02 Banks are not reading anything. In addition during normal driving or idleing it feels as if the truck is stuttering on fuel. After looking at the scans I noticed that the timing also seems to act a little weird. With the TPS at about 53% the timing is set for around 20 then it will all of a sudden drop to about 10, then back up to 20.

I know that the Bank 2 Sensor 1 is probly the passenger side 02 sensor, possibly needs to be replaced.

The main questions I have is:

Shouldnt HPT be able to see the INJ and 02 banks, and if so, what can I check to see what would cause them to not scan at all.

What could I look at to see what is causing the misfires and 02 sensor DTC, besides the 02 sensor?

Ooo BTW this is a stock truck, no mods.... yet

Thank you in advance for any help.

Nkz

Nakoz 07-04-2006 12:36 PM

anyone?

12secSS 07-04-2006 01:06 PM

I would start by inspecting the plugs and wires. Did this happen all of a sudden or gradually did it get bad? PO153 might be a old O2 sensor.


All times are GMT -5. The time now is 01:32 PM.