what did you do to your firebird today? - Page 2 - LS1TECH - Camaro and Firebird Forum Discussion



Pontiac Firebird 1967-2002 Birds of a feather flock together

what did you do to your firebird today?

Reply
 
Thread Tools Search this Thread
Old 03-05-2010, 11:52 AM   #21
Staging Lane
iTrader: (3)
 
Join Date: Aug 2009
Posts: 60
Default

Drove it to work. I'm about to get in it and drive it to lunch. Then I'll get in it and drive back to work. Then finally, I'm thinking I'll drive it home after work. You guys sensing a theme here?
Myrdhyn is offline   Reply With Quote
Old 03-05-2010, 01:33 PM   #22
Staging Lane
iTrader: (10)
 
mikey1107's Avatar
 
Join Date: Oct 2004
Location: Oklahoma
Posts: 68
Default

Seafoam treatment...
mikey1107 is offline   Reply With Quote
Old 03-05-2010, 01:34 PM   #23
TECH Regular
iTrader: (3)
 
twelver12's Avatar
 
Join Date: Feb 2009
Location: Mooresville, Indiana
Posts: 431
Default

Drove it and put gas in it, typical stuff really may be puttin the street tires on it tonight and cruisin this weekend
twelver12 is offline   Reply With Quote
Old 03-05-2010, 01:41 PM   #24
12 Second Club
iTrader: (4)
 
Joshiedoom's Avatar
 
Join Date: Dec 2007
Location: Between Bowling Green/Owensboro
Posts: 1,715
Default

Oh oh I take the cake.... switched out tranny mount again and started to pull out the old header gasket when I accidently rammed a screwdriver through my finger. LOL...


Joshiedoom is offline   Reply With Quote
Old 03-05-2010, 05:13 PM   #25
Staging Lane
iTrader: (23)
 
Doobie52's Avatar
 
Join Date: Jun 2009
Location: Henderson, NV
Posts: 98
Default

I guess working until 2:30 in the morning counts as work today. That's when I finished pulling my dash and removing anything HVAC related. Without the dash in, the car just looks faster.
Doobie52 is offline   Reply With Quote
Old 03-05-2010, 05:28 PM   #26
Staging Lane
 
Join Date: Jun 2007
Location: Naperville, IL
Posts: 82
Default

took off my taillight covers, i just got tired of them
JustAnother95 is offline   Reply With Quote
Old 03-05-2010, 05:30 PM   #27
Staging Lane
Thread Starter
 
Join Date: Sep 2009
Location: canton,MI
Posts: 75
Default

i finally got to drive it! it was about 45* here in michigan, it felt so nice to cruise on the highway with it and the windows down!
Torchie94 is offline   Reply With Quote
Old 03-05-2010, 06:13 PM   #28
On The Tree
 
01350ta's Avatar
 
Join Date: Jan 2008
Location: South Australia
Posts: 124
Default

Swapped out front springs & took it out for a test drive.
01350ta is offline   Reply With Quote
Old 03-05-2010, 09:49 PM   #29
Staging Lane
Thread Starter
 
Join Date: Sep 2009
Location: canton,MI
Posts: 75
Default

Quote:
Originally Posted by 01350ta View Post
Swapped out front springs & took it out for a test drive.

what springs are you running?
Torchie94 is offline   Reply With Quote
Old 03-05-2010, 10:01 PM   #30
TECH Fanatic
iTrader: (2)
 
Join Date: Nov 2007
Location: Newport, RI
Posts: 1,408
Default

I looked at it and said to it as I walked by it to get in my Jeep. The 'Bird doesn't get much love this time of year. I've put about 40 miles on it since the beginning of Feb. I just take it out for a ride every 2 weeks or so if the roads aren't too salty.

It's supposed to be nice tomorrow, so I'm taking it out. If it gets over 40, the tops are coming off, lol.
StuntmanMike is offline   Reply With Quote
Old 03-05-2010, 10:31 PM   #31
On The Tree
 
01350ta's Avatar
 
Join Date: Jan 2008
Location: South Australia
Posts: 124
Default

Switched 600lbs to 650lb Hypercoils. 2 1/2" x 12"
01350ta is offline   Reply With Quote
Old 03-05-2010, 10:33 PM   #32
Teching In
 
Join Date: Mar 2010
Posts: 36
Default

Took the DIY method of making my RamAir hood fully-functional, via a Dremel and Drill
kTrainHurricane is offline   Reply With Quote
Old 03-06-2010, 06:07 AM   #33
11 Second Club
iTrader: (2)
 
millersta's Avatar
 
Join Date: Jan 2007
Location: n/w indiana
Posts: 349
Default

pulled the drive shaft for an aluminum one sea foamed it and ran a 2010 camaro all in all a good day
millersta is offline   Reply With Quote
Old 03-06-2010, 07:48 AM   #34
TECH Fanatic
 
Join Date: Jan 2010
Location: South of Augusta,GA
Posts: 1,339
Default

Getting ready to install LQ4.
MillsMotorvation is offline   Reply With Quote
Old 03-06-2010, 08:33 AM   #35
myk
TECH Fanatic
iTrader: (4)
 
myk's Avatar
 
Join Date: May 2007
Location: Sun Diego
Posts: 1,829
Default

Drove it to and from work, minus t-tops...
myk is offline   Reply With Quote
Old 03-08-2010, 04:23 PM   #36
Staging Lane
Thread Starter
 
Join Date: Sep 2009
Location: canton,MI
Posts: 75
Default

took it for a spin today, i cant wait for it to be full on summer, i'm so pumped.

i also got my headlights working again.

does anybody have a 93-97 firebird shifter boot clip? like the trim that goes around the shifter boot on the center counsel ? i need one
Torchie94 is offline   Reply With Quote
Old 03-08-2010, 10:36 PM   #37
Teching In
 
Join Date: Feb 2010
Location: Goochland VA
Posts: 10
Default

finished up with the LT install and drove it for the first time since before Christmas. the rasp from the LM1 has already made me want to kick puppies...
V8MUSLE is offline   Reply With Quote
Old 03-08-2010, 10:45 PM   #38
Teching In
 
Join Date: Dec 2008
Location: San Diego, CA
Posts: 8
Default

Finished installing poly mount's, LT's and an ORY
bmiller0608 is offline   Reply With Quote
Old 03-09-2010, 04:52 PM   #39
TECH Resident
 
Blackhawk777's Avatar
 
Join Date: Feb 2006
Location: Omahaish. Nebraska.
Posts: 855
Default

WAS gonna pull the exhaust off of it to do some underbody work and coating but never got around to it.... tomorrow probably.
Blackhawk777 is offline   Reply With Quote
Old 03-10-2010, 11:04 PM   #40
TECH Fanatic
iTrader: (22)
 
sway99bird's Avatar
 
Join Date: Jan 2008
Location: Vernon,TX
Posts: 1,451
Default

Installed a adj. PHB and drove it around breaking in the new motor
sway99bird is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LS1 low idle KonkeyDong Fueling & Injection 3 03-02-2017 05:33 PM
LT1 Cold start issues/sputtering Quan Cheese LT1-LT4 Modifications 1 02-08-2017 11:56 AM
Misses when warm Brian100 LT1-LT4 Modifications 4 04-21-2016 03:09 PM
Noisy warm up 02 WS6 ykexplorer New LS1 Owners - Newbie Tech 2 12-13-2015 08:42 PM
Speed density guys, how much does fueling change with weather? SPRAYED 01 Forced Induction 7 11-06-2015 08:57 AM


Tags
02, boot, firebird, free, lebanon, ls1, mo, mobil, nationals, noise, pics, shift, solution, transam, trim

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:46 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: