what did you do to your firebird today? - Page 5 - LS1TECH



Pontiac Firebird 1967-2002 Birds of a feather flock together

what did you do to your firebird today?

Reply
 
Thread Tools Search this Thread
Old 04-07-2010, 09:31 PM   #81
Teching In
 
Hoostompa's Avatar
 
Join Date: Dec 2006
Location: DMV - PG cnty
Posts: 16
Default

Looked at all the pollen built up on him and said DAMN YOUR GREEN!!!!!!! Told em stop hold'n his breath and turn back black........... The trees must pay for this crime!!!!!!!!
Hoostompa is offline   Reply With Quote
Old 04-07-2010, 10:12 PM   #82
TECH Fanatic
iTrader: (2)
 
Join Date: Nov 2007
Location: Newport, RI
Posts: 1,411
Default

Cleaned some bird **** off it when I got home from work.
StuntmanMike is offline   Reply With Quote
Old 04-07-2010, 11:04 PM   #83
Staging Lane
iTrader: (1)
 
f-body_racer99's Avatar
 
Join Date: Feb 2010
Location: Brush, Colorado
Posts: 92
Default

I got my intake manifold out of the way
f-body_racer99 is offline   Reply With Quote
Old 04-08-2010, 02:38 PM   #84
TECH Resident
iTrader: (11)
 
Twotonefreak's Avatar
 
Join Date: Aug 2004
Location: Southeast of Disorder
Posts: 806
Default

I finally got all my new a/c components. Also got my new plugs and VP110 sitting in the garage. Going to dyno on the 200 shot this weekend.
Twotonefreak is offline   Reply With Quote
Old 04-13-2010, 12:36 PM   #85
TECH Resident
iTrader: (5)
 
WarShrike's Avatar
 
Join Date: Sep 2006
Location: Lubbock, TX
Posts: 799
Default

New HID's, gotta adjust some, but I'm already happy w/ the lighting.

WarShrike is offline   Reply With Quote
Old 04-13-2010, 05:04 PM   #86
TECH Junkie
iTrader: (2)
 
1995blacktattop's Avatar
 
Join Date: May 2006
Location: somewhere that doesn't get snow
Posts: 3,460
Default

got it washed and then put a coat of meguiers swirl x on it and then a coat mothers wax.
1995blacktattop is offline   Reply With Quote
Old 04-13-2010, 07:28 PM   #87
12 Second Club
iTrader: (4)
 
Joshiedoom's Avatar
 
Join Date: Dec 2007
Location: Between Bowling Green/Owensboro
Posts: 1,715
Default

Tried to break the stock 170k engine, tranny, 10 bolt.

Joshiedoom is offline   Reply With Quote
Old 04-13-2010, 07:50 PM   #88
Teching In
 
Slo TA's Avatar
 
Join Date: May 2009
Location: birmingham, AL
Posts: 42
Default

put mine on the rack today pulling the trans out and putting a converter in tomorrow
Slo TA is offline   Reply With Quote
Old 04-16-2010, 11:29 PM   #89
TECH Enthusiast
iTrader: (3)
 
zamora7's Avatar
 
Join Date: Feb 2009
Location: Eeerrrwhere south, tx
Posts: 592
Default

Quote:
Originally Posted by Myrdhyn View Post
Drove it to work. I'm about to get in it and drive it to lunch. Then I'll get in it and drive back to work. Then finally, I'm thinking I'll drive it home after work. You guys sensing a theme here?
Yeah, get back to work.
zamora7 is offline   Reply With Quote
Old 04-16-2010, 11:42 PM   #90
TECH Enthusiast
iTrader: (3)
 
zamora7's Avatar
 
Join Date: Feb 2009
Location: Eeerrrwhere south, tx
Posts: 592
Default

By the way my 2000 ws6 is on a 24 hour brake so far. For my 1980 T/A I picked up an Ls1 and t56 combo and everything to make it run along with tan leather seats for it. Next few months should be fun.
zamora7 is offline   Reply With Quote
Old 04-17-2010, 12:37 PM   #91
That's MISTER MODERATOR
iTrader: (9)
 
Paul Bell's Avatar
 
Join Date: Nov 2005
Location: NYC
Posts: 7,330
Default

I’ve done a few things in the last few weeks:

-Installed an aluminum driveshaft after having new U-joints installed and spin balancing it;
-Installed new sun visors from thepartsladi;
-De-screened my MAF;
-Test fit a GTO spare to clear my front brakes;
-Installed new headlights from LMC Truck;
-Beat in the rear wheel housings a bit to reduce tire rub;
-Beat on the exhaust so it clears the D/S loop;
-Changed the air filter;
-Installed new Bosch O2 sensors;
-Fixed an air leak around the EGR thingie in the intake manifold;
-Replaced two burned out bulbs.
Paul Bell is offline   Reply With Quote
Old 04-17-2010, 06:01 PM   #92
TECH Enthusiast
iTrader: (3)
 
zamora7's Avatar
 
Join Date: Feb 2009
Location: Eeerrrwhere south, tx
Posts: 592
Default

Still on brake lol.
zamora7 is offline   Reply With Quote
Old 04-18-2010, 12:51 AM   #93
Launching!
iTrader: (1)
 
tuske427's Avatar
 
Join Date: Aug 2004
Location: Los Angeles
Posts: 242
Default

cut out what was left of my rear wheel wells and dashboard top.

It's a '67 Firebird that's getting the pro touring treatment. It just came back from the chemical stripper on Friday, and it's all apart.

http://www.hotrodders.com/forum/jour...ournalid=20939
tuske427 is offline   Reply With Quote
Old 04-24-2010, 08:17 PM   #94
Staging Lane
Thread Starter
 
Join Date: Sep 2009
Location: canton,MI
Posts: 75
Default

Mine got hit last sunday so I've been tracking down a drivers fender and bumper.
Torchie94 is offline   Reply With Quote
Old 04-25-2010, 09:57 AM   #95
10 Second Club
iTrader: (17)
 
Demonicbird00's Avatar
 
Join Date: Apr 2004
Location: Alloway,NJ
Posts: 2,390
Default

water pump leak, got new stock gaskets and a new lower flexible hose.. my wp is a one off piece. old pic of when i first installed the pump

http://rides.webshots.com/photo/2929...CC?vhost=rides

-brandon
Demonicbird00 is offline   Reply With Quote
Old 04-25-2010, 02:28 PM   #96
TECH Enthusiast
 
Join Date: Dec 2005
Location: Owasso,Ok/Honolulu, HI
Posts: 530
Default

Look at my baby sitting in the parking lot cause the alternator is dead and i can't change it right now. Headers and Y went on two weeks and I can't even enjoy them right now............
lookin4aTA is offline   Reply With Quote
Old 04-25-2010, 02:40 PM   #97
12 Second Club
iTrader: (4)
 
Joshiedoom's Avatar
 
Join Date: Dec 2007
Location: Between Bowling Green/Owensboro
Posts: 1,715
Default

Old gal died at a stoplight last night, wouldnt start for ****, cranked it for a good 45 minutes after testing for fuel etc. It fired right up and hasnt had a problem since... who the heck knows..
Joshiedoom is offline   Reply With Quote
Old 04-25-2010, 08:57 PM   #98
That's MISTER MODERATOR
iTrader: (9)
 
Paul Bell's Avatar
 
Join Date: Nov 2005
Location: NYC
Posts: 7,330
Default

Installed a PCM obtained on eekbay (tuned to my car & VIN for 85 bucks!!) In preparation of sending the original to PCM For Less for tuning.

HMMM, the original had the SES light on, the replacement does not. AND it’s inspection time. GREAT!
Paul Bell is offline   Reply With Quote
Old 04-25-2010, 09:10 PM   #99
TECH Resident
iTrader: (11)
 
Twotonefreak's Avatar
 
Join Date: Aug 2004
Location: Southeast of Disorder
Posts: 806
Default

Put in some new plugs, washed it and took the wife for a cruise to enjoy the beautiful Oklahoma weather today.
Twotonefreak is offline   Reply With Quote
Old 05-01-2010, 12:10 AM   #100
TECH Fanatic
iTrader: (1)
 
great421's Avatar
 
Join Date: Feb 2006
Posts: 1,171
Default

Changed the Plugs (TR6IX's) and the starter!
great421 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Low oil pressure after warm WMSuperSport Generation III Internal Engine 42 12-11-2014 01:51 PM
Engine diesels after shut off..help! Builtz71 Carbureted LSX Forum 33 05-05-2013 08:39 PM
Letting the car warm up, how long is too long? ast95035 Racer's Lounge 72 02-17-2012 09:55 PM
Goodyear runflats to Nitto DRs (rear) Michelin PS2 (front) allngn_c5 Corvette Performance 21 04-08-2009 12:57 PM
is this common for the ls1 99blackbirdls1 Pontiac Firebird 1967-2002 19 05-05-2005 10:06 AM


Tags
02, boot, firebird, free, lebanon, ls1, mo, mobil, nationals, noise, pics, shift, solution, transam, trim

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:57 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send