LS1TECH - Camaro and Firebird Forum Discussion - Search Results

Notices
 
Search: Posts Made By: mightyquickz28
Showing results 1 to 25 of 488
Search took 0.83 seconds.
06-28-2019, 06:45 AM
Replies: 153
Views: 11,928
Posted By mightyquickz28

To be sure, if absolute power and response is...

To be sure, if absolute power and response is your goal (not to mention a thousand blueprints/templates available on how to do it), then the front mount is the better. But I've always admired people...
06-27-2019, 11:01 PM
Replies: 153
Views: 11,928
Posted By mightyquickz28

I've seen a rear mount vette run 8's in the...

I've seen a rear mount vette run 8's in the quarter and a rear mount 88 on a 3rd gen with the 93 -97 LT1 run 7's. No nitrous. Just boost.
3rd gen LT1 rear mount
06-27-2019, 07:18 AM
Replies: 11
Views: 2,491
Posted By mightyquickz28

Another thread on the process (my own) Pusher...

Another thread on the process (my own) Pusher fans (https://ls1tech.com/forums/forced-induction/1671847-pics-my-stock-fans-pushers-lt1-fbody-4th-gen-turbo-car.html)
06-24-2019, 08:53 PM
Replies: 14
Views: 3,659
Posted By mightyquickz28

I was in your boat back in2014. Bought the...

I was in your boat back in2014. Bought the CXRacing T4 kit. It was about $5xx.xx for all the hotside, V-band clamps and all. But I already had a Turbo (PT7675) , wastegate , Intercooler, cold side,...
05-25-2019, 04:24 PM
Replies: 1
Views: 1,680
Posted By mightyquickz28

After putting some jumper wires in the slots of...

After putting some jumper wires in the slots of two of the relays to makes sure both fans could be turned on. I went back to my old Haynes manual and looked that 'coolant fans' section. Hmm... only...
05-24-2019, 08:05 AM
Replies: 1
Views: 1,680
Posted By mightyquickz28

Coolant fans behavior 4th Gen Camaro -RESOLVED

My turbo Z28, using a 5.3, has been amazing these last 3 years. Most impressive to me is that the coolant temp at fully warm leaves the gauge halfway between the first two marks. But 2 days ago, I...
05-24-2019, 07:55 AM
Replies: 6
Views: 753
Posted By mightyquickz28

Have you tried returning all the idle settings...

Have you tried returning all the idle settings back to stock (of course, I'm assuming you've tweaked them) and then logging it to see what is lacking? At some points in my idle tuning (mis)...
05-22-2019, 07:44 AM
Replies: 10
Views: 880
Posted By mightyquickz28

Just an update - The homemade flange works great....

Just an update - The homemade flange works great. Driving around in town, on the tollway, etc is really enjoyable now that the engine can utilize the overdrive. Completely a great upgrade. I hope to...
05-22-2019, 07:32 AM
Replies: 1
Views: 272
Posted By mightyquickz28

Update - Sure enough, the appropriate pins...

Update - Sure enough, the appropriate pins weren't getting voltage. It turns out that in the fuse box under the hood, the fuse that feeds that particular circuit had a feeble connection. The fuse...
05-22-2019, 07:26 AM
Replies: 14
Views: 1,239
Posted By mightyquickz28

Sorry for the late response, yes, he does. Some...

Sorry for the late response, yes, he does. Some other things have developed as well.
So with the new starter, the engine cranks and starts every time , without default to failsafe mode. So Steve...
05-12-2019, 03:05 PM
Replies: 14
Views: 1,239
Posted By mightyquickz28

Small update: After a week or two, the issue...

Small update: After a week or two, the issue started happening again. Cold starts were magnificent, hot starts it would typically go into fail/safe mode and the engine would crank slowly. Steve was...
05-02-2019, 08:50 PM
04-21-2019, 03:25 AM
Replies: 5
Views: 382
Posted By mightyquickz28

I'll give that a try. Thanks for the suggestion.

I'll give that a try. Thanks for the suggestion.
04-19-2019, 03:10 PM
Replies: 1
Views: 272
Posted By mightyquickz28

4L80E TRANS throwing P0753 and P0758 codes

First, after swapping out the TH350 for the 4L80E, I put the two speed sensor connectors on the wrong sensor. At a dead stop, the speedometer was moving, but when leaving a stoplight, it did shift...
04-19-2019, 03:05 PM
Replies: 5
Views: 382
Posted By mightyquickz28

I've got a similar issue. It's throwing P0753 and...

I've got a similar issue. It's throwing P0753 and P0758.
First, after swapping out the TH350 for the 4L80E, I put the two speed sensor connectors on the wrong sensor. At a dead stop, the speedometer...
04-10-2019, 06:40 AM
Replies: 220
Views: 48,674
Posted By mightyquickz28

I'm sure it'll need that! What driveshaft were...

I'm sure it'll need that! What driveshaft were you using previously? I have the Denny's Nitrous ready (good to 1,000hp I think). Kudos also for the 'built it myself'. It was an incredible outcome...
04-09-2019, 07:54 AM
Replies: 80
Views: 10,535
Posted By mightyquickz28

https://cimg4.ibsrv.net/gimg/ls1tech.com-vbulletin...

https://cimg4.ibsrv.net/gimg/ls1tech.com-vbulletin/1201x587/frontview_pass_downpipe01_93fc4e1aeff93e23ee1cb9a2a56eb5021d48a3e6.jpg

Underneath, looking up on the passenger side This is the...
04-08-2019, 07:37 AM
Replies: 220
Views: 48,674
Posted By mightyquickz28

Man, listening to that engine shriek in that...

Man, listening to that engine shriek in that 1,800 hp pull, Jesus... sweet music! Congrats on such a well executed combo.
03-24-2019, 05:37 AM
03-23-2019, 08:32 PM
Replies: 163
Views: 17,402
Posted By mightyquickz28

I'm near Chatham and have some new up and forward...

I'm near Chatham and have some new up and forward Vband Headers for an LS if you want/need some....
03-20-2019, 09:12 AM
Replies: 19
Views: 861
Posted By mightyquickz28

Based on what I've seen here and elsewhere, that...

Based on what I've seen here and elsewhere, that power level wont require any additional hardparts or machining, unlike the older 96 and earlier small blocks. I spent 7K on forgings, going to four...
03-18-2019, 10:41 PM
Replies: 9
Views: 755
Posted By mightyquickz28

I bought a single PT7675 w/Billet wheel, journal...

I bought a single PT7675 w/Billet wheel, journal bearing in 2012. I first ran it on my all forged LT1 in my 96 z28 M6. After 2 years, I decided to follow the herd, pulling out the still running LT1...
03-15-2019, 08:41 AM
03-14-2019, 08:04 PM
Replies: 17
Views: 1,151
Posted By mightyquickz28

I did always wonder about back pressure because...

I did always wonder about back pressure because it was always blowing out the header gaskets on the LT1(all forged 355, TFS heads w/2.08 intakes, 1.60 exh). It got into boost quick but never really...
03-14-2019, 08:04 AM
Replies: 220
Views: 48,674
Posted By mightyquickz28

I'm running E85 on my 96 Z28 5.3. At first, I ran...

I'm running E85 on my 96 Z28 5.3. At first, I ran the 3.0" in/out intercooler that I'd used when running 93 oct pump gas. Since I'd read with E85, you don't *have* to use an intercooler, I thought...
Showing results 1 to 25 of 488
 


 
Forum Jump

About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.