Bolt On LT1 In The 12s! - LS1TECH

Log In 


12 Second Club In the 12s yet? Come inside!

Bolt On LT1 In The 12s!

Reply
 
Thread Tools Search this Thread
Old 12-06-2011, 04:07 PM   #1
12 Second Club
Thread Starter
iTrader: (2)
 
coolmanvette75's Avatar
 
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default Bolt On LT1 In The 12s!

Well my track rental at Atco yesterday really paid off. Car went a best of 12.93 @ 106.4 on a 1.9 60ft. Not too shabby for just a few bolt ons and a 141k mile motor. The car had more in it but I wanted to drive it home, so I took it easy on the ol 10 bolt. Im sure the 141k rockers/springs are holding me back, so those will get changed soon. I didnt get a slip of the 12.93 because it was the last run and they didnt print my ticket. I do have a go pro vid of it that Im waiting for my friend to upload. I do have a 12.94 slip and a 12.98 video of a grudge race between me and an ls2 01z. Let me know what you think guys think...

http://youtu.be/hMSrVEJX9IY

coolmanvette75 is offline   Reply With Quote
Old 12-06-2011, 07:22 PM   #2
12 Second Club
Thread Starter
iTrader: (2)
 
coolmanvette75's Avatar
 
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default

Go Pro 12.93 video
http://www.youtube.com/watch?v=nATFe...&feature=share
coolmanvette75 is offline   Reply With Quote
Old 12-06-2011, 09:16 PM   #3
TECH Resident
iTrader: (37)
 
Mike Morris's Avatar
 
Join Date: Mar 2010
Location: Md/PA/FL
Posts: 962
Default

Good job
Mike Morris is offline   Reply With Quote
Old 12-07-2011, 02:45 AM   #4
10 Second Club
iTrader: (15)
 
LS1LT1's Avatar
 
Join Date: Nov 2001
Posts: 9,340
Thumbs up

Good stuff Matt, congrats again.
LS1LT1 is offline   Reply With Quote
Old 12-11-2011, 11:32 AM   #5
On The Tree
 
ROMERO98Z28's Avatar
 
Join Date: Aug 2009
Location: MANASSAS,VIRGINIA
Posts: 188
Default

looking good!
ROMERO98Z28 is offline   Reply With Quote
Old 12-15-2011, 03:24 PM   #6
TECH Regular
 
Join Date: Mar 2005
Posts: 457
Default

Nice man, not bad for an old lt1!
sweetC5 is offline   Reply With Quote
Old 12-15-2011, 06:21 PM   #7
12 Second Club
Thread Starter
iTrader: (2)
 
coolmanvette75's Avatar
 
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default

Thanks guys. And Marc, I think its time to update your sig
coolmanvette75 is offline   Reply With Quote
Old 12-17-2011, 03:50 PM   #8
TECH Apprentice
iTrader: (2)
 
GtoSpd's Avatar
 
Join Date: Mar 2007
Location: Raleigh, NC
Posts: 370
Default

Well done! Congrats man.
GtoSpd is offline   Reply With Quote
Old 12-17-2011, 10:39 PM   #9
Moderator
iTrader: (32)
 
BizZzatch350's Avatar
 
Join Date: Dec 2001
Location: T E X A S
Posts: 9,691
Default

Nice! Way to represent the Lt1 cars
BizZzatch350 is offline   Reply With Quote
Old 12-18-2011, 07:16 PM   #10
On The Tree
 
Uwilllosetomy93lt1's Avatar
 
Join Date: Dec 2011
Location: Kissimmee, Florida
Posts: 109
Default

Great job! Dont take much to get these LT's into 12's....
Uwilllosetomy93lt1 is offline   Reply With Quote
Old 12-26-2011, 06:32 PM   #11
12 Second Club
Thread Starter
iTrader: (2)
 
coolmanvette75's Avatar
 
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default

Thanks guys. Hoping for 11s this spring on spray
coolmanvette75 is offline   Reply With Quote
Old 01-03-2012, 02:18 PM   #12
Teching In
 
Join Date: Jul 2009
Posts: 36
Default

Good times man! I hope to put down those times soon in my lt1.
doran_the_man is offline   Reply With Quote
Old 01-03-2012, 03:01 PM   #13
12 Second Club
Thread Starter
iTrader: (2)
 
coolmanvette75's Avatar
 
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default

Thanks. Hoping for 11s with the nitrous outlet plate kit I just picked up...
coolmanvette75 is offline   Reply With Quote
Old 01-23-2012, 05:31 PM   #14
TECH Apprentice
iTrader: (2)
 
Wimimc's Avatar
 
Join Date: May 2010
Location: Somerset NJ
Posts: 393
Default

ok you made me this much closer to getting an LT1..
Wimimc is offline   Reply With Quote
Old 01-23-2012, 05:43 PM   #15
11 Second Club
iTrader: (9)
 
LS1rob00's Avatar
 
Join Date: Apr 2010
Location: Bay Area, CA
Posts: 965
Default

Nice! Good time for an LT1.

What was the DA?
LS1rob00 is offline   Reply With Quote
Old 01-23-2012, 06:09 PM   #16
12 Second Club
Thread Starter
iTrader: (2)
 
coolmanvette75's Avatar
 
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default

Quote:
Originally Posted by Wimimc View Post
ok you made me this much closer to getting an LT1..
Come to one of the NJFBOA meets this spring and I'll make you even closer
Quote:
Originally Posted by LS1rob00 View Post
Nice! Good time for an LT1.

What was the DA?
DA was around -400 during that pass. Was a very humid day. Wish it was around -1000 like it should have been...
coolmanvette75 is offline   Reply With Quote
Old 01-23-2012, 06:15 PM   #17
TECH Apprentice
iTrader: (2)
 
Wimimc's Avatar
 
Join Date: May 2010
Location: Somerset NJ
Posts: 393
Default

Quote:
Originally Posted by coolmanvette75 View Post
Come to one of the NJFBOA meets this spring and I'll make you even closer

I might with a new ride.. I'll show you haha
Wimimc is offline   Reply With Quote
Old 01-27-2012, 11:30 PM   #18
TECH Regular
iTrader: (6)
 
blakez28's Avatar
 
Join Date: Nov 2010
Location: Fort Mill, SC
Posts: 411
Default

What advice do you have for launching?
What tires were you on?
blakez28 is offline   Reply With Quote
Old 01-28-2012, 09:16 AM   #19
12 Second Club
Thread Starter
iTrader: (2)
 
coolmanvette75's Avatar
 
Join Date: Jan 2011
Location: Old Bridge, NJ/Corpus Christi, TX
Posts: 1,221
Default

Quote:
Originally Posted by blakez28 View Post
What advice do you have for launching?
What tires were you on?
Launching? I was dumping it at 4-5k. On the last run I dumped it at 5k but the clutch was a little hot and it slipped slightly (you can here it in the go pro vid). I was on shot toyo proxes tq drag radials...
coolmanvette75 is offline   Reply With Quote
Old 01-28-2012, 10:47 AM   #20
TECH Regular
iTrader: (6)
 
blakez28's Avatar
 
Join Date: Nov 2010
Location: Fort Mill, SC
Posts: 411
Default

Quote:
Originally Posted by coolmanvette75 View Post
Launching? I was dumping it at 4-5k. On the last run I dumped it at 5k but the clutch was a little hot and it slipped slightly (you can here it in the go pro vid). I was on shot toyo proxes tq drag radials...
That's what I heard then. I couldn't tell if you were holding it at 1/2 throttle after dumping it or what. Awesome vids.
blakez28 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Drag setup Photoshoot coolmanvette75 Multimedia Exchange 8 01-06-2013 10:58 PM
Bolt on/150 shot LT1 track results coolmanvette75 Nitrous Oxide 10 05-21-2012 08:52 PM
Bolt on/150 shot track results coolmanvette75 LT1-LT4 Modifications 9 05-19-2012 04:13 PM
Spraying a high mileage LT1 coolmanvette75 LT1-LT4 Modifications 26 12-25-2011 08:48 PM
Cheap junkyard rear end solution? coolmanvette75 LT1-LT4 Modifications 8 05-15-2011 11:32 PM


Tags
12, 12s, 93, bolt, car, corvette, forum, lca, lt1, ons, phb, put, twelves, umi, z28

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 04:18 AM.