New Best - LS1TECH

Log In 


Drag Racing Tech a.sponlink:link {font-size: 9px;} img.surround{ border-color: #000000; border-width:1px; margin-bottom: 9.5px; } span.sponsortext { font-size: 10px; }
Rules | Safety | Setups | Hardware | Methods
Sponsored by
Scoggin-Dickey Parts Center
Click Here

New Best

Reply
 
Thread Tools Search this Thread
Old 10-15-2011, 01:44 AM   #1
TECH Apprentice
Thread Starter
iTrader: (5)
 
Join Date: Feb 2007
Posts: 318
Default New Best

Got to the track finally from a two month hiatus...went 10.25 @ 135 with a 1.64 60'. This pass was at about 15 degrees of timing on E-85 and close to 15 psi. I think it will get down to that magic 9 number, but it is going to take some more suspension work and tuning. I was looking at the logs and I was only dropping about 600 rpm between shifts so I think I need to get the convertor tightened up. Just kind of seems like it is blowing through the convertor too much. Input? The mph to the ET doesn't seem that off. Just getting down to a 1.4X 60 would definately get me there though, I think.
bpope is offline   Reply With Quote
Old 10-15-2011, 10:26 AM   #2
TECH Enthusiast
iTrader: (22)
 
Join Date: Dec 2005
Posts: 697
Default

What shocks do you have?
mr_biscuitz is offline   Reply With Quote
Old 10-15-2011, 10:28 AM   #3
TECH Enthusiast
iTrader: (22)
 
Join Date: Dec 2005
Posts: 697
Default

What settings are the shocks on? Whats the pinion angle? How about your lca angle?


And what did Rob run last night???????? Some more mid 5's?
mr_biscuitz is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:58 PM.