No power to racetronix pump..... - LS1TECH



Fueling & Injection Fuel Pumps | Injectors | Rails | Regulators | Tanks

No power to racetronix pump.....

Reply
 
Thread Tools Search this Thread
Old 06-08-2012, 05:14 AM   #1
TECH Enthusiast
Thread Starter
iTrader: (33)
 
headed-ws6's Avatar
 
Join Date: Aug 2006
Location: DFW
Posts: 606
Default No power to racetronix pump.....

Okay so I just installed my racetronix pump in my new fuel bucket which i also purchased from racetronix. Before installing the bucket into the tank i wanted make sure the fuel pump worked.

Got the new pump sitting in fuel but when i ground the pump and put power to it nothing happens.....

Can someone please help me with a correct method to check to make sure the pump is working..
headed-ws6 is offline   Reply With Quote
Old 06-08-2012, 06:56 AM   #2
LS1TECH Sponsor
iTrader: (2)
 
Racetronix's Avatar
 
Join Date: Mar 2002
Location: A Racetronix dealer near you...
Posts: 1,937
Default

Quote:
Originally Posted by headed-ws6 View Post
Okay so I just installed my racetronix pump in my new fuel bucket which i also purchased from racetronix. Before installing the bucket into the tank i wanted make sure the fuel pump worked.

Got the new pump sitting in fuel but when i ground the pump and put power to it nothing happens.....

Can someone please help me with a correct method to check to make sure the pump is working..
Have you joined our support forum to get the help you require?
Racetronix is offline   Reply With Quote
Reply


Tags
forum, racetronix, support

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:06 PM.