new 2011 2ss owner oil pressure problem - LS1TECH

Go Back   LS1TECH > Gen 5 Camaro 2010+ Forum > Gen 5 Racing Tech
Sign in using an external account
Register Forgot Password?
Search


Gen 5 Racing Tech
Heads, cam, valvetrain, short block discussion
Sponsored by
School of Automotive Machinists
Click Here


new 2011 2ss owner oil pressure problem

Reply
 
Thread Tools Search this Thread
Old 07-02-2012, 09:41 AM   #1
Registered User
 
Trader Rating: 0
Join Date: Jul 2012
Posts: 2
Question new 2011 2ss owner oil pressure problem

does any body know of oil pump problems with the gen 5 camaros? heard valvetrain clatter and then saw low oil pressure turn engine off message. Car is currently in for service and I am frantically awaiting the diagnosis. In some blogs online I have read that there is a TSB out from chevy and just looking for any info on this problem

Last edited by GRAYLS3; 07-02-2012 at 10:40 AM..
GRAYLS3 is offline   Reply With Quote
Old 07-02-2012, 05:56 PM   #2
Grumpy Bastard
 
Gunslinger09's Avatar
 
Trader Rating: 0
Join Date: Nov 2004
Location: Tampa FL
Posts: 719
Default

Hadn't heard anything myself but since it's in service now they will fix it.
__________________
2010 2SS
Black/Inferno Orange
Gunslinger09 is offline   Reply With Quote
Old 07-06-2012, 08:21 AM   #3
Registered User
 
Trader Rating: 0
Join Date: Jul 2012
Posts: 2
Default

Hey Gunslinger09, thanx just got my car back yesterday with new pump installed now im wondering what normal oil pressure is for an LS3 motor any clue its been a steady 35 psi
GRAYLS3 is offline   Reply With Quote
Old 07-06-2012, 08:48 AM   #4
Grumpy Bastard
 
Gunslinger09's Avatar
 
Trader Rating: 0
Join Date: Nov 2004
Location: Tampa FL
Posts: 719
Default

Quote:
Originally Posted by GRAYLS3 View Post
Hey Gunslinger09, thanx just got my car back yesterday with new pump installed now im wondering what normal oil pressure is for an LS3 motor any clue its been a steady 35 psi
That seems about rigt. Mine idles at about that hot.
__________________
2010 2SS
Black/Inferno Orange
Gunslinger09 is offline   Reply With Quote
Old 07-14-2012, 08:42 PM   #5
TECH Fanatic
 
FiredUpZ28's Avatar
 
Trader Rating: 0
Join Date: Jun 2006
Location: Elgin, Il
Posts: 1,289
Default

Per GM service information minimum oil pressure is 6 psi hot @ idle.
__________________
~Ryan~
'01 SS - m6, lid, factory SLP exhaust
'99 T/A - a4, 222/226 cam, 243 heads, working tune
Quote:
Originally Posted by I8UR4RD View Post
You shut your ***** mouth!
FiredUpZ28 is offline   Reply With Quote
Old 07-14-2012, 08:42 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
2010, 2011, 2012, bouncing, camaro, failure, ls3, motor, normal, oil, pressure, problems, psi, pump, ss


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 12:51 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details