Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search

General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions

A/C issues

Reply
 
Thread Tools Search this Thread
Old 05-18-2012, 10:27 PM   #1
Teching In
 
Trader Rating: 1
Join Date: Dec 2005
Location: St.Peters MO
Posts: 35
Send a message via Yahoo to Chico05RST
Default A/C issues

The a/c will work if I had let the car sit in the shade or the garage but if im out driving it on a warm day then it will only blow out hot air. I can hear the flap open and close as well as the the compressor kicking in, and it is holding the freon, so im at a loss as what it could be?
__________________
05 GMC RST
96 Chameleon blue/green TA
Chico05RST is offline   Reply With Quote
Old 05-18-2012, 10:48 PM   #2
TECH Senior Member
 
Trader Rating: 2
Join Date: May 2008
Location: South Florida
Posts: 9,452
Default

A/C gets real cold in the shade or garage.

You might just need a recharge.

.
__________________
1998 WS6 T/A, AES 390ci fully forged iron block, LS6 intake, LS1 heads, 239/235 .600/.600 114 lsa, 1 7/8" Grot LT's, 3" w/Magnaflow, 4L60E, Strange 12 bolt, Baer brakes, Hotchkis STB, UMI PH Bar, LCA's w/relocation brackets, SFC's, LG G2 Super Springs. Hals FR, Bilsteins RR, 275/315.

427ci stroker died at 173,000 miles...what a great engine that was, built by the late, great - Dave DiLuca...RIP...
-Life may not be the party we hoped for, but while we're here we might as well DANCE.
LS6427 is offline   Reply With Quote
Old 05-19-2012, 10:42 PM   #3
Teching In
 
Trader Rating: 1
Join Date: Dec 2005
Location: St.Peters MO
Posts: 35
Send a message via Yahoo to Chico05RST
Default

Well I tried to recharge it but it was already full, It did it to me again it was working fine (cool but not cold air) then it went back to blowing hot air again and it still has a full charge?
__________________
05 GMC RST
96 Chameleon blue/green TA
Chico05RST is offline   Reply With Quote
Old 05-19-2012, 11:08 PM   #4
TECH Enthusiast
 
Trader Rating: 1
Join Date: Apr 2012
Location: West TN
Posts: 629
Default

Might be overfull?
__________________
95 Firebird Formula M6 Hardtop - Flowmaster Catback and K&N Filter - IT IS ALIVE!!!!
Check the Opti - Check the Opti - Check the Opti

US Army Veteran
Having a 10 second Honda is like coming out of the closet. You may surprise a few people, but you're still gay.
DisasterFormula is offline   Reply With Quote
Old 05-20-2012, 08:52 AM   #5
Teching In
 
Trader Rating: 0
Join Date: Sep 2011
Location: western wisconsin
Posts: 46
Default

Quote:
Originally Posted by DisasterFormula View Post
Might be overfull?
I second that it might be overfull. This happened to me last fall, I kept putting more freon in but it only got worse. I think mine also had moisture in the system that was freezing up the orifice tube. After the shop evacuated the system and properly charged, it works now. Although I've noticed that the AC system still isn't as cold as my 08 Sierra but it does okay.
__________________
Black '98 Trans Am A4 - SLP Lid, MagnaFlow catback, Racetronix
Bigbee is offline   Reply With Quote
Old 05-20-2012, 08:52 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
1995, 98, ac, blow, blows, car, cat, cold, firebird, fix, hot, issues, ls1, shade, warm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 10:49 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details