Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search

General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions

TA headlight problems

Reply
 
Thread Tools Search this Thread
Old 05-29-2012, 10:29 PM   #1
Staging Lane
 
SinisterBirdWS6's Avatar
 
Trader Rating: 3
Join Date: Apr 2012
Location: NWI
Posts: 82
Default TA headlight problems

There is something wrong with my headlights. Its hard to explain without pics but ill try...When low beams are on, all 4 lights are on but the inner lights(pointing inward, looking at front) guessing there supposed to be high beams are really dim, and my drivers side low beam is a little dimmer than the pass side.
When i turn on the high beams, The two lights on the passenger side are pretty bright but the two on the other side dont work at all lol.

My dad said it might be bad ground because of the dimming.
Was planning on going with HID's pretty soon here anyways, but sounds like i need to fix this first.
Anyone else have this problem? any help on helping me see at night would be much appreciated lol
Thanks
__________________
99 WS6 M6 |Lid|P&P TB|LS6 intake|LT's|Pro-Kit|KYB AGX|
SinisterBirdWS6 is offline   Reply With Quote
Old 05-30-2012, 09:35 PM   #2
Staging Lane
 
SinisterBirdWS6's Avatar
 
Trader Rating: 3
Join Date: Apr 2012
Location: NWI
Posts: 82
Default

ttt, help is appreciated!
__________________
99 WS6 M6 |Lid|P&P TB|LS6 intake|LT's|Pro-Kit|KYB AGX|
SinisterBirdWS6 is offline   Reply With Quote
Old 05-31-2012, 01:13 PM   #3
TECH Resident
 
White 96LT1's Avatar
 
Trader Rating: 4
Join Date: Jun 2006
Location: WYLIE, TEXAS
Posts: 918
Default

sounds to me like you need a multifunction switch!
__________________
White 96 Trans AM M6 of course (every bolt-on there is)
355 LT1
http://www.fquick.com/White96LT1
White 96LT1 is offline   Reply With Quote
Old 05-31-2012, 05:32 PM   #4
TECH Enthusiast
 
US_Army_Z28's Avatar
 
Trader Rating: 3
Join Date: Mar 2011
Location: Gaffney, S.C.
Posts: 559
Send a message via Yahoo to US_Army_Z28
Default

Sounds likee a ground problem or someone rewired the headlights have all of them on at once and didnt know what they were doing
__________________

2000 Camaro Z28: SLP Flo Pac, Founders STB, Pacesetter LT's, TSP True Duals, cat delete, new motor
South Carolina F-Body Association Co-Founder
www.scfba.org
US_Army_Z28 is offline   Reply With Quote
Old 05-31-2012, 10:08 PM   #5
Staging Lane
 
SinisterBirdWS6's Avatar
 
Trader Rating: 3
Join Date: Apr 2012
Location: NWI
Posts: 82
Default

I had em on today and they were normal, just low beams on at the same brightness but i turn em off then back on it its back to how they were before
__________________
99 WS6 M6 |Lid|P&P TB|LS6 intake|LT's|Pro-Kit|KYB AGX|
SinisterBirdWS6 is offline   Reply With Quote
Old 05-31-2012, 10:28 PM   #6
On The Tree
 
AlamoTA's Avatar
 
Trader Rating: 10
Join Date: Apr 2011
Location: San Antonio
Posts: 111
Default

Its either the grounds right near the headlights on rail support or the connection. I pulled my grounds and found that they had painted the support bracket and then installed the ground. I'd start there. Pull it off and clean off the paint. If not, then it's probably the connection from the headlight, but I'd lay money on the grounds.
__________________

M6, SLP Lid, P&P TB, smooth bellow, STB, SFC, elec cut-out, Borla adjustable
AlamoTA is offline   Reply With Quote
Old 06-06-2012, 06:15 PM   #7
Staging Lane
 
SinisterBirdWS6's Avatar
 
Trader Rating: 3
Join Date: Apr 2012
Location: NWI
Posts: 82
Default

I cleaned the ground ring connectors, even though they were not corroded or anything, didnt change. Do you mean the radiator support should not have paint underneath the ring terminals?
__________________
99 WS6 M6 |Lid|P&P TB|LS6 intake|LT's|Pro-Kit|KYB AGX|
SinisterBirdWS6 is offline   Reply With Quote
Old 06-06-2012, 06:15 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
96, bracket, head, light, trans


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 01:24 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details