Yeah.... another vibration question - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Log In 

General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions

Yeah.... another vibration question

Thread Tools Search this Thread
Old 07-28-2006, 12:35 AM   #1
TECH Enthusiast
fast01's Avatar
Trader Rating: 16
Join Date: Jun 2004
Location: Farmingville, New York
Posts: 586
Default Yeah.... another vibration question

Ok, here's the abridged version. Put the car on dyno, broke the extention housing, replaced the housing, and now it vibrates like hell. I noticed while it was on the lift that the engine is leaning to the passenger side and the tranny mount is completely compressed on the passenger side. I'm getting what feels like an intermittant "clunk" at idle and a good solid "clunk" when the car is first started. The wierd thing is I'm getting a bad vibration when I make a right turn and only on a right turn. I can feel it in the gas pedal and in the floor. I just ordered some new poly mounts and am going to order a new factory tranny mount tomorrow. Does anyone think this will help? Thanks!
2001 Z-28....Gone, but not forgotten!
fast01 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


All times are GMT -5. The time now is 02:37 PM.