Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search

General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions

smell of burnt oil...

Reply
 
Thread Tools Search this Thread
Old 12-07-2006, 02:54 PM   #1
TECH Addict
 
lastcall190's Avatar
 
Trader Rating: 36
Join Date: May 2004
Location: NJ
Posts: 2,657
Default smell of burnt oil...

When I drive my car somewhat hard and using the gears to slow down more than the brakes (M6), when I finally come to a stop, I smell a faint odor of burnt oil for maybe 5 seconds. There is no smoke, either on start up, accel, decel, etc. Doesn't leak any on my garage floor, there's nothing spewing all over the motor. I just started using GC 0W-30. I check the oil level about once per week/week and a half and adjust as necessary (if needed). Is this somewhat normal? Maybe a dumb question, but thankfully this is all I have to worry about with the car (knock on wood)

-J
__________________
Quote:
Originally Posted by JakeFusion™ View Post
I just keep buying things. My wife gave up.

She was pissed about the FLT Trans for a long time. Still is in fact.
lastcall190 is offline   Reply With Quote
Old 12-07-2006, 04:48 PM   #2
TECH Senior Member
 
staringback05's Avatar
 
Trader Rating: 8
Join Date: Apr 2006
Posts: 6,699
Default

pcv valve is likely burning your oil....unless you have a leak or have major oil consumption i wouldnt worry
__________________
http://www.fquick.com/garages/viewgallery.php?carid=1595
99' Trans Am 11.97........sold
07' Z71 getting dirty
staringback05 is offline   Reply With Quote
Old 12-07-2006, 04:51 PM   #3
12 Second Club
 
spy2520's Avatar
 
Trader Rating: 3
Join Date: Feb 2005
Location: Waldorf, MD
Posts: 3,433
Send a message via MSN to spy2520
Default

i get the smell every once in a while, i believe it is 100% caused by the pcv system
__________________
spy2520 is offline   Reply With Quote
Old 12-07-2006, 05:02 PM   #4
TECH Addict
 
lastcall190's Avatar
 
Trader Rating: 36
Join Date: May 2004
Location: NJ
Posts: 2,657
Default

Quote:
Originally Posted by staringback05
pcv valve is likely burning your oil....unless you have a leak or have major oil consumption i wouldnt worry
Go to know, thanks guys!
__________________
Quote:
Originally Posted by JakeFusion™ View Post
I just keep buying things. My wife gave up.

She was pissed about the FLT Trans for a long time. Still is in fact.
lastcall190 is offline   Reply With Quote
Old 02-04-2007, 05:32 PM   #5
Teching In
 
Trader Rating: 0
Join Date: May 2006
Location: New Smyrna Beach
Posts: 34
Send a message via AIM to volumebikertom
Default

The pcv system is a definate problem on these cars. also, since I work at a dealership, I have found that GM released information saying that the 97-00 ls1 engines do not have the perfect piston rings in them. They tend to flutter at high rpms, or under compression braking. this causes alot of oil blow by. nature of the beast, ls1's use some oil
volumebikertom is offline   Reply With Quote
Old 02-04-2007, 05:32 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
burnt, ls1, ls1tech, oil, smell, tech


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 12:26 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details