Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > General Maintenance & Repairs
Sign in using an external account
Register Forgot Password?
Search

General Maintenance & Repairs
Leaks | Squeaks | Clunks | Rattles | Grinds
Sponsored by
Gearstar Performance Transmissions

50 amp ingnition fuse blowing

Reply
 
Thread Tools Search this Thread
Old 05-08-2007, 09:13 AM   #1
TECH Fanatic
 
z-ya's Avatar
 
Trader Rating: 1
Join Date: Jan 2003
Location: minneapolis,mn
Posts: 1,101
Default 50 amp ingnition fuse blowing

I have been blowing the 50 amp ingnition fuse under the hood on my 2001 z28.Does anyone know what would cause this issue,it just began happening
this year when it came out to play after winter.
__________________
2001 z/28 2004r,moser 12 bolt 4.30,
3 1/2 ds,1350 ujoints,hals,air bag,centerline convopros,M&H 275x60x15 muscle car drags,line lock,edelbrock coated race victors,5.3 ported heads, bowler cam,magnaflow catback,ported fast90,nw tb,racetroics fp and hot wire,42lb injectors march pulley,160 stat,2step,yank crossmember,n20
4130 lca's,phb,sfc,stb,hp tuners,lm1,arctic wht,
z-ya is offline   Reply With Quote
Old 05-08-2007, 12:52 PM   #2
TECH Senior Member
 
staringback05's Avatar
 
Trader Rating: 8
Join Date: Apr 2006
Posts: 6,699
Default

you could have a bad ground, a wire on wire, or a frayed end....check loads on wires..
__________________
http://www.fquick.com/garages/viewgallery.php?carid=1595
99' Trans Am 11.97........sold
07' Z71 getting dirty
staringback05 is offline   Reply With Quote
Old 05-11-2007, 06:12 AM   #3
TECH Fanatic
 
z-ya's Avatar
 
Trader Rating: 1
Join Date: Jan 2003
Location: minneapolis,mn
Posts: 1,101
Default

I took the odessy battery out put in a fully charged optima red top, drove it to work with no problems.Shut the car off,tried to restart it and blew the fuse again.Put in a new fuse but still no crank.HELP!!!!
__________________
2001 z/28 2004r,moser 12 bolt 4.30,
3 1/2 ds,1350 ujoints,hals,air bag,centerline convopros,M&H 275x60x15 muscle car drags,line lock,edelbrock coated race victors,5.3 ported heads, bowler cam,magnaflow catback,ported fast90,nw tb,racetroics fp and hot wire,42lb injectors march pulley,160 stat,2step,yank crossmember,n20
4130 lca's,phb,sfc,stb,hp tuners,lm1,arctic wht,
z-ya is offline   Reply With Quote
Old 05-11-2007, 01:03 PM   #4
Launching!
 
blownta00's Avatar
 
Trader Rating: 0
Join Date: May 2007
Posts: 248
Default

check your grounds man
blownta00 is offline   Reply With Quote
Old 02-22-2008, 04:58 PM   #5
TECH Fanatic
 
Black02SLPSS's Avatar
 
Trader Rating: 5
Join Date: Nov 2006
Location: Owasso, Ok
Posts: 1,476
Default

Bringin this one back from the dead. Im having the same problem. z-ya did you ever get yours figured out?
__________________
02 Camaro SS 345HP CME K&N FIPK M6 4.11s Koni 4/4 Strano springs & bars Poly motor & trans mounts Textralia OZ700



"A true hotrodder wouldn't be content until he had created a car so violent, so hairy, so totally sick that the very act of dropping the hammer would result in instant death. Anything less results in the need to go faster." - Tony DeFeo
Black02SLPSS is offline   Reply With Quote
Old 02-22-2008, 04:58 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 12:37 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details