New LS1 buyer with SLP lid issue - LS1TECH

Log In 


Introductions & Greetings New to the site? Say hello!

New LS1 buyer with SLP lid issue

Reply
 
Thread Tools Search this Thread
Old 05-22-2012, 09:06 PM   #1
12 Second Club
Thread Starter
 
Red97GT's Avatar
 
Join Date: Jan 2006
Posts: 54
Default New LS1 buyer with SLP lid issue

Hello, Just got a 02 T/A A4 60k
I just put a SLP lid on and the hold down clip for the lid pops open when I drive the car. I called SLP and they told Me to bend clip to adjust it. What I'M seeing is that the rolled edge of the lid slips off the clamp. Unlike the GM lid has a flat edge the clips behind it.
Anyone else have this issue?
Attached Thumbnails
New LS1 buyer with SLP lid issue-trans-am-003.jpg   New LS1 buyer with SLP lid issue-trans-am-005.jpg  

Last edited by Red97GT; 05-22-2012 at 09:37 PM.
Red97GT is offline   Reply With Quote
Old 05-22-2012, 09:34 PM   #2
11 Second Club
iTrader: (13)
 
jsteele90's Avatar
 
Join Date: Mar 2007
Location: delaware
Posts: 2,873
Default

Put the lid inside the lower airbox on the front edge
jsteele90 is offline   Reply With Quote
Old 05-22-2012, 09:39 PM   #3
Teching In
 
ranman02ta's Avatar
 
Join Date: Mar 2012
Location: gilbert az
Posts: 41
Default

Quote:
Originally Posted by jsteele90 View Post
Put the lid inside the lower airbox on the front edge

did the same
ranman02ta is offline   Reply With Quote
Old 05-22-2012, 10:05 PM   #4
12 Second Club
Thread Starter
 
Red97GT's Avatar
 
Join Date: Jan 2006
Posts: 54
Default

Thanks jsteele90

I just went out and took the bellow loose and put the lid inside the lower box and it clips down real tight now.
Thats a great tip. I wonder why SLP would not tell Me that...
Red97GT is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
WTB: SLP lid LilJayV10 Parts Wanted 4 03-26-2014 09:57 PM
Air Lid clips '02 WS6 Parts Wanted 4 10-21-2013 08:41 PM
Blackwing Lid, SLP Lids, Bellows *ALL ITEMS SOLD* TurdsOfMayhem Parts Classifieds 6 12-07-2012 09:28 AM
Installing FTP lid..98 camaro question calgary_z28 New LS1 Owners - Newbie Tech 6 02-20-2012 06:33 PM
MTI lid?? WizardofDetailing New LS1 Owners - Newbie Tech 21 02-12-2010 01:03 PM


Tags
air, box, car, clips, fitting, gutted, install, issue, issues, lid, louder, ls1, maf, screen, slp, tight

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:56 PM.