Stereo & Electronics - Not an F-body but stereo problem/question




Malicious
12-08-2003, 10:31 AM
Buddy of mine and I installed my amp(MTX 2300x amp) and 2 x Kicker comp 12's subs. All 4 gauge wiring, fuse under the hood, whole shin dig. Got the amp run off the 1 set of RCA's that isnt labeled "front output", remote wire is on the wire on the head unit wiring harness that says "remote system control". It was the only unused wire on the harness. Turn the deck off the amp goes off, find and dandy....right?

No.
No sound to the subs. We tried a different set of RCA's, tried running the speakers parallel, tried running them stereo. Eventually the fan inside the amp came on because it was getting warm but no matter what we changed on the headunit or the amp nothing happened. A friend of the guy that helped me owns an alarm/tint shop here in town and also does car audio on the side, so I'm taking the car up to his shop this afternoon and having him check out our wiring and see what he thinks. We tried all he could think of over the phone, he thinks it could be a bad amp. Too bad for me, it was bought used from a buddy who owns an audio shop in Cali. Bought over a year ago so I doubt I'd go rail him if it were bad, it could have been fine until it sat so long. Anyways shoot me some ideas if you have any for things to check. The amp has 3 fuses, but he said if they were popped the amp wouldn't come on at all, but I plan on checking anyways :cry:


Beeler422
12-08-2003, 11:53 AM
Are the RCA's running to the headunit or do you have an LOC? Does the amp have any sort of power light that comes on? Do you have a crossover at all? Some headunits have a funtion somewhere in a menu that you have to go thru to turn on the subs. I know I had one like that and thought something was messed up until I found that option.

Malicious
12-08-2003, 02:25 PM
Got it fixed, all that was correct, it was the one thing I did not do, which was wire the subs into the box. He had it all wrong. 2 terminals(both small, easy miss) and has both positive and negative hooked up on one(kinda a U clip with 2 posts). Fixed now, thanks for the help :)