New LS1 Owners - Newbie Tech - newbie




View Full Version : newbie


silverz28ls1
02-13-2011, 10:18 AM
i have just recently bought a 1999 z28 ls1. i love the car but it has some bugs that need to be worked out. for starters when i go into reverse my reverse lights do not come on. secondly all my lights surge from bright to dim. also i have a lil back fire when i let off the gas and tap it again i have a crane cams tuner....



mods are cat back greddy intake? and k&n intake:confused:

http://i1220.photobucket.com/albums/dd449/2004burns/IMG_20110211_211003.jpg


ULTIMATEORANGESS
02-13-2011, 12:46 PM
you might need a tune up.


id check your fuses and bulbs.

silverz28ls1
02-14-2011, 09:54 AM
thanks.....you know a better place to post alll i got was one reply lol


BowTieDrifter
02-14-2011, 12:03 PM
this is form one newb to another but its basic car stuff...
seems you are having some electrical issues, to say the least.
reverse lights: make sure all of the sensors are connected on your trans, check fuses, bulbs.
lights surging: what's happening during the surge? does it change with RPM? check the lighting thread, i've seen some people asking about dimming lights. sorry its the exterior apperance section here http://www.ls1tech.com/forums/appearance-detailing-18/
backfiring: check timing with a light. does it run rough? check spark plugs to see if you have injector/ignition problems. could have something to do with that crane tuner also...

just a bonus, could you post a pic of your intake? i'd like to see this greddy/K&N lol

silverz28ls1
02-14-2011, 09:52 PM
lol i will post a pic and also video of the surging k&n lid and greddy ram air thing

http://i1220.photobucket.com/albums/dd449/2004burns/th_VID_20110214_225355.jpg (http://s1220.photobucket.com/albums/dd449/2004burns/?action=view&current=VID_20110214_225355.mp4)

i thought u only check timing with the light if it has distributor

myk
02-15-2011, 12:41 AM
i thought u only check timing with the light if it has distributor

Yeah LS1's don't have distributors. Is your computer throwing any codes at you?

silverz28ls1
02-15-2011, 10:41 AM
no codes yet

this is form one newb to another but its basic car stuff...
seems you are having some electrical issues, to say the least.
reverse lights: make sure all of the sensors are connected on your trans, check fuses, bulbs.
lights surging: what's happening during the surge? does it change with RPM? check the lighting thread, i've seen some people asking about dimming lights. sorry its the exterior apperance section here http://www.ls1tech.com/forums/appearance-detailing-18/
backfiring: check timing with a light. does it run rough? check spark plugs to see if you have injector/ignition problems. could have something to do with that crane tuner also...

just a bonus, could you post a pic of your intake? i'd like to see this greddy/K&N lol


http://i1220.photobucket.com/albums/dd449/2004burns/th_VID_20110215_123232.jpg (http://s1220.photobucket.com/albums/dd449/2004burns/?action=view&current=VID_20110215_123232.mp4)