View Full Version : Tcs


99Z28camaroman
07-15-2011, 01:41 AM
Hey guys, I've been a way for a while as I had a classic 67 Firebird Convertable the last 2 years and a C5 Vette before that.

I juat got a 98 Trans Am it has an SLP air lid and a WS6 hood and a set of Torque thrust II alloys.

It has a TCS button but it does not work so the TCS light is on!
Most of you guys probably think this is a good thing. when you press the TCS button nothing happens. Is it normal for the TCS to default to off if the switch is faulty?

I tried removing the switch to look at it there are about 5 pins and wires on there! How do I test it to see if it's broke. I have a test meter.

dr_whigham
07-15-2011, 04:55 AM
Did you check to see if maybe the previous owner installed an SLP TCS Logic Module?

http://www.slponline.com/view_product_site.asp?P=63015

oChristiano
07-15-2011, 04:57 AM
^thats what I was gunna say. When you click it does tcs turn on?

99Z28camaroman
07-16-2011, 01:27 AM
The previous owner thought the TCS was turned off some how! So I don't think it has an SLP module he didn't know what an SLP module was until I said about it!. When you press the TCS button nothing happens. There is no light on the button and the dash still says TCS off.

I thought the TCS was default on and you had to switch it off! What I'm thinking if the switch is broken it must default to off. I thought it could not be turned off in the PCM you had to get one of the SLP modules to switch it's default setting from on to off!

If it does have an SLP module the switch should still work! Where would the SLP module be if it has one?

I wanted to test my TCS switch with a meter to see if it works but I don't know how? I could just get a TCS switch and try it but it would be a waste of money if there is nothing wrong with the one I have.

Remember I am in the UK and would have to get a TCS switch sent from the USA!

dr_whigham
07-16-2011, 03:50 AM
If it has the module you'd see it sitting right on top of the radio. The harness for those things are really short to begin with.

If you don't see anything extra plugged in, I think it's safe to say your switch is probably faulty.

99Z28camaroman
07-21-2011, 01:14 AM
I had a look for an SLP module but I coundn't even get the radio bezel off!:bang:
I got a good deal on a used TCS switch so I will fit it when it arrives, maybe that will cure it!

99Z28camaroman
08-03-2011, 01:28 AM
Well my replacement TCS switch arrived from the USA and I fitted it and guess what still the same! The dash says TCS off no lights on the switch and nothing happens when you press the TCS switch! :bang:

Anyone have any suggestions on what to check next?