View Full Version : 1st Kill since TT3000 install...


storm5.3
06-05-2005, 11:57 AM
Well I've been kinda taking it easy this whole week since the install trying to get used to the verter. I think I'm used to it since now it feels tighter to me. Well I was on my way back from lunch and caught a light next to a Grand Am that kept creeping and inching up waiting for the light to turn green, and I'm thinking no contest. Then on my right a pretty new blue sportbike pulls up, a guy w/ his girl on the back. Now here's the layout : me in the middle lane, GA in the left lane, and the sportbike in the right turning lane that carries over across the intersection then merges into my lane ( A known spot that everyone races to beat the guy in the middle lane). So I'm waiting for the light, it pops green then I take off kinda smartly but still slow as not to lose traction. Then I hear the sportbike rev alittle and I pour the coals on it, run her up through first gear and right after the tires bark after the 1-2 I shut her down and I'm at 60MPH, check for cops ( speed limit is 50MPH ), none sighted, check my rearview and the sportbike is right behind me about 2-3 truck lenghts back coming up hard. As he gets to my rear he pops the clutch and is revving at me bouncing it off the rev limitter as he passes and I just laugh. :jest: :jest: The best part was watching the chick on the back holding on for dear life during this little escapade and also the nice ass shot as they passed by. :D

99FormulaM6
06-05-2005, 08:09 PM
sounds like you got a pretty quick truck there. i was @ the track yesterday and saw one of those turbo diesel fords running 15.02 on some big ass 33's or something with only a chip and exhaust.

storm5.3
06-05-2005, 08:19 PM
It's not that quick compared to others I know but it'll surprized ya for looking stock... :)