Blown trans help - LS1TECH

Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Manual Transmission
Log In 
Search


Manual Transmission
T56 | T5 | MN12 | Clutches | Hydraulics | Shifters
Sponsored by
McLeod Clutch


Blown trans help

Reply
 
Thread Tools Search this Thread
Old 04-14-2012, 11:01 PM   #1
Registered User
 
Trader Rating: 0
Join Date: Apr 2012
Posts: 2
Default Blown trans help

Hello everyone my names Pete im an LS1 tech newbie. Ive had 23 cars in my 20 years of life. 70 Lemans 78, 79 and the newest 2000 Trans Am. LS1 / T56 car. Dyno'd 296rwhp. Had it almost 6 weeks now and blew the trans 3 hours ago. I was passing a car in 3rd gear. Around 85 rather gentle i pulled lnto 4th gear. Engaged the clutch and heard the kinda metal on metal carnage no man wants to hear. I figured i missed 4th so tried softly for it and again it went in but when engaged just grinds. So i put it in 6th thinking id be ok. Same thing. I immediately pulled off the road yo inspect it. No fluid leakage. And the car will go into gear and move under its own power until under and given load. And throttle above idle makes it grind like hell. I figure its shot but im not for certain. So any help would be greatly appreciated. Im currently unemployed and not too thrilled. Especially because my buddys Wrx blew them trans last night. Not a good week for transmissions at all.

So any and all help, suggestions, whatever you got would be awesome.
Thanks. Pete
BrokenBucketTransAm is offline   Reply With Quote
Old 04-15-2012, 01:21 AM   #2
Staging Lane
 
Trader Rating: 9
Join Date: Apr 2012
Posts: 50
Default

do you still have the problem,the trans wasnt overheated was it?ive seen trans not go in any gear just grind because of heat once they cooled they worked again,just a thought
arob987 is offline   Reply With Quote
Old 04-15-2012, 10:04 AM   #3
Registered User
 
Trader Rating: 0
Join Date: Apr 2012
Posts: 2
Default

No i had just left my buddys house. It still goes in gear and moves but any gas above idle and it grinds
BrokenBucketTransAm is offline   Reply With Quote
Reply


Tags
2000, blew, broken, dyno, ls1, manual, tranmission, transam, transmission


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 09:44 AM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details