what the hell!!! - LS1TECH

Go Back   LS1TECH > WELCOME TO LS1TECH > New LS1 Owners - Newbie Tech
Log In 
Search


New LS1 Owners - Newbie Tech
Basic Technical Questions & Advice
Sponsored by
Improved Racing


what the hell!!!

Reply
 
Thread Tools Search this Thread
Old 12-17-2011, 04:52 PM   #1
Launching!
 
stoning_volcom's Avatar
 
Trader Rating: 6
Join Date: Jan 2010
Location: MURICA
Posts: 248
Default what the hell!!!

I bought a 98 camaro z28 bought a month ago. long story short motor blew up and i just replaced it. not my throttle is sticking. this is not my throttle body. this has something to do with the cruise control box and it is sticking about and 8th open. so it gets stuck at bout 2500 rpm
__________________
Instagram @BNM_Performance_Fab

"Providing quality Fabrication, at affordable prices"

For estimates or quotes feel free to email me @ BnM_Performance_Fab@hotmail.com

Thanks Evan
stoning_volcom is offline   Reply With Quote
Old 12-17-2011, 04:57 PM   #2
TECH Addict
 
blk/slvr02ss's Avatar
 
Trader Rating: 21
Join Date: Dec 2006
Location: Port Saint Lucie,Florida
Posts: 2,773
Default

Spray some WD40 or PB Blaster on the throttle shaft and loosen it up !
__________________
2008 CBR1000RR !!!
blk/slvr02ss is offline   Reply With Quote
Old 12-17-2011, 05:05 PM   #3
Launching!
 
stoning_volcom's Avatar
 
Trader Rating: 6
Join Date: Jan 2010
Location: MURICA
Posts: 248
Default

Quote:
Originally Posted by blk/slvr02ss View Post
Spray some WD40 or PB Blaster on the throttle shaft and loosen it up !
already did that,......... so anything else? once again it is NOT the throttle body. has something to do with the cruise control module?
__________________
Instagram @BNM_Performance_Fab

"Providing quality Fabrication, at affordable prices"

For estimates or quotes feel free to email me @ BnM_Performance_Fab@hotmail.com

Thanks Evan
stoning_volcom is offline   Reply With Quote
Old 12-18-2011, 08:15 AM   #4
TECH Fanatic
 
RARON455's Avatar
 
Trader Rating: 35
Join Date: Apr 2008
Location: Fort Worth Texas
Posts: 1,612
Default

Did you try lubing the cruise control cable,, maybe spray some PB blaster down in it??
__________________
1998 white T/A callies stuffed 383 (built by ME), prc heads, ported fast 92, EPS cam,morels,and the rest of the goodies,pushed by a QTP ford 9" Jakes performance 4l80 with transbrake and tcs billet converter.

Never save anything for a special day, THIS day the Lord has given IS special.
RARON455 is offline   Reply With Quote
Old 12-18-2011, 08:07 PM   #5
Launching!
 
stoning_volcom's Avatar
 
Trader Rating: 6
Join Date: Jan 2010
Location: MURICA
Posts: 248
Default

ixed it had to tear the cruise control module apart and reset it.
__________________
Instagram @BNM_Performance_Fab

"Providing quality Fabrication, at affordable prices"

For estimates or quotes feel free to email me @ BnM_Performance_Fab@hotmail.com

Thanks Evan
stoning_volcom is offline   Reply With Quote
Old 12-18-2011, 09:04 PM   #6
Teching In
 
Trader Rating: 0
Join Date: Oct 2010
Posts: 6
Default

Hey stoning, how did you fix it. I think I am having the exact same problem. If I go WOT, it pegs at full throttle and bounces of rev limiter. Is this what was happening to you? I check the TB and it seems to work very smooth. I am truly at a loss for how to fix my car. I was about to replace my TB just in case. Its scary when it pegs at WOT or bounces off fuel cut off when I go to grab the next gear. Anyone else have any ideas? Thank you!
__________________
2000 SS Coupe Black

2001 SVT Lightning
SilentArmy is offline   Reply With Quote
Old 12-19-2011, 10:45 AM   #7
TECH Resident
 
ragtopz28's Avatar
 
Trader Rating: 34
Join Date: Aug 2007
Location: Ft. Myers, FL
Posts: 915
Default

Check cable to ASR for slack. If you hammer the throttle and it sticks, the cable could be jumping up on lip of the cam/pulley and sticking between it and the plastic cover.
Mine did and it took me 5 kicks of the pedal before it jumped back in place.
Scary ****with a 15mph 90 degree curve fast approching.
Adjusted cable with no WOT issues to date.
__________________
2002 Z28 SOM A4 17K miles SBE, full weight, full bolt-ons, full suspension, BTR cam, spray, stall, FLT Level VI, SD tune (10.52 @ 129.2 mph) w/more to come
2011 Silverado CC Z-71 DD

2002 Z28 A4 Vert. 28K miles, Triple Black (SOLD)
1976 T/A w/550hp n/a 355ci 1/8 mi bracket car (SOLD)
1968 GMC w/blown and chromed 468ci (SOLD)
ragtopz28 is offline   Reply With Quote
Reply


Tags
1998, 98, blaster, body, camaro, control, cruise, hell, ls1, pb, spray, stick, sticking, stuck, throttle


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 12:24 AM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details