what the hell? - LS1TECH

Log In 


New LS1 Owners - Newbie Tech Basic Technical Questions & Advice
Sponsored by:
Sponsored by:

what the hell?

Reply
 
Thread Tools Search this Thread
Old 03-24-2012, 03:29 PM   #1
On The Tree
Thread Starter
 
Join Date: Dec 2011
Location: Gold Coast, Australia
Posts: 129
Default what the hell?

I noticed in my coolant there are lots of tiny black coloured plastic bits floating in it. They appear to look like flaked off paint? When I pick one up it feels like lightweight, thin, shiny plastic paper. I have mls head gaskets and a new water pump was fitted only weeks ago.

Anyone else had this before? What is it?
ls1 down under is offline   Reply With Quote
Old 03-24-2012, 03:48 PM   #2
TECH Enthusiast
iTrader: (10)
 
Join Date: Dec 2009
Location: texas
Posts: 623
Default

flush all the coolant out and see if it continues. could be from the old head gaskets if they didnt scrape the deck surface good enough or some just got into the coolant passages. shouldnt be any reason to worry
usafws6 is offline   Reply With Quote
Old 04-05-2012, 01:25 AM   #3
TECH Regular
iTrader: (2)
 
HumanNipple's Avatar
 
Join Date: Jan 2007
Location: Northern Virginia
Posts: 484
Default

Quote:
Originally Posted by ls1 down under View Post
I noticed in my coolant there are lots of tiny black coloured plastic bits floating in it. They appear to look like flaked off paint? When I pick one up it feels like lightweight, thin, shiny plastic paper. I have mls head gaskets and a new water pump was fitted only weeks ago.

Anyone else had this before? What is it?
those are most likely pieces of old radiator hoses. They dry rot and start losing pieces of themselves in your cooling system. Check your hoses, my bike had a dry rotted hose that lost pieces just like you described. Flush your radiator, if that doesn't work do a full system flush. The flush of my system solved the problem.
HumanNipple is offline   Reply With Quote
Old 04-05-2012, 01:35 AM   #4
TECH Senior Member
iTrader: (90)
 
01ssreda4's Avatar
 
Join Date: Aug 2007
Location: Turnin' Wrenches Infractions: 005
Posts: 21,403
Default

Motor is done. Put a 408 in there
01ssreda4 is offline   Reply With Quote
Reply


Tags
black, camaro, coolant, flakes, gold, ls1tech, tiny

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:54 AM.