"Change Oil" light came on - LS1TECH

Go Back   LS1TECH > WELCOME TO LS1TECH > New LS1 Owners - Newbie Tech
Log In 
Search


New LS1 Owners - Newbie Tech
Basic Technical Questions & Advice
Sponsored by
Improved Racing


"Change Oil" light came on

Reply
 
Thread Tools Search this Thread
Old 03-21-2005, 05:49 PM   #1
Staging Lane
 
MyKeE's Avatar
 
Trader Rating: 0
Join Date: Sep 2004
Location: So.California (805)
Posts: 97
Default "Change Oil" light came on

my change oil light came on and i have less than 1,000 miles since my last oil change.

i had it done at the dealership (so that i can have all the service records) and when i got the car back,my tripometer was reset so i figured they had reset the oil change "sensor" ;if thats what its called,... so i didn't bother in doing it myself.

Under 1000 miles later, the light comes on. My question is, is it possible that i in fact need to change my oil again, or is it most likely that the computer is keeping track of the revs from the "previous" oil change.

p.s. car has been driven under normal conditions
__________________
2000 Camaro SS
MyKeE is offline   Reply With Quote
Old 03-21-2005, 06:15 PM   #2
Copy & Paste Moderator
 
VIP1's Avatar
 
Trader Rating: 0
Join Date: Apr 2002
Location: Eastern MA
Posts: 8,620
Default

Check the oil level to make sure you arent low. Otherwise they most likely didnt properly reset the oil computer.

Here is how you reset it:
1.) Turn the key to "ON" (DO NOT START THE ENGINE)
2.) Push and hold in the Trip Reset button until the "Change Oil" light flashes

Thats it.
The "Change Oil" light should now be off.

If it comes on again soon, then there is something wrong.
__________________
------------ www.fadingarrow.com ------------
2001 Black Formula - 75th Anniversary Package
Mods: Koni SA, UMI Roto LCA & PHB, Lid, Holly Filter, Strano 35/22 sway, Black Z06 Motorsports 17x9.5, F1 GS-D3 275/40/17, Silver Door Panel & Arm Rest Fabric, Silver Vent Rings, A4 Leather Shift Boot, Hella 90mm Projectors, Pioneer AVIC-D3

2013 Deep Inpact Blue Mustang GT Premium
Mods: Corsa Exhaust, Ford Procal Tune
-- Lighting FAQ - Suspension Issues / FAQ --
VIP1 is offline   Reply With Quote
Old 03-21-2005, 06:21 PM   #3
WOT
TECH Regular
 
WOT's Avatar
 
Trader Rating: 1
Join Date: Apr 2003
Location: My Garage!
Posts: 399
Default

Your oil level is fine... You have a seperate low oil light that is in the bottom left side. The oil change light just needs to be reset. It is useless this time, but when you get your next servicing, reset the light and it will remind you when the time comes.
__________________
2001 Black WS6 / 781 fire breathing rwtq / SOLD

1993 Cobra / Forged 408 solid roller / Built C-4 / spooled / caged

Track times
Cobra: 11.15 with 1.55 60' 126 MPH NA

Man o War 438ci in work with 2 stages of fun!
WOT is offline   Reply With Quote
Old 03-21-2005, 06:47 PM   #4
Staging Lane
 
MyKeE's Avatar
 
Trader Rating: 0
Join Date: Sep 2004
Location: So.California (805)
Posts: 97
Default

....thanks guys

yeah, i know about the low oil light, and i checked my oil and it looked good(of course no actual oil analysis was done)... so i just wanted to make sure that there isn't other problems or circumstances that i'm unaware of that will force you to change an engines oil so quickly
__________________
2000 Camaro SS
MyKeE is offline   Reply With Quote
Reply


Tags
change, light, ls1, oil


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 07:27 AM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details