Go Back   LS1TECH > CHASSIS, SUSPENSION, APPEARANCE > Stereo & Electronics
Sign in using an external account
Register Forgot Password?
Search

Stereo & Electronics Audio Components | Radars | Alarms

HID wiring with H3 projector headlamps (camaro)

Reply
 
Thread Tools Search this Thread
Old 07-24-2009, 06:53 PM   #1
Staging Lane
 
Trader Rating: 0
Join Date: Jan 2002
Location: Coral Springs, FL
Posts: 56
Default HID wiring with H3 projector headlamps (camaro)

I'm having trouble getting my HID (H3 bulb) headlights to light up. I bought the dual CCFL halo projector headlamps for the camaro and the halos are wired properly. As far as the HID system, the bulbs are mounted, but I'm not sure about a couple of things. The normal H3 bulbs have one wire from the bulb, and the other from a metal tab on the back of them, and those wires lead into a female connector where the stock male connector fits in to control the lights.

On the HID's, the back of the bulb, there are two wires that each have a connector coming from the bulb which plug into the ballast. Now, does that mean they are already grounded, or do I still need to run a wire from the tab to a ground somewhere?

Also, there are these relay wiring harnesses that were included. I'm not sure if these are necessary, but if they are, could someone explain to me where they connect to?

For what it's worth these are Xentec slim ballast HID kits. Thanks so much!
__________________
2000 black SS with a silver stripe...
Evil SS is offline   Reply With Quote
Old 07-24-2009, 06:56 PM   #2
TECH Senior Member
 
SparkyJJO's Avatar
 
Trader Rating: 10
Join Date: Aug 2007
Location: Ohio
Posts: 6,736
Send a message via AIM to SparkyJJO
Default

You just need to connect the two connectors on the bulbs to the ballast. Nothing else is necessary.

Bear in mind, if the HIDs don't turn on, you may need to plug the ballast into the car's headlight harness "backwards" - GM in their wisdom wired the plugs backwards from standard (nice of them). Just FYI.

There are no relays with Xentec kits (I have the same kit). They included some random wires but why I'm not sure. They aren't necessary.
__________________
'99 Camaro, Mystic Teal Metallic, L36, A4, cammed, headers, tuned; Stranos, Bilsteins, Founders LCAs, relos, and adj. panhard; C5DD, BLS w/ 5000k HID, tinted corners
'02 Trailblazer, Forest Green Metallic, Herculiner, and rust brown; Vortec 4.2L I6, 4x4, suspension lift; retrofitted projector headlights w/ 5000k HID, LED conversion
'07 Silverado Z71, Blue Granite Metallic, Vortec 5.3L, A4, 4x4; totally untouched (for now)
SparkyJJO is offline   Reply With Quote
Old 07-24-2009, 11:19 PM   #3
Staging Lane
 
Trader Rating: 0
Join Date: Jan 2002
Location: Coral Springs, FL
Posts: 56
Default

Thanks man! The bulbs were connected, but I had the connector backward...thanks GM! The bulbs look great, now I just have to make sure the projectors are aligned properly so I don't blind everyone...again thanks!
__________________
2000 black SS with a silver stripe...
Evil SS is offline   Reply With Quote
Old 07-24-2009, 11:19 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Tags
camaro, connections, h3, headlamps, headlight, hid, hids, lamps, lights, projection, projector, proyector, system, wire, wiring


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 06:24 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details