pretty lame - LS1TECH

Log In 


Western Members CA, AZ, NV, UT, CO, NM, HI

pretty lame

Reply
 
Thread Tools Search this Thread
Old 07-02-2009, 03:06 PM   #1
Teching In
Thread Starter
iTrader: (2)
 
Smmokin01SS's Avatar
 
Join Date: Oct 2008
Posts: 18
Default pretty lame

so about 2 weeks ago i keep hearing a weird ticking noise adn i got scared i damaged my motor, today i took off the headers and realized that a huge chunk outa my gasket was missing, turns out i had the fattest exhaust leek known to man and every header bolt was loose, haha make sure you have the metal gaskets if you do the header swap, i learned the hard way with the shitty paper ones
Smmokin01SS is offline   Reply With Quote
Old 07-02-2009, 03:14 PM   #2
TECH Addict
iTrader: (3)
 
hlaalu's Avatar
 
Join Date: Oct 2007
Location: Orange County
Posts: 2,541
Default

damn. at least it's just a gasket lol. didn't someone on here blow a hole through one of the headers randomly?
hlaalu is offline   Reply With Quote
Old 07-02-2009, 03:17 PM   #3
Banned Village Idiot
iTrader: (36)
 
LS1BLKSS's Avatar
 
Join Date: Aug 2007
Location: Anaheim,CA
Posts: 2,553
Default

Quote:
Originally Posted by hlaalu View Post
damn. at least it's just a gasket lol. didn't someone on here blow a hole through one of the headers randomly?

mine was something like this

Last edited by LS1BLKSS; 07-02-2009 at 03:44 PM.
LS1BLKSS is offline   Reply With Quote
Old 07-06-2009, 05:59 PM   #4
TECH Senior Member
iTrader: (36)
 
ss.slp.ls1's Avatar
 
Join Date: Jan 2008
Location: Orange County, CA
Posts: 7,535
Default

Quote:
Originally Posted by Smmokin01SS View Post
so about 2 weeks ago i keep hearing a weird ticking noise adn i got scared i damaged my motor, today i took off the headers and realized that a huge chunk outa my gasket was missing, turns out i had the fattest exhaust leek known to man and every header bolt was loose, haha make sure you have the metal gaskets if you do the header swap, i learned the hard way with the shitty paper ones
LOL, told you that you had an exhaust leak...
ss.slp.ls1 is offline   Reply With Quote
Old 07-06-2009, 07:09 PM   #5
TECH Enthusiast
iTrader: (47)
 
1Loudz28's Avatar
 
Join Date: Aug 2007
Location: BAY AREA CA
Posts: 711
Default

my tapping was caused by this:


good thing it was just a gasket!
1Loudz28 is offline   Reply With Quote
Old 07-06-2009, 07:12 PM   #6
11 Second Club
iTrader: (21)
 
Kingc8r's Avatar
 
Join Date: Jan 2008
Location: The Bay Area
Posts: 4,383
Default

The same thing happened to me. The bad part was that my boy that helped with my header install cross threaded a header bolt
Kingc8r is offline   Reply With Quote
Old 07-07-2009, 09:16 AM   #7
TECH Enthusiast
iTrader: (118)
 
xxrillixx's Avatar
 
Join Date: Oct 2005
Location: Las Vegas
Posts: 664
Default

Quote:
Originally Posted by Kingc8r View Post
The same thing happened to me. The bad part was that my boy that helped with my header install cross threaded a header bolt
Awsome! Thats my favorite!

lol
xxrillixx is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:45 AM.