another starter problem - LS1TECH - Camaro and Firebird Forum Discussion



General Maintenance & Repairs Leaks | Squeaks | Clunks | Rattles | Grinds

another starter problem

Reply
 
Thread Tools Search this Thread
Old 11-24-2011, 01:34 PM   #1
TECH Apprentice
Thread Starter
iTrader: (22)
 
Join Date: Jun 2010
Location: Clewiston, FL 33440
Posts: 374
Default another starter problem

so i replaced my 12 year old starter today with one off of ebay yeah i know but for $50 i figured id give it a shot...
everything went in and after i reinstalled everything back together i get in to turn it on and my gauges swipe the whole way across the dash when the car turns on...kind of weird but does it every time...any idea what it might be guys?
ISMELLRICE is offline   Reply With Quote
Old 11-24-2011, 03:33 PM   #2
TECH Junkie
iTrader: (17)
 
Tally TransAm's Avatar
 
Join Date: Nov 2001
Location: Tallahassee, Fl
Posts: 3,402
Default

low voltage/dead batt
Tally TransAm is offline   Reply With Quote
Old 11-24-2011, 07:46 PM   #3
TECH Apprentice
Thread Starter
iTrader: (22)
 
Join Date: Jun 2010
Location: Clewiston, FL 33440
Posts: 374
Default

New battery new starter
ISMELLRICE is offline   Reply With Quote
Reply


Tags
ls1, problem, starter, tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: