LS6 no oil pressure - Page 2 - LS1TECH - Camaro and Firebird Forum Discussion



Generation III Internal Engine 1997-2006 LS1 | LS6
Sponsored by:
Sponsored by:

LS6 no oil pressure

Reply
 
Thread Tools Search this Thread
Old 03-13-2017, 09:56 PM   #21
TECH Addict
iTrader: (15)
 
Mercier's Avatar
 
Join Date: Jun 2014
Location: Baton Rouge, LA
Posts: 2,382
Default

Hadn't seen that particular video before. I thought it was the pitch for their oil priming system(visible on top of the engine in the first scene) but then it wasn't. That's a good idea. I was referring to pressure-filling through the engine, but that may not be necessary.
Mercier is offline   Reply With Quote
Old 03-17-2017, 05:36 PM   #22
On The Tree
Thread Starter
iTrader: (3)
 
Join Date: Dec 2008
Location: Houston
Posts: 110
Default

New pump in, pinned the crank, installed front cover and balancer, turned the motor over with the starter and had oil pressure on my mechanical gauge after ~10 seconds of cranking. Time for reassembly. Hopefully rest of the process is smooth sailling.
onspeed is offline   Reply With Quote
Old 03-18-2017, 02:58 AM   #23
TECH Addict
iTrader: (15)
 
Mercier's Avatar
 
Join Date: Jun 2014
Location: Baton Rouge, LA
Posts: 2,382
Default

Congrats; nice that it was fairly simple...even if it still required a lot of work. How much pressure did you achieve just with the starter?
Mercier is offline   Reply With Quote
Old 03-18-2017, 08:50 AM   #24
On The Tree
Thread Starter
iTrader: (3)
 
Join Date: Dec 2008
Location: Houston
Posts: 110
Default

40+psi with a small leak on the gauge fitting. I didn't bother to see how high it would go. I fired the car really briefly last night and it was around 60psi cold idle.
onspeed is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil pressure LOW at high temps LSGunZ28 Generation IV Internal Engine 40 09-14-2017 05:54 PM
Low Oil Pressure in my Daily Driver--Please Help! 68SS98Z28 Generation III Internal Engine 25 04-18-2016 06:22 AM
LQ4 knocking after rebuild. JC316 Generation III Internal Engine 5 01-02-2016 04:50 PM
first drive: things went great, then oil psi issues Ryanbgb22 Forced Induction 10 12-26-2015 05:28 PM
Very low oil pressure. JC316 Generation III Internal Engine 11 11-29-2015 12:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:35 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: